summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-11-29 22:51:51 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-11-29 22:51:51 +0000
commit7eb673483ff4a81349e68e0b20fa0a2c083aeaec (patch)
treeac60b5e5bbe8d67e15c433eedd325220085674dd /games-arcade/sdl-sopwith/sdl-sopwith-1.7.1.ebuild
parentinitial commit (bug 34723) (diff)
downloadgentoo-2-7eb673483ff4a81349e68e0b20fa0a2c083aeaec.tar.gz
gentoo-2-7eb673483ff4a81349e68e0b20fa0a2c083aeaec.tar.bz2
gentoo-2-7eb673483ff4a81349e68e0b20fa0a2c083aeaec.zip
initial commit (bug 34723)
Diffstat (limited to 'games-arcade/sdl-sopwith/sdl-sopwith-1.7.1.ebuild')
-rw-r--r--games-arcade/sdl-sopwith/sdl-sopwith-1.7.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/games-arcade/sdl-sopwith/sdl-sopwith-1.7.1.ebuild b/games-arcade/sdl-sopwith/sdl-sopwith-1.7.1.ebuild
new file mode 100644
index 000000000000..e62910a44864
--- /dev/null
+++ b/games-arcade/sdl-sopwith/sdl-sopwith-1.7.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdl-sopwith/sdl-sopwith-1.7.1.ebuild,v 1.1 2003/11/29 22:51:50 mr_bones_ Exp $
+
+inherit games
+
+MY_P="${P/-/_}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Port of the classic Sopwith game using LibSDL"
+HOMEPAGE="http://sdl-sopwith.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+KEYWORDS="x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=media-libs/libsdl-1.1.3
+ dev-libs/atk
+ x11-libs/pango
+ >=x11-libs/gtk+-2
+ >=dev-libs/glib-2
+ dev-util/pkgconfig
+ media-libs/gdk-pixbuf
+ >=media-libs/freetype-2"
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog FAQ NEWS README TODO doc/*txt || die "dodoc failed"
+ rm -rf "${D}/usr/games/share/"
+ prepgamesdirs
+}