summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2015-01-04 15:03:11 +0000
committerAlfredo Tupone <tupone@gentoo.org>2015-01-04 15:03:11 +0000
commit3d0c9671961c31e7aa3c396358563a77f8835431 (patch)
treee160752d281c15ab56fff3375e735983c8e4a28b /games-arcade
parentCleanup. (diff)
downloadgentoo-2-3d0c9671961c31e7aa3c396358563a77f8835431.tar.gz
gentoo-2-3d0c9671961c31e7aa3c396358563a77f8835431.tar.bz2
gentoo-2-3d0c9671961c31e7aa3c396358563a77f8835431.zip
EAPI 5
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0145142D)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/gav/ChangeLog7
-rw-r--r--games-arcade/gav/gav-0.9.0.ebuild19
2 files changed, 15 insertions, 11 deletions
diff --git a/games-arcade/gav/ChangeLog b/games-arcade/gav/ChangeLog
index 1a3dd40973c6..1cde009b629e 100644
--- a/games-arcade/gav/ChangeLog
+++ b/games-arcade/gav/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-arcade/gav
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/gav/ChangeLog,v 1.15 2010/10/12 13:16:59 tupone Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/gav/ChangeLog,v 1.16 2015/01/04 15:03:11 tupone Exp $
+
+ 04 Jan 2015; Tupone Alfredo <tupone@gentoo.org> gav-0.9.0.ebuild:
+ EAPI 5
12 Oct 2010; Tupone Alfredo <tupone@gentoo.org> gav-0.9.0.ebuild,
+files/gav-0.9.0-ldflags.patch:
diff --git a/games-arcade/gav/gav-0.9.0.ebuild b/games-arcade/gav/gav-0.9.0.ebuild
index c02654c8a05a..7ef1e9adddda 100644
--- a/games-arcade/gav/gav-0.9.0.ebuild
+++ b/games-arcade/gav/gav-0.9.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/gav/gav-0.9.0.ebuild,v 1.5 2010/10/12 15:54:35 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/gav/gav-0.9.0.ebuild,v 1.6 2015/01/04 15:03:11 tupone Exp $
-EAPI=2
+EAPI=5
inherit eutils games
DESCRIPTION="GPL Arcade Volleyball"
@@ -25,6 +25,7 @@ IUSE=""
DEPEND="media-libs/sdl-image[jpeg,png]
media-libs/sdl-net
media-libs/libsdl[joystick,video]"
+RDEPEND="${DEPEND}"
src_prepare() {
local d
@@ -53,17 +54,17 @@ src_prepare() {
src_compile() {
# bug #41530 - doesn't like the hot parallel make action.
- emake -C automa || die "emake failed"
- emake -C menu || die "emake failed"
- emake -C net || die "emake failed"
- emake || die "emake failed"
+ emake -C automa
+ emake -C menu
+ emake -C net
+ emake
}
src_install() {
dodir "${GAMES_BINDIR}"
- emake ROOT="${D}" install || die "emake install failed"
+ emake ROOT="${D}" install
insinto "${GAMES_DATADIR}"/${PN}
- doins -r sounds || die "doins failed"
+ doins -r sounds
dodoc CHANGELOG README
prepgamesdirs
}