summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-04-06 01:33:28 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-04-06 01:33:28 +0000
commit47a64140d0dc4704019d1c9f1a7989e253fa80e9 (patch)
tree62ec717e900c3018515287ca9f9fea20dbfb1a2b /games-emulation/daphne
parentAdding kernel_linux and kernel_FreeBSD to IUSE (diff)
downloadgentoo-2-47a64140d0dc4704019d1c9f1a7989e253fa80e9.tar.gz
gentoo-2-47a64140d0dc4704019d1c9f1a7989e253fa80e9.tar.bz2
gentoo-2-47a64140d0dc4704019d1c9f1a7989e253fa80e9.zip
use games_get_libdir
(Portage version: 2.1.2.3)
Diffstat (limited to 'games-emulation/daphne')
-rw-r--r--games-emulation/daphne/daphne-0.99.6-r2.ebuild83
-rw-r--r--games-emulation/daphne/daphne-0.99.7.ebuild10
-rw-r--r--games-emulation/daphne/files/0.99.6-local-dapinput.patch29
-rw-r--r--games-emulation/daphne/files/daphne-0.99.6-gcc41.patch22
-rw-r--r--games-emulation/daphne/files/digest-daphne-0.99.6-r23
5 files changed, 5 insertions, 142 deletions
diff --git a/games-emulation/daphne/daphne-0.99.6-r2.ebuild b/games-emulation/daphne/daphne-0.99.6-r2.ebuild
deleted file mode 100644
index 7321347619e6..000000000000
--- a/games-emulation/daphne/daphne-0.99.6-r2.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/daphne/daphne-0.99.6-r2.ebuild,v 1.10 2006/08/28 01:53:27 tupone Exp $
-
-inherit eutils flag-o-matic games
-
-DESCRIPTION="Laserdisc Arcade Game Emulator"
-HOMEPAGE="http://www.daphne-emu.com/"
-SRC_URI="http://www.daphne-emu.com/download/${P}-src.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86"
-IUSE=""
-
-RDEPEND="media-libs/libogg
- media-libs/libvorbis
- media-libs/libsdl
- media-libs/sdl-mixer
- sys-libs/zlib"
-
-S=${WORKDIR}/${PN}
-
-src_unpack() {
- unpack ${A}
-
- replace-cpu-flags i686 pentium3 pentium4 i586 #18807
-
- cd "${S}"
- epatch "${FILESDIR}/${P}"-gcc41.patch
- cd src
- sed \
- -e "/^DFLAGS/d" \
- -e "/-fexpensive-optimizations/d " \
- -e "s/\${DFLAGS}/${CFLAGS}/g" \
- Makefile.vars.linux_x86 > Makefile.vars \
- || die "sed failed"
-
- # lets make this guy play nice with our filesystem setup
- sed -i \
- -e "s:pics/:${GAMES_DATADIR}/${PN}/pics/:g" \
- video/video.cpp \
- || die "sed failed"
- sed -i \
- -e "s:roms/:${GAMES_DATADIR}/${PN}/roms/:g" \
- game/game.cpp \
- || die "sed failed"
- sed -i \
- -e "s:sound/:${GAMES_DATADIR}/${PN}/sound/:g" \
- sound/sound.cpp \
- || die "sed failed"
- sed -i \
- -e "s:./lib:${GAMES_LIBDIR}/${PN}/lib:g" \
- io/dll.h \
- || die "sed failed"
- sed -i \
- -e 's:daphne_log.txt:/tmp/daphne_log.txt:g' \
- daphne.cpp daphne.h io/error.cpp \
- || die "sed failed"
- epatch "${FILESDIR}/${PV}-local-dapinput.patch"
-}
-
-src_compile() {
- cd "${S}/src"
- emake || die "src build failed"
- cd "${S}/src/vldp"
- emake -f Makefile.linux || die "vldp build failed"
- cd "${S}/src/vldp2"
- egamesconf || die
- emake -f Makefile.linux || die "vldp2 build failed"
-}
-
-src_install() {
- dogamesbin daphne || die "dogamesbin failed"
- exeinto "${GAMES_LIBDIR}/${PN}"
- doexe libvldp*.so || die "doexe failed"
- dodir "${GAMES_DATADIR}/${PN}"
- cp -rf pics sound roms "${D}/${GAMES_DATADIR}/${PN}/" \
- || die "cp failed"
- dodoc doc/*.{ini,txt}
- dohtml -r doc/*
- prepgamesdirs
-}
diff --git a/games-emulation/daphne/daphne-0.99.7.ebuild b/games-emulation/daphne/daphne-0.99.7.ebuild
index ce11fa4a8e04..245f7419d42a 100644
--- a/games-emulation/daphne/daphne-0.99.7.ebuild
+++ b/games-emulation/daphne/daphne-0.99.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/daphne/daphne-0.99.7.ebuild,v 1.1 2006/12/28 00:13:14 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/daphne/daphne-0.99.7.ebuild,v 1.2 2007/04/06 01:33:28 nyhm Exp $
inherit eutils toolchain-funcs games
@@ -10,7 +10,7 @@ SRC_URI="http://www.daphne-emu.com/download/${P}-src.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="x86"
IUSE=""
DEPEND="media-libs/libogg
@@ -35,7 +35,7 @@ src_unpack() {
sed -i "s:sound/:${GAMES_DATADIR}/${PN}/&:" \
sound/sound.cpp \
|| die "sed sound.cpp failed"
- sed -i "s:./lib:${GAMES_LIBDIR}/${PN}/lib:" \
+ sed -i "s:./lib:$(games_get_libdir)/${PN}/lib:" \
io/dll.h \
|| die "sed dll.h failed"
cp Makefile.vars{.linux_x86,}
@@ -58,7 +58,7 @@ src_compile() {
src_install() {
cd ..
dogamesbin daphne || die "dogamesbin failed"
- exeinto "${GAMES_LIBDIR}"/${PN}
+ exeinto "$(games_get_libdir)"/${PN}
doexe libvldp2.so || die "doexe failed"
insinto "${GAMES_DATADIR}"/${PN}
doins -r pics roms sound || die "doins failed"
diff --git a/games-emulation/daphne/files/0.99.6-local-dapinput.patch b/games-emulation/daphne/files/0.99.6-local-dapinput.patch
deleted file mode 100644
index 9b3c3a413e02..000000000000
--- a/games-emulation/daphne/files/0.99.6-local-dapinput.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/io/input.cpp.orig 2003-11-04 02:51:56.308868080 -0500
-+++ src/io/input.cpp 2003-11-04 02:53:57.283477144 -0500
-@@ -22,6 +22,9 @@
-
- // Handles SDL input functions (low-level keyboard/joystick input)
-
-+#include <unistd.h>
-+#include <sys/stat.h>
-+#include <sys/types.h>
- #include <time.h>
- #include "input.h"
- #include "conout.h"
-@@ -113,6 +116,9 @@
- char strTemp[25] = {0};
- char thisChar = 0;
-
-+ chdir(getenv("HOME"));
-+ mkdir(".daphne", 0700);
-+ chdir(".daphne");
- F = fopen("dapinput.ini", "rt");
-
- // if we opened the file successfully
-@@ -589,4 +595,4 @@
- }
- idle_timer = refresh_ms_time();
- }
--// end edit
-\ No newline at end of file
-+// end edit
diff --git a/games-emulation/daphne/files/daphne-0.99.6-gcc41.patch b/games-emulation/daphne/files/daphne-0.99.6-gcc41.patch
deleted file mode 100644
index b136ebd387f8..000000000000
--- a/games-emulation/daphne/files/daphne-0.99.6-gcc41.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- src/game/game.h.old 2006-08-27 18:45:27.000000000 +0200
-+++ src/game/game.h 2006-08-27 18:45:43.000000000 +0200
-@@ -121,7 +121,7 @@
- int get_video_col_offset();
- SDL_Surface *get_video_overlay(int index); // returns pointer to video overlay specified, or NULL if index is out of range
- SDL_Surface *get_active_video_overlay(); // returns the current active video overlay (that is currently being drawn)
-- SDL_Surface *game::get_finished_video_overlay(); // returns the last complete video overlay (that isn't currently being drawn)
-+ SDL_Surface *get_finished_video_overlay(); // returns the last complete video overlay (that isn't currently being drawn)
- bool is_overlay_size_dynamic(); // returns m_overlay_size_is_dynamic
-
- void enable_cheat();
---- src/ldp-out/pioneer.h.old 2006-08-27 18:47:55.000000000 +0200
-+++ src/ldp-out/pioneer.h 2006-08-27 18:48:12.000000000 +0200
-@@ -45,7 +45,7 @@
- bool pioneer_audio1;
- bool pioneer_audio2;
- bool check_result(Uint32, bool);
-- bool pioneer::getstring(char *, int, Uint32,bool);
-+ bool getstring(char *, int, Uint32,bool);
- void printmodel();
- };
-
diff --git a/games-emulation/daphne/files/digest-daphne-0.99.6-r2 b/games-emulation/daphne/files/digest-daphne-0.99.6-r2
deleted file mode 100644
index 344ba83b7d7b..000000000000
--- a/games-emulation/daphne/files/digest-daphne-0.99.6-r2
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 7602c8c1c7d54f61e23e55fe55b44ffd daphne-0.99.6-src.tar.gz 2685633
-RMD160 b4e7902887e6dad03d9ad0b8f9fc5b4b34ca9166 daphne-0.99.6-src.tar.gz 2685633
-SHA256 ca8e4365d3af7dd484ce14d30eeffafef7947e41956fa12ec7120308ff3658f9 daphne-0.99.6-src.tar.gz 2685633