summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-10-18 07:28:58 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-10-18 07:28:58 +0000
commitd99b733fcac6cb1b0bdb40efc258e6417adb6e63 (patch)
tree769a1dee4e29210a2954e0785e8a56590cb9eecb /games-emulation/dosbox/dosbox-0.60.ebuild
parentversion bump (diff)
downloadgentoo-2-d99b733fcac6cb1b0bdb40efc258e6417adb6e63.tar.gz
gentoo-2-d99b733fcac6cb1b0bdb40efc258e6417adb6e63.tar.bz2
gentoo-2-d99b733fcac6cb1b0bdb40efc258e6417adb6e63.zip
removed the depend on ncurses since we don't use the debugger
Diffstat (limited to 'games-emulation/dosbox/dosbox-0.60.ebuild')
-rw-r--r--games-emulation/dosbox/dosbox-0.60.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/games-emulation/dosbox/dosbox-0.60.ebuild b/games-emulation/dosbox/dosbox-0.60.ebuild
index 0f165c2c98eb..4f6cc7fb2962 100644
--- a/games-emulation/dosbox/dosbox-0.60.ebuild
+++ b/games-emulation/dosbox/dosbox-0.60.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/dosbox-0.60.ebuild,v 1.1 2003/10/16 22:34:23 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/dosbox-0.60.ebuild,v 1.2 2003/10/18 07:28:56 mr_bones_ Exp $
inherit games
@@ -14,12 +14,17 @@ SLOT="0"
IUSE="alsa ncurses png"
-DEPEND="ncurses? ( sys-libs/ncurses )
- png? ( media-libs/libpng sys-libs/zlib )
+DEPEND="png? ( media-libs/libpng sys-libs/zlib )
alsa? ( media-libs/alsa-lib )
media-libs/sdl-net
>=media-libs/libsdl-1.2.0"
+src_compile() {
+ egamesconf \
+ `use_enable alsa alsatest` || die
+ emake || die "emake failed"
+}
+
src_install() {
make DESTDIR=${D} install || die "make install failed"
dodoc AUTHORS ChangeLog INSTALL NEWS README THANKS