summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2004-03-21 20:17:28 +0000
committerDavid Holm <dholm@gentoo.org>2004-03-21 20:17:28 +0000
commitd7ca55ca3c40d4c43d8e0aedf0c683051ac7c297 (patch)
tree13a37d53f5a4b4db4ce7785bc99876188dd8debd /games-emulation/fbzx/fbzx-1.4.ebuild
parentMassive ebuild cleanup. (Manifest recommit) (diff)
downloadgentoo-2-d7ca55ca3c40d4c43d8e0aedf0c683051ac7c297.tar.gz
gentoo-2-d7ca55ca3c40d4c43d8e0aedf0c683051ac7c297.tar.bz2
gentoo-2-d7ca55ca3c40d4c43d8e0aedf0c683051ac7c297.zip
Initial import
Diffstat (limited to 'games-emulation/fbzx/fbzx-1.4.ebuild')
-rw-r--r--games-emulation/fbzx/fbzx-1.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/games-emulation/fbzx/fbzx-1.4.ebuild b/games-emulation/fbzx/fbzx-1.4.ebuild
new file mode 100644
index 000000000000..085e73877a18
--- /dev/null
+++ b/games-emulation/fbzx/fbzx-1.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fbzx/fbzx-1.4.ebuild,v 1.1 2004/03/21 20:17:28 dholm Exp $
+
+S="${WORKDIR}/${PN}"
+DESCRIPTION="FBZX is a Sinclair Spectrum emulator, designed to work at full screen using the FrameBuffer."
+SRC_URI="http://www.rastersoft.com/programas/fbzx/${PN}14.tar.gz"
+HOMEPAGE="http://www.rastersoft.com/fbzx.html"
+LICENSE="GPL-2"
+DEPEND="media-libs/libsdl"
+KEYWORDS="~ppc"
+SLOT="0"
+IUSE="sdl"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ sed -i -e "s|share/spectrum|share/fbzx|g" emulator.c
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install () {
+ dobin fbzx
+
+ dodir /usr/share/fbzx
+ insinto /usr/share/fbzx/roms
+ doins roms/*
+
+ dodoc COPYING FAQ INSTALL README TODO
+}