summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-01-05 02:53:24 +0000
committerMike Frysinger <vapier@gentoo.org>2004-01-05 02:53:24 +0000
commitaa79392bba18fb81e9b3193c8c30792826117c5c (patch)
treee6a1dd7efab9d5adc4a3b4e06504f7e4f40bbe44 /games-emulation
parentold (diff)
downloadgentoo-2-aa79392bba18fb81e9b3193c8c30792826117c5c.tar.gz
gentoo-2-aa79392bba18fb81e9b3193c8c30792826117c5c.tar.bz2
gentoo-2-aa79392bba18fb81e9b3193c8c30792826117c5c.zip
games.eclass support
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/zsnes/ChangeLog9
-rw-r--r--games-emulation/zsnes/zsnes-1.36.ebuild32
2 files changed, 20 insertions, 21 deletions
diff --git a/games-emulation/zsnes/ChangeLog b/games-emulation/zsnes/ChangeLog
index 4a1d206251d7..77b8e0d436f0 100644
--- a/games-emulation/zsnes/ChangeLog
+++ b/games-emulation/zsnes/ChangeLog
@@ -1,14 +1,17 @@
# ChangeLog for games-emulation/zsnes
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/ChangeLog,v 1.2 2003/09/10 15:59:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/ChangeLog,v 1.3 2004/01/05 02:53:24 vapier Exp $
+
+*zsnes-1.36 (21 Jul 2002)
+
+ 04 Jan 2004; Mike Frysinger <vapier@gentoo.org> :
+ Touchups + games.eclass support.
10 Jul 2003; Michael Sterrett <msterret@gentoo.org> zsnes-1.36.ebuild:
use emake; use use_with
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
-*zsnes-1.36 (21 Jul 2002)
-
03 Nov 2002; Mike Frysinger <vapier@gentoo.org> :
Added pkg_setup fix for #9446.
diff --git a/games-emulation/zsnes/zsnes-1.36.ebuild b/games-emulation/zsnes/zsnes-1.36.ebuild
index 74817af92072..2ac3cb9f657a 100644
--- a/games-emulation/zsnes/zsnes-1.36.ebuild
+++ b/games-emulation/zsnes/zsnes-1.36.ebuild
@@ -1,15 +1,17 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/zsnes-1.36.ebuild,v 1.1 2003/09/09 16:26:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/zsnes-1.36.ebuild,v 1.2 2004/01/05 02:53:24 vapier Exp $
+
+inherit games
DESCRIPTION="SNES (Super Nintendo) emulator that uses x86 assembly"
-SRC_URI="mirror://sourceforge/zsnes/zsnes${PV//./}src.tar.gz"
HOMEPAGE="http://www.zsnes.com/"
+SRC_URI="mirror://sourceforge/zsnes/zsnes${PV//./}src.tar.gz"
LICENSE="GPL-2"
-KEYWORDS="x86 -ppc -sparc"
-IUSE="opengl"
SLOT="0"
+KEYWORDS="-* x86"
+IUSE="opengl"
RDEPEND="opengl? ( virtual/opengl )
virtual/x11
@@ -19,24 +21,18 @@ RDEPEND="opengl? ( virtual/opengl )
DEPEND="${RDEPEND}
>=dev-lang/nasm-0.98"
-pkg_setup() {
- # xfree should not install these, remove until the fixed
- # xfree is in main use.
- rm -f /usr/X11R6/include/{zconf.h,zlib.h}
-}
-
src_compile() {
- # Don't attempt to introduce $CFLAGS usage, docs say result will be slower.
- cd ${S}/src
- econf `use_with opengl`
+ # Do NOT introduce custom ${CFLAGS}.
+ # Current choices are the optimal ones
+ cd src
+ egamesconf `use_with opengl` || die
emake || die "emake failed"
}
src_install() {
- cd ${S}/src
- into /usr
- dobin zsnes
- doman linux/zsnes.1
- cd ${S}
+ dogamesbin src/zsnes
+ newman src/linux/zsnes.1 zsnes.6
+ cd ..
dodoc *.txt linux/*
+ prepgamesdirs
}