summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-06-22 02:06:59 +0000
committerMike Frysinger <vapier@gentoo.org>2007-06-22 02:06:59 +0000
commit03db60ed2261d8701d01e6b17e1b075704c465de (patch)
tree464278b404d68cfc70a25dddf28bba8a9ba4861b /games-fps/quake3
parentliboil bump (diff)
downloadgentoo-2-03db60ed2261d8701d01e6b17e1b075704c465de.tar.gz
gentoo-2-03db60ed2261d8701d01e6b17e1b075704c465de.tar.bz2
gentoo-2-03db60ed2261d8701d01e6b17e1b075704c465de.zip
Fix by nyhm for gcc-4.2 issues #179649 by Philipp.
(Portage version: 2.1.3_rc3)
Diffstat (limited to 'games-fps/quake3')
-rw-r--r--games-fps/quake3/ChangeLog6
-rw-r--r--games-fps/quake3/files/quake3-1.34_rc3-gcc42.patch22
-rw-r--r--games-fps/quake3/quake3-1.34_rc3.ebuild3
3 files changed, 29 insertions, 2 deletions
diff --git a/games-fps/quake3/ChangeLog b/games-fps/quake3/ChangeLog
index 05e21a52738d..77490a7dc3ab 100644
--- a/games-fps/quake3/ChangeLog
+++ b/games-fps/quake3/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-fps/quake3
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/ChangeLog,v 1.46 2007/01/30 22:20:29 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/ChangeLog,v 1.47 2007/06/22 02:06:59 vapier Exp $
+
+ 22 Jun 2007; Mike Frysinger <vapier@gentoo.org>
+ +files/quake3-1.34_rc3-gcc42.patch, quake3-1.34_rc3.ebuild:
+ Fix by nyhm for gcc-4.2 issues #179649 by Philipp.
30 Jan 2007; Chris Gianelloni <wolf31o2@gentoo.org>
-quake3-1.34_rc2.ebuild, quake3-1.34_rc3.ebuild, quake3-9999.ebuild:
diff --git a/games-fps/quake3/files/quake3-1.34_rc3-gcc42.patch b/games-fps/quake3/files/quake3-1.34_rc3-gcc42.patch
new file mode 100644
index 000000000000..d62abcaf480a
--- /dev/null
+++ b/games-fps/quake3/files/quake3-1.34_rc3-gcc42.patch
@@ -0,0 +1,22 @@
+Index: code/tools/asm/cmdlib.c
+===================================================================
+--- code/tools/asm/cmdlib.c (revision 1098)
++++ code/tools/asm/cmdlib.c (revision 1099)
+@@ -312,7 +312,7 @@ char *ExpandArg (const char *path)
+ char *ExpandPath (const char *path)
+ {
+ static char full[1024];
+- if (!qdir)
++ if (!qdir[0])
+ Error ("ExpandPath called without qdir set");
+ if (path[0] == '/' || path[0] == '\\' || path[1] == ':') {
+ strcpy( full, path );
+@@ -325,7 +325,7 @@ char *ExpandPath (const char *path)
+ char *ExpandGamePath (const char *path)
+ {
+ static char full[1024];
+- if (!qdir)
++ if (!qdir[0])
+ Error ("ExpandGamePath called without qdir set");
+ if (path[0] == '/' || path[0] == '\\' || path[1] == ':') {
+ strcpy( full, path );
diff --git a/games-fps/quake3/quake3-1.34_rc3.ebuild b/games-fps/quake3/quake3-1.34_rc3.ebuild
index d231d3b9a7ca..0f4febeaad01 100644
--- a/games-fps/quake3/quake3-1.34_rc3.ebuild
+++ b/games-fps/quake3/quake3-1.34_rc3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-1.34_rc3.ebuild,v 1.6 2007/04/09 18:07:58 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-1.34_rc3.ebuild,v 1.7 2007/06/22 02:06:59 vapier Exp $
# quake3-9999 -> latest svn
# quake3-9999.REV -> use svn REV
@@ -54,6 +54,7 @@ src_unpack() {
else
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc42.patch
fi
sed -i \
-e '/INSTALL/s: -s : :' \