summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2012-04-06 19:23:15 +0000
committerAlfredo Tupone <tupone@gentoo.org>2012-04-06 19:23:15 +0000
commitbd6f89e5a34bbc32028c14e9553daa0afba11622 (patch)
treee72cccb4ddbaa771c6f33d6156298155fa8f71d0 /games-fps
parentStable for amd64, wrt bug #410871 (diff)
downloadgentoo-2-bd6f89e5a34bbc32028c14e9553daa0afba11622.tar.gz
gentoo-2-bd6f89e5a34bbc32028c14e9553daa0afba11622.tar.bz2
gentoo-2-bd6f89e5a34bbc32028c14e9553daa0afba11622.zip
Fix x11 mouse. Patch from bug #358955
(Portage version: 2.1.10.56/cvs/Linux i686)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/quake2-icculus/ChangeLog7
-rw-r--r--games-fps/quake2-icculus/files/quake2-icculus-0.16.1-x11_mouse.patch13
-rw-r--r--games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild3
3 files changed, 21 insertions, 2 deletions
diff --git a/games-fps/quake2-icculus/ChangeLog b/games-fps/quake2-icculus/ChangeLog
index f1dbe3f0f144..e063487076a2 100644
--- a/games-fps/quake2-icculus/ChangeLog
+++ b/games-fps/quake2-icculus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-fps/quake2-icculus
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/ChangeLog,v 1.45 2012/04/01 20:04:46 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/ChangeLog,v 1.46 2012/04/06 19:23:15 tupone Exp $
+
+ 06 Apr 2012; Tupone Alfredo <tupone@gentoo.org>
+ quake2-icculus-0.16.1-r1.ebuild,
+ +files/quake2-icculus-0.16.1-x11_mouse.patch:
+ Fix x11 mouse. Patch from bug #358955 by ocrbj
01 Apr 2012; Tupone Alfredo <tupone@gentoo.org>
quake2-icculus-0.16.1-r1.ebuild, +files/quake2-icculus-0.16.1-x11_soft.patch:
diff --git a/games-fps/quake2-icculus/files/quake2-icculus-0.16.1-x11_mouse.patch b/games-fps/quake2-icculus/files/quake2-icculus-0.16.1-x11_mouse.patch
new file mode 100644
index 000000000000..b4a7dcc2eb94
--- /dev/null
+++ b/games-fps/quake2-icculus/files/quake2-icculus-0.16.1-x11_mouse.patch
@@ -0,0 +1,13 @@
+--- src/linux/rw_x11.c.old 2012-04-06 20:51:11.545642465 +0200
++++ src/linux/rw_x11.c 2012-04-06 20:55:48.159425787 +0200
+@@ -989,8 +989,8 @@
+ }
+ else
+ {
+- mx -= ((int)event.xmotion.x + mwx)*2;
+- my -= ((int)event.xmotion.y + mwy)*2;
++ mx += ((int)event.xmotion.x - mwx)*2;
++ my += ((int)event.xmotion.y - mwy)*2;
+ mwx = event.xmotion.x;
+ mwy = event.xmotion.y;
+
diff --git a/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild b/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild
index e037424665a9..34272db26c35 100644
--- a/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild
+++ b/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild,v 1.26 2012/04/01 20:04:46 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild,v 1.27 2012/04/06 19:23:15 tupone Exp $
EAPI=2
inherit eutils toolchain-funcs games
@@ -82,6 +82,7 @@ src_prepare() {
"${FILESDIR}"/${P}-no-asm-io.patch \
"${FILESDIR}"/${P}-gnusource.patch \
"${FILESDIR}"/${P}-x11_soft.patch \
+ "${FILESDIR}"/${P}-x11_mouse.patch \
"${FILESDIR}"/${P}-alsa.patch
if use xatrix ; then