summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2014-07-03 20:24:21 +0000
committerIan Stakenvicius <axs@gentoo.org>2014-07-03 20:24:21 +0000
commitfda04029fc0c3e0f979c0571113449835967569f (patch)
treeff95db3e944df2d6bee4bce41c452dab4c0f649c /games-fps
parentBackport the multilib support to giflib-4.1.6 to ease stabilization. (diff)
downloadgentoo-2-fda04029fc0c3e0f979c0571113449835967569f.tar.gz
gentoo-2-fda04029fc0c3e0f979c0571113449835967569f.tar.bz2
gentoo-2-fda04029fc0c3e0f979c0571113449835967569f.zip
bumped EAPI to 5; converted deps to gx86-multilib
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/avp/ChangeLog10
-rw-r--r--games-fps/avp/avp-20070130-r2.ebuild54
2 files changed, 62 insertions, 2 deletions
diff --git a/games-fps/avp/ChangeLog b/games-fps/avp/ChangeLog
index c10b1a684dda..c9c951104d82 100644
--- a/games-fps/avp/ChangeLog
+++ b/games-fps/avp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/avp
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/avp/ChangeLog,v 1.13 2012/05/03 03:23:09 jdhore Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/avp/ChangeLog,v 1.14 2014/07/03 20:24:21 axs Exp $
+
+*avp-20070130-r2 (03 Jul 2014)
+
+ 03 Jul 2014; Ian Stakenvicius (_AxS_) <axs@gentoo.org>
+ +avp-20070130-r2.ebuild:
+ bumped EAPI to 5; converted deps to gx86-multilib
03 May 2012; Jeff Horelick <jdhore@gentoo.org> avp-20070130-r1.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/games-fps/avp/avp-20070130-r2.ebuild b/games-fps/avp/avp-20070130-r2.ebuild
new file mode 100644
index 000000000000..d51f3967e725
--- /dev/null
+++ b/games-fps/avp/avp-20070130-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/avp/avp-20070130-r2.ebuild,v 1.1 2014/07/03 20:24:21 axs Exp $
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Linux port of Aliens vs Predator"
+HOMEPAGE="http://www.icculus.org/avp/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="AvP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="|| (
+ (
+ media-libs/openal[abi_x86_32(-)]
+ media-libs/libsdl[video,joystick,opengl,abi_x86_32(-)]
+ )
+ ( app-emulation/emul-linux-x86-sdl[-abi_x86_32(-)] )
+)"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gcc42.patch \
+ "${FILESDIR}"/${P}-glibc2.10.patch
+ sed -i \
+ -e '/^CC /s:=:?=:' \
+ -e '/^CXX /s:=:?=:' \
+ -e "/^CFLAGS/s/-g.*/${CFLAGS}/" \
+ -e "/^LDLIBS/s/$/${LDFLAGS}/" \
+ -e "s:openal-config:pkg-config openal:" \
+ Makefile \
+ || die "sed failed"
+}
+
+src_install() {
+ newgamesbin AvP.bin AvP || die "newgamesbin failed"
+ dodoc README TODO
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "please follow the instructions in"
+ elog "/usr/share/doc/${PF}"
+ elog "to install the rest of the game"
+}