summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2005-11-30 09:38:30 +0000
committerChris White <chriswhite@gentoo.org>2005-11-30 09:38:30 +0000
commit67c8b060271109f68d8b0a44de61d297ddfbe2e7 (patch)
tree42ce8164da9dd6d55caa82dfe6832b4a2a0a6ad5 /games-kids/gcompris/gcompris-6.1.ebuild
parent*** empty log message *** (diff)
downloadgentoo-2-67c8b060271109f68d8b0a44de61d297ddfbe2e7.tar.gz
gentoo-2-67c8b060271109f68d8b0a44de61d297ddfbe2e7.tar.bz2
gentoo-2-67c8b060271109f68d8b0a44de61d297ddfbe2e7.zip
Diffstat (limited to 'games-kids/gcompris/gcompris-6.1.ebuild')
-rw-r--r--games-kids/gcompris/gcompris-6.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-kids/gcompris/gcompris-6.1.ebuild b/games-kids/gcompris/gcompris-6.1.ebuild
new file mode 100644
index 000000000000..2420b32c5510
--- /dev/null
+++ b/games-kids/gcompris/gcompris-6.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-kids/gcompris/gcompris-6.1.ebuild,v 1.1 2004/08/17 02:41:35 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="full featured educational application for children from 3 to 10"
+HOMEPAGE="http://ofset.sourceforge.net/gcompris/"
+SRC_URI="mirror://sourceforge/gcompris/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="python editor"
+
+DEPEND="virtual/x11
+ >=dev-libs/glib-2.0
+ =x11-libs/gtk+-2*
+ >=gnome-base/libgnomecanvas-2.0.2
+ >=dev-python/gnome-python-2.0
+ media-libs/sdl-mixer
+ media-libs/libsdl
+ dev-libs/libxml2
+ dev-libs/popt
+ games-board/gnuchess
+ sys-apps/texinfo
+ app-text/texi2html
+ python? ( dev-lang/python )
+ editor? (
+ >=gnome-base/libgnome-1.96.0
+ >=gnome-base/libgnomeui-1.96.0
+ )"
+
+src_compile() {
+ export GNUCHESS="${GAMES_BINDIR}/gnuchess"
+ econf \
+ `use_with python python /usr/bin/python` \
+ `use_with editor` \
+ || die
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}