summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-11-08 06:59:19 +0000
committerMike Frysinger <vapier@gentoo.org>2003-11-08 06:59:19 +0000
commit9827360ee91320ffbde5b268aa093f0306aa9630 (patch)
tree928d881c132ecfc3e26e7ccd43e27cd8016acfef /games-kids/tuxmathscrabble/tuxmathscrabble-2.4a.ebuild
parentwont work w/out ipv6 #32860 (diff)
downloadgentoo-2-9827360ee91320ffbde5b268aa093f0306aa9630.tar.gz
gentoo-2-9827360ee91320ffbde5b268aa093f0306aa9630.tar.bz2
gentoo-2-9827360ee91320ffbde5b268aa093f0306aa9630.zip
ver bump #32873
Diffstat (limited to 'games-kids/tuxmathscrabble/tuxmathscrabble-2.4a.ebuild')
-rw-r--r--games-kids/tuxmathscrabble/tuxmathscrabble-2.4a.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-kids/tuxmathscrabble/tuxmathscrabble-2.4a.ebuild b/games-kids/tuxmathscrabble/tuxmathscrabble-2.4a.ebuild
new file mode 100644
index 000000000000..1b52e9c681ee
--- /dev/null
+++ b/games-kids/tuxmathscrabble/tuxmathscrabble-2.4a.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-kids/tuxmathscrabble/tuxmathscrabble-2.4a.ebuild,v 1.1 2003/11/08 06:59:19 vapier Exp $
+
+inherit games distutils
+
+MY_P=TuxMathScrabble_v${PV//./_}
+DESCRIPTION="math-version of the popular board game for children 4-10"
+HOMEPAGE="http://www.asymptopia.org/"
+SRC_URI="mirror://sourceforge/tuxmathscrabble/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND=""
+RDEPEND="dev-lang/python
+ dev-python/pygame
+ media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-fix-setup.patch
+ sed -i 's:/usr/local/bin/python:/usr/bin/python:' tuxmathscrabble.py
+}
+
+src_install() {
+ DOCS="AUTHOR CHANGES VERSION"
+ distutils_src_install
+ newgamesbin tuxmathscrabble.py tuxmathscrabble
+ prepgamesdirs
+}