summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2005-11-30 09:54:41 +0000
committerChris White <chriswhite@gentoo.org>2005-11-30 09:54:41 +0000
commitd5bde511b34d1dc342f01cfedd19c4a1f6198797 (patch)
tree7a5651dbb086e5db9d13ef5d366044fd1b0d326c /games-misc/cowsay
parent(no commit message) (diff)
downloadgentoo-2-d5bde511b34d1dc342f01cfedd19c4a1f6198797.tar.gz
gentoo-2-d5bde511b34d1dc342f01cfedd19c4a1f6198797.tar.bz2
gentoo-2-d5bde511b34d1dc342f01cfedd19c4a1f6198797.zip
*** empty log message ***
Diffstat (limited to 'games-misc/cowsay')
-rw-r--r--games-misc/cowsay/ChangeLog32
-rw-r--r--games-misc/cowsay/Manifest6
-rw-r--r--games-misc/cowsay/cowsay-3.03.ebuild47
-rw-r--r--games-misc/cowsay/files/cowsay.bashcomp2
4 files changed, 60 insertions, 27 deletions
diff --git a/games-misc/cowsay/ChangeLog b/games-misc/cowsay/ChangeLog
index ce6cbffda10d..7e3de78252a9 100644
--- a/games-misc/cowsay/ChangeLog
+++ b/games-misc/cowsay/ChangeLog
@@ -1,6 +1,32 @@
-# ChangeLog for app-games/cowsay
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/cowsay/ChangeLog,v 1.1 2003/09/10 18:14:04 vapier Exp $
+# ChangeLog for games-misc/cowsay
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/cowsay/ChangeLog,v 1.1.1.1 2005/11/30 09:50:03 chriswhite Exp $
+
+ 13 Jul 2005; Stephen Bennett <spb@gentoo.org> cowsay-3.03.ebuild:
+ mips stable
+
+ 01 Jun 2005; Stephen Bennett <spb@gentoo.org> cowsay-3.03.ebuild:
+ ~mips keywords
+
+ 06 Feb 2005; Aaron Walker <ka0ttic@gentoo.org> +files/cowsay.bashcomp,
+ cowsay-3.03.ebuild:
+ Added cowsay command-line completion.
+
+ 01 Feb 2005; Kito <kito@gentoo.org> cowsay-3.03.ebuild:
+ added ~ppc-macos
+
+ 15 Apr 2004; Guy Martin <gmsoft@gentoo.org> cowsay-3.03.ebuild:
+ Marked stable on hppa.
+
+ 20 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> cowsay-3.03.ebuild:
+ add STANDARD_HELP_VERSION=1 to the code to fix bug #45238; stop using the
+ provided install.sh script since it doesn't really make src_install cleaner.
+
+ 07 Jan 2004; Jon Portnoy <avenj@gentoo.org> cowsay-3.03.ebuild :
+ AMD64 keywords.
+
+ 23 Sep 2003; Todd Sunderlin <todd@gentoo.org> cowsay-3.03.ebuild:
+ marked stable for sparc
06 Jun 2003; <msterret@gentoo.org> cowsay-3.03.ebuild:
DEPEND on sed >=4
diff --git a/games-misc/cowsay/Manifest b/games-misc/cowsay/Manifest
index 326e897762ca..7b191fa2a79e 100644
--- a/games-misc/cowsay/Manifest
+++ b/games-misc/cowsay/Manifest
@@ -1,3 +1,5 @@
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 0dade6a9c04892b6d21c01385dd539cf cowsay-3.03.ebuild 1208
+MD5 f9f6b967f835671af1bcb534f0d1a155 ChangeLog 1444
MD5 2e5e04a0c30b4e7e3dab7781049e7d99 files/digest-cowsay-3.03 62
-MD5 50a6ba8e53381d13d50cd169618568ac cowsay-3.03.ebuild 1083
-MD5 8c41be354c88daa3a3fff35d21e7f677 ChangeLog 568
+MD5 2744086053e49bfd0592c2341dbb8e41 files/cowsay.bashcomp 1095
diff --git a/games-misc/cowsay/cowsay-3.03.ebuild b/games-misc/cowsay/cowsay-3.03.ebuild
index aeca89c71320..a64461d9a2d9 100644
--- a/games-misc/cowsay/cowsay-3.03.ebuild
+++ b/games-misc/cowsay/cowsay-3.03.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/cowsay/cowsay-3.03.ebuild,v 1.1 2003/09/10 18:14:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/cowsay/cowsay-3.03.ebuild,v 1.1.1.1 2005/11/30 09:50:03 chriswhite Exp $
+
+inherit bash-completion
DESCRIPTION="configurable talking ASCII cow (and other characters)"
HOMEPAGE="http://www.nog.net/~tony/warez/cowsay.shtml"
@@ -8,29 +10,32 @@ SRC_URI="http://www.nog.net/~tony/warez/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc"
+KEYWORDS="amd64 hppa mips ppc ~ppc-macos sparc x86"
+IUSE=""
DEPEND=">=sys-apps/sed-4"
RDEPEND=">=dev-lang/perl-5"
-src_install() {
- ./install.sh ${D}/usr || "install problem"
-
- dodir /usr/share/${P}
- mv ${D}/usr/share/cows ${D}/usr/share/${P}
-
- cd ${D}/usr/bin
- sed -i "s|${D}/usr/share/cows|/usr/share/${P}/cows|g" cowsay || \
- die "sed cowsay failed"
- chmod 755 cowsay
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e '1 c\#!/usr/bin/perl'\
+ -e 's/\$version/\$VERSION/g'\
+ -e "s:%PREFIX%/share/cows:/usr/share/${P}/cows:" \
+ -e '/getopts/ i\$Getopt::Std::STANDARD_HELP_VERSION=1;' cowsay \
+ || die "sed cowsay failed"
+ sed -i \
+ -e "s|%PREFIX%/share/cows|/usr/share/${P}/cows|" cowsay.1 \
+ || die "sed cowsay.1 failed"
+}
- # Oh what an ugly hack. install.sh installs into /usr/man so just
- # "use that energy" and kill it off after doman is done with it.
- cd ${D}/usr/man/man1
- sed -i "s|${D}/usr/share/cows|/usr/share/${P}/cows|g" cowsay.1
+src_install() {
+ dobin cowsay || die "dobin failed"
doman cowsay.1
- cd ${D}/usr/share/man/man1
- ln -s cowsay.1.gz cowthink.1.gz
- rm -rf ${D}/usr/man
-
+ dosym cowsay /usr/bin/cowthink
+ dosym cowsay.1.gz /usr/share/man/man1/cowthink.1.gz
+ dodir "/usr/share/${P}/cows"
+ cp -r cows "${D}/usr/share/${P}/" || die "cp failed"
+ dobashcompletion ${FILESDIR}/${PN}.bashcomp
}
diff --git a/games-misc/cowsay/files/cowsay.bashcomp b/games-misc/cowsay/files/cowsay.bashcomp
index 94860b240689..7f547bc4c9fb 100644
--- a/games-misc/cowsay/files/cowsay.bashcomp
+++ b/games-misc/cowsay/files/cowsay.bashcomp
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/cowsay/files/cowsay.bashcomp,v 1.1 2005/02/06 14:37:54 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/cowsay/files/cowsay.bashcomp,v 1.1.1.1 2005/11/30 09:50:03 chriswhite Exp $
# bash command-line completion for cowsay
# Author: Aaron Walker <ka0ttic@gentoo.org>