summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-06-29 20:11:51 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-06-29 20:11:51 +0000
commit001c9d8099f92739e01dfb2361017deaba1b3c31 (patch)
tree14f1e1c4163c33b18e4947668df7246a031678ce /games-puzzle/pingus
parentVersion bump (diff)
downloadgentoo-2-001c9d8099f92739e01dfb2361017deaba1b3c31.tar.gz
gentoo-2-001c9d8099f92739e01dfb2361017deaba1b3c31.tar.bz2
gentoo-2-001c9d8099f92739e01dfb2361017deaba1b3c31.zip
use the latest boost
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'games-puzzle/pingus')
-rw-r--r--games-puzzle/pingus/ChangeLog5
-rw-r--r--games-puzzle/pingus/pingus-0.7.6.ebuild22
2 files changed, 24 insertions, 3 deletions
diff --git a/games-puzzle/pingus/ChangeLog b/games-puzzle/pingus/ChangeLog
index a6575d757362..93e71cc13c63 100644
--- a/games-puzzle/pingus/ChangeLog
+++ b/games-puzzle/pingus/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-puzzle/pingus
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/ChangeLog,v 1.40 2012/05/24 18:06:07 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/ChangeLog,v 1.41 2012/06/29 20:11:51 mr_bones_ Exp $
+
+ 29 Jun 2012; Michael Sterrett <mr_bones_@gentoo.org> pingus-0.7.6.ebuild:
+ use the latest boost
24 May 2012; Michael Sterrett <mr_bones_@gentoo.org> pingus-0.7.6.ebuild:
Add strip-flags for bug #396149
diff --git a/games-puzzle/pingus/pingus-0.7.6.ebuild b/games-puzzle/pingus/pingus-0.7.6.ebuild
index 999851092a97..8e725811d6cd 100644
--- a/games-puzzle/pingus/pingus-0.7.6.ebuild
+++ b/games-puzzle/pingus/pingus-0.7.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/pingus-0.7.6.ebuild,v 1.5 2012/05/24 18:06:07 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/pingus-0.7.6.ebuild,v 1.6 2012/06/29 20:11:51 mr_bones_ Exp $
EAPI=2
inherit eutils flag-o-matic scons-utils toolchain-funcs games
@@ -21,8 +21,26 @@ DEPEND="media-libs/libsdl[joystick,opengl?,video]
media-libs/libpng
dev-libs/boost"
-src_compile() {
+src_prepare() {
+ # how do I hate boost? Let me count the ways...
+ local boost_ver=$(best_version ">=dev-libs/boost-1.36")
+
+ boost_ver=${boost_ver/*boost-/}
+ boost_ver=${boost_ver%.*}
+ boost_ver=${boost_ver/./_}
+
+ einfo "Using boost version ${boost_ver}"
+ append-cxxflags \
+ -I/usr/include/boost-${boost_ver}
+ append-ldflags \
+ -L/usr/$(get_libdir)/boost-${boost_ver}
+ export BOOST_INCLUDEDIR="/usr/include/boost-${boost_ver}"
+ export BOOST_LIBRARYDIR="/usr/$(get_libdir)/boost-${boost_ver}"
+
strip-flags
+}
+
+src_compile() {
escons \
CXX="$(tc-getCXX)" \
CCFLAGS="${CXXFLAGS}" \