summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-11 12:22:49 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-11 12:22:49 +0000
commit24cea9be2d2942f1a56de593b1a1455defa581f5 (patch)
treebabf0042eddc7e1e9769bfc4c4e9aafa8e876c06 /games-simulation/senken/senken-0.2.6.ebuild
parentfix dvdr support (diff)
downloadgentoo-2-24cea9be2d2942f1a56de593b1a1455defa581f5.tar.gz
gentoo-2-24cea9be2d2942f1a56de593b1a1455defa581f5.tar.bz2
gentoo-2-24cea9be2d2942f1a56de593b1a1455defa581f5.zip
simulation type games
Diffstat (limited to 'games-simulation/senken/senken-0.2.6.ebuild')
-rw-r--r--games-simulation/senken/senken-0.2.6.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/games-simulation/senken/senken-0.2.6.ebuild b/games-simulation/senken/senken-0.2.6.ebuild
new file mode 100644
index 000000000000..3ce593c3301b
--- /dev/null
+++ b/games-simulation/senken/senken-0.2.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/senken/senken-0.2.6.ebuild,v 1.1 2003/09/11 12:22:49 vapier Exp $
+
+inherit games
+
+DESCRIPTION="city simulation game"
+HOMEPAGE="http://www.contrib.andrew.cmu.edu/~tmartin/senken/"
+SRC_URI="http://www.contrib.andrew.cmu.edu/~tmartin/senken/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="nls"
+
+DEPEND="=x11-libs/gtk+-1*
+ >=sys-apps/sed-4
+ virtual/x11
+ >=media-libs/libsdl-1.2.4
+ media-libs/sdl-image"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S} && \
+ sed -i \
+ -e "s:/usr/local/share:${GAMES_DATADIR}:" \
+ lib/utils.h || die "sed lib/utils.h failed"
+
+}
+src_compile() {
+ egamesconf `use_enable nls` || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+ dodoc AUTHORS README TODO
+
+ cd ${D}/${GAMES_PREFIX}
+ dodir ${GAMES_DATADIR}
+ mv share/senken ${D}/${GAMES_DATADIR}/
+ rm -rf include lib man share
+
+ insinto ${GAMES_DATADIR}/senken/img
+ doins ${S}/img/*.png
+
+ prepgamesdirs
+}