summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2013-10-12 03:27:22 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2013-10-12 03:27:22 +0000
commitb3d8eab7b02914fd766059e5c6cb40883268c5f8 (patch)
tree959f69df687a61c3150de099368e7eecfa9b312f /games-strategy/megaglest
parentkeyword ~arm (diff)
downloadgentoo-2-b3d8eab7b02914fd766059e5c6cb40883268c5f8.tar.gz
gentoo-2-b3d8eab7b02914fd766059e5c6cb40883268c5f8.tar.bz2
gentoo-2-b3d8eab7b02914fd766059e5c6cb40883268c5f8.zip
upstream fix for build failure against gcc-4.7
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'games-strategy/megaglest')
-rw-r--r--games-strategy/megaglest/ChangeLog6
-rw-r--r--games-strategy/megaglest/files/megaglest-3.7.1-gcc47.patch25
-rw-r--r--games-strategy/megaglest/megaglest-3.7.1.ebuild4
3 files changed, 32 insertions, 3 deletions
diff --git a/games-strategy/megaglest/ChangeLog b/games-strategy/megaglest/ChangeLog
index 317bfead9a05..c0eaf2551c49 100644
--- a/games-strategy/megaglest/ChangeLog
+++ b/games-strategy/megaglest/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/megaglest
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/megaglest/ChangeLog,v 1.14 2013/05/18 16:29:37 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/megaglest/ChangeLog,v 1.15 2013/10/12 03:27:22 slyfox Exp $
+
+ 12 Oct 2013; Sergei Trofimovich <slyfox@gentoo.org>
+ +files/megaglest-3.7.1-gcc47.patch, megaglest-3.7.1.ebuild:
+ upstream fix for build failure against gcc-4.7
18 May 2013; Julian Ospald <hasufell@gentoo.org> megaglest-3.6.0.3.ebuild,
megaglest-3.7.0.ebuild, megaglest-3.7.1.ebuild:
diff --git a/games-strategy/megaglest/files/megaglest-3.7.1-gcc47.patch b/games-strategy/megaglest/files/megaglest-3.7.1-gcc47.patch
new file mode 100644
index 000000000000..e8389566b2a6
--- /dev/null
+++ b/games-strategy/megaglest/files/megaglest-3.7.1-gcc47.patch
@@ -0,0 +1,25 @@
+Fix build failure against jpeg-9 (gcc-4.8)
+
+> [ 26%] Building CXX object sources/graphics/JPGReader.cpp.o
+> sources/graphics/JPGReader.cpp: In function 'boolean Shared::Graphics::fill_input_buffer(j_decompress_ptr)':
+> sources/graphics/JPGReader.cpp:40:9: error: cannot convert 'bool' to 'boolean' in return
+> return true;
+> ^
+> source/shared_lib/sources/graphics/JPGReader.cpp:41:1: warning: control reaches end of non-void function [-Wreturn-type]
+> }
+> ^
+> make[2]: *** [sources/graphics/JPGReader.cpp.o] Error 1
+
+Upstream-patch: http://megaglest.svn.sourceforge.net/viewvc/megaglest/trunk/source/shared_lib/sources/graphics/JPGReader.cpp?r1=4082&r2=4095&view=patch
+
+--- source/shared_lib/sources/graphics/JPGReader.cpp
++++ source/shared_lib/sources/graphics/JPGReader.cpp
+@@ -37,7 +37,7 @@
+ }
+ static boolean fill_input_buffer (j_decompress_ptr cinfo) {
+ //it is already filled
+- return true;
++ return boolean(true);
+ }
+ static void skip_input_data (j_decompress_ptr cinfo, long num_bytes) {
+ if (num_bytes > 0) {
diff --git a/games-strategy/megaglest/megaglest-3.7.1.ebuild b/games-strategy/megaglest/megaglest-3.7.1.ebuild
index b0df21221de9..aa5745fc4639 100644
--- a/games-strategy/megaglest/megaglest-3.7.1.ebuild
+++ b/games-strategy/megaglest/megaglest-3.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/megaglest/megaglest-3.7.1.ebuild,v 1.5 2013/05/18 16:29:37 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/megaglest/megaglest-3.7.1.ebuild,v 1.6 2013/10/12 03:27:22 slyfox Exp $
EAPI=4
VIRTUALX_REQUIRED="manual"
@@ -66,7 +66,7 @@ src_prepare() {
need-wxwidgets unicode
fi
- epatch "${FILESDIR}"/${P}-{static-build,as-needed,miniupnpc-1.8}.patch
+ epatch "${FILESDIR}"/${P}-{static-build,as-needed,miniupnpc-1.8,gcc47}.patch
}
src_configure() {