summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2014-10-22 06:45:48 +0000
committerAlfredo Tupone <tupone@gentoo.org>2014-10-22 06:45:48 +0000
commit5262857a46051b5af3b58ef2b2845c9869400800 (patch)
treeed258ea30aad1a9670c400e1cd99ffcc4923326a /games-strategy/ufo-ai
parentVersion bump. (diff)
downloadgentoo-2-5262857a46051b5af3b58ef2b2845c9869400800.tar.gz
gentoo-2-5262857a46051b5af3b58ef2b2845c9869400800.tar.bz2
gentoo-2-5262857a46051b5af3b58ef2b2845c9869400800.zip
Fix build as per Bug #481678
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0145142D)
Diffstat (limited to 'games-strategy/ufo-ai')
-rw-r--r--games-strategy/ufo-ai/ChangeLog6
-rw-r--r--games-strategy/ufo-ai/files/ufo-ai-2.4-anon.patch17
-rw-r--r--games-strategy/ufo-ai/ufo-ai-2.4.ebuild23
3 files changed, 34 insertions, 12 deletions
diff --git a/games-strategy/ufo-ai/ChangeLog b/games-strategy/ufo-ai/ChangeLog
index 5be5f415a3ae..365a95036ef3 100644
--- a/games-strategy/ufo-ai/ChangeLog
+++ b/games-strategy/ufo-ai/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/ufo-ai
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/ufo-ai/ChangeLog,v 1.43 2014/09/09 11:50:08 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/ufo-ai/ChangeLog,v 1.44 2014/10/22 06:45:48 tupone Exp $
+
+ 22 Oct 2014; Alfredo Tupone <tupone@gentoo.org> ufo-ai-2.4.ebuild,
+ +files/ufo-ai-2.4-anon.patch:
+ Fix build as per Bug #481678 by Torsten Kaiser
09 Sep 2014; Samuli Suominen <ssuominen@gentoo.org>
files/ufo-ai-2.4-mathlib.patch:
diff --git a/games-strategy/ufo-ai/files/ufo-ai-2.4-anon.patch b/games-strategy/ufo-ai/files/ufo-ai-2.4-anon.patch
new file mode 100644
index 000000000000..53f07261bb7e
--- /dev/null
+++ b/games-strategy/ufo-ai/files/ufo-ai-2.4-anon.patch
@@ -0,0 +1,17 @@
+--- src/tools/radiant/radiant/camera/CameraSettings.h.old 2014-10-22 08:30:35.690248415 +0200
++++ src/tools/radiant/radiant/camera/CameraSettings.h 2014-10-22 08:31:12.329900302 +0200
+@@ -16,13 +16,13 @@
+ const std::string RKEY_ENABLE_FARCLIP = "user/ui/camera/enableCubicClipping";
+ const std::string RKEY_DRAWMODE = "user/ui/camera/drawMode";
+ const std::string RKEY_SOLID_SELECTION_BOXES = "user/ui/xyview/solidSelectionBoxes";
++}
+
+ enum CameraDrawMode
+ {
+ drawWire, drawSolid, drawTexture
+ };
+
+-}
+ /* greebo: This is the home of all the camera settings. As this class derives
+ * from a RegistryKeyObserver, it can be connected to the according registry keys
+ * and gets notified if any of the observed keys are changed.*/
diff --git a/games-strategy/ufo-ai/ufo-ai-2.4.ebuild b/games-strategy/ufo-ai/ufo-ai-2.4.ebuild
index 12ba09fb526f..f2e38d26177e 100644
--- a/games-strategy/ufo-ai/ufo-ai-2.4.ebuild
+++ b/games-strategy/ufo-ai/ufo-ai-2.4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/ufo-ai/ufo-ai-2.4.ebuild,v 1.5 2014/05/10 05:40:33 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/ufo-ai/ufo-ai-2.4.ebuild,v 1.6 2014/10/22 06:45:48 tupone Exp $
-EAPI=3
+EAPI=5
inherit eutils flag-o-matic games
MY_P=${P/o-a/oa}
@@ -56,6 +56,7 @@ src_prepare() {
epatch \
"${FILESDIR}"/${P}-mathlib.patch \
+ "${FILESDIR}"/${P}-anon.patch \
"${FILESDIR}"/${P}-locale.patch
cp "${DISTDIR}"/1maps.pk3 "${WORKDIR}"/base/ || die
@@ -81,35 +82,35 @@ src_configure() {
}
src_compile() {
- emake || die
- emake lang || die
+ emake
+ emake lang
if use editor; then
- emake uforadiant || die
+ emake uforadiant
fi
}
src_install() {
- newicon src/ports/linux/ufo.png ${PN}.png || die
- dobin ufoded || die
+ newicon src/ports/linux/ufo.png ${PN}.png
+ dobin ufoded
make_desktop_entry ufoded "UFO: Alien Invasion Server" ${PN}
if ! use dedicated; then
- dobin ufo || die
+ dobin ufo
make_desktop_entry ufo "UFO: Alien Invasion" ${PN}
fi
if use editor; then
- dobin ufo2map ufomodel || die
+ dobin ufo2map ufomodel
fi
# install data
insinto "${GAMES_DATADIR}"/${PN/-}
- doins -r base || die
+ doins -r base
rm -rf "${ED}/${GAMES_DATADIR}/${PN/-}/base/game.so"
dogameslib base/game.so
# move translations where they belong
- dodir "${GAMES_DATADIR_BASE}/locale" || die
+ dodir "${GAMES_DATADIR_BASE}/locale"
mv "${ED}/${GAMES_DATADIR}/${PN/-}/base/i18n/"* \
"${ED}/${GAMES_DATADIR_BASE}/locale/" || die
rm -rf "${ED}/${GAMES_DATADIR}/${PN/-}/base/i18n/" || die