summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-06-25 06:05:04 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-06-25 06:05:04 +0000
commit3eee668986c67935a7dd9ed8d5a9ee548d6069af (patch)
tree16dad5887d7eb78395308a2cdd8a9d0094f7e77d /games-strategy
parentVersion bumped. (Manifest recommit) (diff)
downloadgentoo-2-3eee668986c67935a7dd9ed8d5a9ee548d6069af.tar.gz
gentoo-2-3eee668986c67935a7dd9ed8d5a9ee548d6069af.tar.bz2
gentoo-2-3eee668986c67935a7dd9ed8d5a9ee548d6069af.zip
Fix error case; tidy
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/ufo-ai/ChangeLog6
-rw-r--r--games-strategy/ufo-ai/ufo-ai-0.10.040218.ebuild26
2 files changed, 18 insertions, 14 deletions
diff --git a/games-strategy/ufo-ai/ChangeLog b/games-strategy/ufo-ai/ChangeLog
index 8eaf20607c8a..32636aab6981 100644
--- a/games-strategy/ufo-ai/ChangeLog
+++ b/games-strategy/ufo-ai/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/ufo-ai
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/ufo-ai/ChangeLog,v 1.8 2004/06/24 23:29:50 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/ufo-ai/ChangeLog,v 1.9 2004/06/25 06:05:04 mr_bones_ Exp $
+
+ 24 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ ufo-ai-0.10.040218.ebuild:
+ Fix error case; tidy
16 May 2004; Mike Frysinger <vapier@gentoo.org> ufo-ai-0.10.040218.ebuild:
Make sure to filter-flags -fstack-protector #51116 by Alexander Kahl/Peter
diff --git a/games-strategy/ufo-ai/ufo-ai-0.10.040218.ebuild b/games-strategy/ufo-ai/ufo-ai-0.10.040218.ebuild
index 7a7a121006c8..719138dedcad 100644
--- a/games-strategy/ufo-ai/ufo-ai-0.10.040218.ebuild
+++ b/games-strategy/ufo-ai/ufo-ai-0.10.040218.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/ufo-ai/ufo-ai-0.10.040218.ebuild,v 1.10 2004/06/24 23:29:50 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/ufo-ai/ufo-ai-0.10.040218.ebuild,v 1.11 2004/06/25 06:05:04 mr_bones_ Exp $
inherit eutils games flag-o-matic
@@ -20,34 +20,34 @@ DEPEND="virtual/glibc
media-libs/libvorbis
media-libs/libogg"
-S=${WORKDIR}
+S="${WORKDIR}"
src_unpack() {
unpack ${A}
cd source/linux
- epatch ${FILESDIR}/${PV}-Makefile.patch
+ epatch "${FILESDIR}/${PV}-Makefile.patch"
}
src_compile() {
filter-flags -fstack-protector #51116
- cd ${S}/source/linux
+ cd "${S}/source/linux"
make build_release \
OPTCFLAGS="${CFLAGS}" \
|| die "make failed"
}
src_install() {
- dodir ${GAMES_DATADIR}/${PN}
- cp -rf ${S}/ufo/* ${D}${GAMES_DATADIR}/${PN} || die "copying data"
- if [ ${ARCH} == x86 ]; then
+ dodir "${GAMES_DATADIR}/${PN}"
+ cp -rf "${S}/ufo/"* "${D}${GAMES_DATADIR}/${PN}" || die "copying data"
+ if use x86 ; then
ARCH=i386
fi
- exeinto ${GAMES_DATADIR}/${PN}
- doexe ${S}/source/linux/release${ARCH}-glibc/{ref_gl.so,ref_glx.so,ufo} \
- || "doexe ufo"
- exeinto ${GAMES_DATADIR}/${PN}/base
- doexe ${S}/source/linux/release${ARCH}-glibc/game${ARCH}.so \
+ exeinto "${GAMES_DATADIR}/${PN}"
+ doexe "${S}/source/linux/release${ARCH}-glibc/"{ref_gl.so,ref_glx.so,ufo} \
+ || die "doexe ufo"
+ exeinto "${GAMES_DATADIR}/${PN}/base"
+ doexe "${S}/source/linux/release${ARCH}-glibc/game${ARCH}.so" \
|| die "doexe game${ARCH}.so"
- games_make_wrapper ufo-ai ./ufo ${GAMES_DATADIR}/${PN}
+ games_make_wrapper ufo-ai ./ufo "${GAMES_DATADIR}/${PN}"
prepgamesdirs
}