summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2002-02-14 16:34:19 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2002-02-14 16:34:19 +0000
commit83021f2bf8b453caab5f2ff619d1ad2232ed3c90 (patch)
treeb64549a8b6b144b58dac280162a09e91a9a05c3b /gnome-base/bonobo/bonobo-1.0.19-r1.ebuild
parentAdded zlib and libungif dependencies. I know the zlib one is needed; (diff)
downloadgentoo-2-83021f2bf8b453caab5f2ff619d1ad2232ed3c90.tar.gz
gentoo-2-83021f2bf8b453caab5f2ff619d1ad2232ed3c90.tar.bz2
gentoo-2-83021f2bf8b453caab5f2ff619d1ad2232ed3c90.zip
Updated dependencies. Thanks to Edward Muller.
Diffstat (limited to 'gnome-base/bonobo/bonobo-1.0.19-r1.ebuild')
-rw-r--r--gnome-base/bonobo/bonobo-1.0.19-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/gnome-base/bonobo/bonobo-1.0.19-r1.ebuild b/gnome-base/bonobo/bonobo-1.0.19-r1.ebuild
new file mode 100644
index 000000000000..7dabda902bc7
--- /dev/null
+++ b/gnome-base/bonobo/bonobo-1.0.19-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/bonobo/bonobo-1.0.19-r1.ebuild,v 1.1 2002/02/14 16:34:19 g2boojum Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A set of language and system independant CORBA interfaces"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnome.org/"
+
+
+RDEPEND=">=gnome-base/oaf-0.6.8
+ >=gnome-base/ORBit-0.5.13
+ >=gnome-base/gnome-print-0.30"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ sys-devel/perl
+ >=dev-util/intltool-0.11"
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ CFLAGS="${CFLAGS} `gnome-config --cflags print`"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ ${myconf} || die
+
+ make || die # make -j 4 didn't work
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ chmod 644 ${D}/usr/lib/pkgconfig/libefs.pc
+
+ dodoc AUTHORS COPYING* ChangeLog README
+ dodoc NEWS TODO
+}
+
+
+
+
+