summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Brabec <utx@gentoo.org>2003-08-20 15:19:36 +0000
committerStanislav Brabec <utx@gentoo.org>2003-08-20 15:19:36 +0000
commit26114e231e6b6f68be42da40ddbe22fe6cb4546e (patch)
tree36289de9cc289f7db117773903d6f153a4ebe001 /gnome-extra/gucharmap
parentadd metadata (diff)
downloadgentoo-2-26114e231e6b6f68be42da40ddbe22fe6cb4546e.tar.gz
gentoo-2-26114e231e6b6f68be42da40ddbe22fe6cb4546e.tar.bz2
gentoo-2-26114e231e6b6f68be42da40ddbe22fe6cb4546e.zip
added new ebuild
Diffstat (limited to 'gnome-extra/gucharmap')
-rw-r--r--gnome-extra/gucharmap/ChangeLog13
-rw-r--r--gnome-extra/gucharmap/gucharmap-0.8.0.ebuild38
2 files changed, 51 insertions, 0 deletions
diff --git a/gnome-extra/gucharmap/ChangeLog b/gnome-extra/gucharmap/ChangeLog
new file mode 100644
index 000000000000..70b692d11e8f
--- /dev/null
+++ b/gnome-extra/gucharmap/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for gnome-extra/gucharmap
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gucharmap/ChangeLog,v 1.1 2003/08/20 15:19:36 utx Exp $
+
+*gucharmap-0.8.0 (20 Aug 2003)
+
+ 20 Aug 2003; Stanislav Brabec <utx@gentoo.org> gucharmap-0.8.0.ebuild:
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/gnome-extra/gucharmap/gucharmap-0.8.0.ebuild b/gnome-extra/gucharmap/gucharmap-0.8.0.ebuild
new file mode 100644
index 000000000000..66c594676a6c
--- /dev/null
+++ b/gnome-extra/gucharmap/gucharmap-0.8.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gucharmap/gucharmap-0.8.0.ebuild,v 1.1 2003/08/20 15:19:36 utx Exp $
+
+inherit gnome2
+
+IUSE=""
+DESCRIPTION="A featureful Unicode character map."
+HOMEPAGE="http://www.gnome.org/"
+
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~x86"
+
+RDEPEND=">=gnome-base/libgnomeui-2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.22
+ dev-util/pkgconfig"
+
+src_install() {
+ sed -i -e '/\$(GTK_QUERY_IMMODULES)/d' gucharmap/Makefile
+
+ make DESTDIR=${D} \
+ install || die
+
+ dodoc COPYING COPYING.LIB ChangeLog INSTALL README TODO
+}
+
+# DOCS="COPYING COPYING.LIB ChangeLog INSTALL README TODO"
+
+pkg_postinst() {
+ gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
+}
+
+pkg_postrm() {
+ gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
+}