summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-12-30 02:38:30 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-12-30 02:38:30 +0000
commit6ff338cfb752de4d084d3e6088dc154bd49533da (patch)
tree04b2f9e0ed9e13fed04ed48703237d30e493d07f /gnome-extra/nemo
parentVersion bump -- masked until testing in the tree is finished #423393 by Peter... (diff)
downloadgentoo-2-6ff338cfb752de4d084d3e6088dc154bd49533da.tar.gz
gentoo-2-6ff338cfb752de4d084d3e6088dc154bd49533da.tar.bz2
gentoo-2-6ff338cfb752de4d084d3e6088dc154bd49533da.zip
Version bump for bug #440612; thanks to Anton Bolshakov et al.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'gnome-extra/nemo')
-rw-r--r--gnome-extra/nemo/ChangeLog8
-rw-r--r--gnome-extra/nemo/files/nemo-1.1.2-view-toolbar.patch160
-rw-r--r--gnome-extra/nemo/nemo-1.1.2.ebuild90
3 files changed, 257 insertions, 1 deletions
diff --git a/gnome-extra/nemo/ChangeLog b/gnome-extra/nemo/ChangeLog
index ddecdbe618ff..0fb97eb7847e 100644
--- a/gnome-extra/nemo/ChangeLog
+++ b/gnome-extra/nemo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/nemo
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/nemo/ChangeLog,v 1.1 2012/09/28 06:37:30 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/nemo/ChangeLog,v 1.2 2012/12/30 02:38:29 tetromino Exp $
+
+*nemo-1.1.2 (30 Dec 2012)
+
+ 30 Dec 2012; Alexandre Rostovtsev <tetromino@gentoo.org> +nemo-1.1.2.ebuild,
+ +files/nemo-1.1.2-view-toolbar.patch:
+ Version bump for bug #440612; thanks to Anton Bolshakov et al.
*nemo-1.0.2 (28 Sep 2012)
diff --git a/gnome-extra/nemo/files/nemo-1.1.2-view-toolbar.patch b/gnome-extra/nemo/files/nemo-1.1.2-view-toolbar.patch
new file mode 100644
index 000000000000..6214ba2da1ff
--- /dev/null
+++ b/gnome-extra/nemo/files/nemo-1.1.2-view-toolbar.patch
@@ -0,0 +1,160 @@
+From ec763f341d737c61a2eee020de53ccd5db8b8dcf Mon Sep 17 00:00:00 2001
+From: Michael Webster <miketwebster@gmail.com>
+Date: Fri, 23 Nov 2012 10:26:31 -0500
+Subject: [PATCH] Simplify view toolbar item management
+
+---
+ src/nemo-window-menus.c | 39 +++++++++++++++++++++++----------------
+ src/nemo-window-menus.h | 9 +++++----
+ src/nemo-window.c | 2 +-
+ 3 files changed, 29 insertions(+), 21 deletions(-)
+
+diff --git a/src/nemo-window-menus.c b/src/nemo-window-menus.c
+index 927c6b7..bd29084 100644
+--- a/src/nemo-window-menus.c
++++ b/src/nemo-window-menus.c
+@@ -27,8 +27,9 @@
+ */
+ #include <config.h>
+
+-#include <locale.h>
++#include <locale.h>
+
++#include "nemo-window-menus.h"
+ #include "nemo-actions.h"
+ #include "nemo-application.h"
+ #include "nemo-connect-server-dialog.h"
+@@ -767,6 +768,13 @@ action_edit_location_callback (GtkAction *action,
+ nemo_window_pane_ensure_location_bar (pane);
+ }
+
++enum {
++ ICON_VIEW,
++ LIST_VIEW,
++ COMPACT_VIEW,
++ NULL_VIEW
++};
++
+ static void
+ action_icon_view_callback (GtkAction *action,
+ gpointer user_data)
+@@ -776,7 +784,7 @@ action_icon_view_callback (GtkAction *action,
+ window = NEMO_WINDOW (user_data);
+ slot = nemo_window_get_active_slot (window);
+ nemo_window_slot_set_content_view (slot, NEMO_ICON_VIEW_ID);
+- toolbar_set_view_button (NEMO_ACTION_ICON_VIEW, nemo_window_get_active_pane(window));
++ toolbar_set_view_button (ICON_VIEW, nemo_window_get_active_pane(window));
+ }
+
+
+@@ -789,7 +797,7 @@ action_list_view_callback (GtkAction *action,
+ window = NEMO_WINDOW (user_data);
+ slot = nemo_window_get_active_slot (window);
+ nemo_window_slot_set_content_view (slot, NEMO_LIST_VIEW_ID);
+- toolbar_set_view_button (NEMO_ACTION_LIST_VIEW, nemo_window_get_active_pane(window));
++ toolbar_set_view_button (LIST_VIEW, nemo_window_get_active_pane(window));
+ }
+
+
+@@ -802,30 +810,29 @@ action_compact_view_callback (GtkAction *action,
+ window = NEMO_WINDOW (user_data);
+ slot = nemo_window_get_active_slot (window);
+ nemo_window_slot_set_content_view (slot, FM_COMPACT_VIEW_ID);
+- toolbar_set_view_button (NEMO_ACTION_COMPACT_VIEW, nemo_window_get_active_pane(window));
++ toolbar_set_view_button (COMPACT_VIEW, nemo_window_get_active_pane(window));
+ }
+
+-
+-gchar *
+-toolbar_action_for_view_id (gchar *view_id)
++guint
++toolbar_action_for_view_id (const char *view_id)
+ {
+ if (g_strcmp0(view_id, NEMO_ICON_VIEW_ID) == 0) {
+- return NEMO_ACTION_ICON_VIEW;
++ return ICON_VIEW;
+ } else if (g_strcmp0(view_id, NEMO_LIST_VIEW_ID) == 0) {
+- return NEMO_ACTION_LIST_VIEW;
++ return LIST_VIEW;
+ } else if (g_strcmp0(view_id, FM_COMPACT_VIEW_ID) == 0) {
+- return NEMO_ACTION_COMPACT_VIEW;
++ return COMPACT_VIEW;
+ } else {
+- return NULL;
++ return NULL_VIEW;
+ }
+ }
+
+ void
+-toolbar_set_view_button (gchar *action_id, NemoWindowPane *pane)
++toolbar_set_view_button (guint action_id, NemoWindowPane *pane)
+ {
+ GtkAction *action, *action1, *action2;
+ GtkActionGroup *action_group;
+- if (action_id == NULL) {
++ if (action_id == NULL_VIEW) {
+ return;
+ }
+ action_group = nemo_window_pane_get_toolbar_action_group (pane);
+@@ -858,19 +865,19 @@ toolbar_set_view_button (gchar *action_id, NemoWindowPane *pane)
+ action_compact_view_callback,
+ NULL);
+
+- if (g_strcmp0(action_id, NEMO_ACTION_ICON_VIEW) != 0) {
++ if (action_id != ICON_VIEW) {
+ gtk_toggle_action_set_active(GTK_TOGGLE_ACTION(action), FALSE);
+ } else {
+ gtk_toggle_action_set_active(GTK_TOGGLE_ACTION(action), TRUE);
+ }
+
+- if (g_strcmp0(action_id, NEMO_ACTION_LIST_VIEW) != 0) {
++ if (action_id != LIST_VIEW) {
+ gtk_toggle_action_set_active(GTK_TOGGLE_ACTION(action1), FALSE);
+ } else {
+ gtk_toggle_action_set_active(GTK_TOGGLE_ACTION(action1), TRUE);
+ }
+
+- if (g_strcmp0(action_id, NEMO_ACTION_COMPACT_VIEW) != 0) {
++ if (action_id != COMPACT_VIEW) {
+ gtk_toggle_action_set_active(GTK_TOGGLE_ACTION(action2), FALSE);
+ } else {
+ gtk_toggle_action_set_active(GTK_TOGGLE_ACTION(action2), TRUE);
+diff --git a/src/nemo-window-menus.h b/src/nemo-window-menus.h
+index 2ed773b..9ecf614 100644
+--- a/src/nemo-window-menus.h
++++ b/src/nemo-window-menus.h
+@@ -22,13 +22,14 @@
+ Author: Holger Berndt <berndth@gmx.de>
+ */
+
+-#ifndef NEMO_WINDOW_PANE_H
+-#define NEMO_WINDOW_PANE_H
++#ifndef NEMO_WINDOW_MENUS_H
++#define NEMO_WINDOW_MENUS_H
+
+ #include "nemo-window.h"
++#include "nemo-window-pane.h"
+ #include <gtk/gtk.h>
+
+-gchar * toolbar_action_for_view_id (gchar *view_id );
+-void toolbar_set_view_button (gchar *action_id, NemoWindowPane *pane);
++guint toolbar_action_for_view_id (const char *view_id );
++void toolbar_set_view_button (guint action_id, NemoWindowPane *pane);
+
+ #endif /* NEMO_WINDOW_PANE_H */
+diff --git a/src/nemo-window.c b/src/nemo-window.c
+index 4b4e67d..592e346 100644
+--- a/src/nemo-window.c
++++ b/src/nemo-window.c
+@@ -1246,7 +1246,7 @@ nemo_window_sync_view_as_menus (NemoWindow *window)
+ char action_name[32];
+ GList *node;
+ GtkAction *action;
+- gchar *view_id;
++ const char *view_id;
+
+ g_assert (NEMO_IS_WINDOW (window));
+
+--
+1.8.0.2
+
diff --git a/gnome-extra/nemo/nemo-1.1.2.ebuild b/gnome-extra/nemo/nemo-1.1.2.ebuild
new file mode 100644
index 000000000000..60df6c1a93aa
--- /dev/null
+++ b/gnome-extra/nemo/nemo-1.1.2.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/nemo/nemo-1.1.2.ebuild,v 1.1 2012/12/30 02:38:29 tetromino Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2 virtualx
+
+DESCRIPTION="A file manager for Cinnamon, forked from Nautilus"
+HOMEPAGE="http://cinnamon.linuxmint.com/"
+SRC_URI="https://github.com/linuxmint/nemo/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2+ LGPL-2+ FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="exif +introspection packagekit tracker xmp" # doc
+
+COMMON_DEPEND=">=dev-libs/glib-2.31.9:2
+ >=x11-libs/pango-1.28.3
+ >=x11-libs/gtk+-3.3.17:3[introspection?]
+ >=dev-libs/libxml2-2.7.8:2
+ >=gnome-base/gnome-desktop-3.0.0:3=
+
+ gnome-base/dconf:=
+ gnome-base/gsettings-desktop-schemas
+ >=x11-libs/libnotify-0.7:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+
+ exif? ( >=media-libs/libexif-0.6.20:= )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.4 )
+ tracker? ( >=app-misc/tracker-0.12:= )
+ xmp? ( >=media-libs/exempi-2.1.0:= )"
+RDEPEND="${COMMON_DEPEND}
+ x11-themes/gnome-icon-theme-symbolic
+ packagekit? ( app-admin/packagekit-base )"
+DEPEND="${COMMON_DEPEND}
+ >=dev-lang/perl-5
+ >=dev-util/gdbus-codegen-2.31.0
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.40.1
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-proto/xproto
+
+ gnome-base/gnome-common"
+# For eautoreconf
+# gnome-base/gnome-common
+PDEPEND=">=gnome-base/gvfs-0.1.2"
+
+S="${WORKDIR}/linuxmint-nemo-7bee834"
+
+src_prepare() {
+ # In next release; apparently fixes crashes
+ epatch "${FILESDIR}/${P}-view-toolbar.patch"
+
+ sed 's:-DG.*DISABLE_DEPRECATED::g' -i configure.in || die
+ eautoreconf # no configure in tarball :/
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README THANKS TODO"
+ # FIXME: add $(use_enable doc gtk-doc) once gnome.eclass supports it in EAPI5
+ gnome2_src_configure \
+ --disable-update-mimedb \
+ $(use_enable exif libexif) \
+ $(use_enable introspection) \
+ $(use_enable packagekit) \
+ $(use_enable tracker) \
+ $(use_enable xmp)
+}
+
+src_test() {
+ if ! [[ -f "${EROOT}usr/share/glib-2.0/schemas/org.nemo.gschema.xml" ]]; then
+ ewarn "Skipping tests because Nemo gsettings schema are not installed."
+ ewarn "To run the tests, a version of ${CATEGORY}/${PN} needs to be"
+ ewarn "already installed."
+ return
+ fi
+ gnome2_environment_reset
+ unset DBUS_SESSION_BUS_ADDRESS
+ export GSETTINGS_BACKEND="memory"
+ cd src # we don't care about translation tests
+ Xemake check
+ unset GSETTINGS_BACKEND
+}