summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-09-06 10:20:41 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-09-06 10:20:41 +0000
commitfe3537939a9cdd4c2208d0917351bd2cb26d3610 (patch)
tree61d9b1946a85f14bcf0a13079dd128880a5a96a4 /gnome-extra/tasks
parentUse ffmpeg.org svn repo and add PV conditionals so that we can make snapshots... (diff)
downloadgentoo-2-fe3537939a9cdd4c2208d0917351bd2cb26d3610.tar.gz
gentoo-2-fe3537939a9cdd4c2208d0917351bd2cb26d3610.tar.bz2
gentoo-2-fe3537939a9cdd4c2208d0917351bd2cb26d3610.zip
Version bump. Magic pattern support. Add an edit cli switch. Translation updates. Port to new gtk/glib APIs. Clean up old revision.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/tasks')
-rw-r--r--gnome-extra/tasks/ChangeLog9
-rw-r--r--gnome-extra/tasks/tasks-0.16.ebuild (renamed from gnome-extra/tasks/tasks-0.13.ebuild)23
2 files changed, 26 insertions, 6 deletions
diff --git a/gnome-extra/tasks/ChangeLog b/gnome-extra/tasks/ChangeLog
index 76b8470743a8..18be1187132d 100644
--- a/gnome-extra/tasks/ChangeLog
+++ b/gnome-extra/tasks/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-extra/tasks
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/tasks/ChangeLog,v 1.3 2009/07/09 21:46:00 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/tasks/ChangeLog,v 1.4 2009/09/06 10:20:41 eva Exp $
+
+*tasks-0.16 (06 Sep 2009)
+
+ 06 Sep 2009; Gilles Dartiguelongue <eva@gentoo.org> -tasks-0.13.ebuild,
+ +tasks-0.16.ebuild:
+ Version bump. Magic pattern support. Add an edit cli switch. Translation
+ updates. Port to new gtk/glib APIs. Clean up old revision.
09 Jul 2009; Gilles Dartiguelongue <eva@gentoo.org> tasks-0.14.ebuild,
+files/tasks-0.14-configh.patch:
diff --git a/gnome-extra/tasks/tasks-0.13.ebuild b/gnome-extra/tasks/tasks-0.16.ebuild
index f360c8fc4fa5..0a0776e9e4ea 100644
--- a/gnome-extra/tasks/tasks-0.13.ebuild
+++ b/gnome-extra/tasks/tasks-0.16.ebuild
@@ -1,8 +1,11 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/tasks/tasks-0.13.ebuild,v 1.2 2008/04/26 03:45:30 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/tasks/tasks-0.16.ebuild,v 1.1 2009/09/06 10:20:41 eva Exp $
-inherit gnome2
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2
DESCRIPTION="A small, lightweight to-do list for Gnome"
HOMEPAGE="http://pimlico-project.org/tasks.html"
@@ -14,8 +17,9 @@ KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
RDEPEND=">=gnome-extra/evolution-data-server-1.8
- >=x11-libs/gtk+-2.6
- x11-libs/libsexy"
+ >=x11-libs/gtk+-2.16
+ >=dev-libs/glib-2.14
+ >=dev-libs/libunique-1"
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.9.0
@@ -23,3 +27,12 @@ DEPEND="${RDEPEND}
sys-devel/gettext"
DOCS="AUTHORS ChangeLog INSTALL NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --with-unique --enable-gtk"
+}
+
+#src_prepare() {
+# # Add missing config.h, bug #277115
+# epatch "${FILESDIR}/${P}-configh.patch"
+#}