summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2001-09-24 03:00:31 +0000
committerDonny Davies <woodchip@gentoo.org>2001-09-24 03:00:31 +0000
commit5d483bc7ddf803add3a467693617d20e9dbb1e8c (patch)
treedea0822488f5df99086ca85b8c2249d8c38ec5bc /incoming
parenttry 2 (diff)
downloadgentoo-2-5d483bc7ddf803add3a467693617d20e9dbb1e8c.tar.gz
gentoo-2-5d483bc7ddf803add3a467693617d20e9dbb1e8c.tar.bz2
gentoo-2-5d483bc7ddf803add3a467693617d20e9dbb1e8c.zip
older then what we alredy have
Diffstat (limited to 'incoming')
-rw-r--r--incoming/esound/esound-0.2.8.ebuild71
-rw-r--r--incoming/esound/files/esddsp.c.diff17
2 files changed, 0 insertions, 88 deletions
diff --git a/incoming/esound/esound-0.2.8.ebuild b/incoming/esound/esound-0.2.8.ebuild
deleted file mode 100644
index 302552f2ae8b..000000000000
--- a/incoming/esound/esound-0.2.8.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# /home/cvsroot/gentoo-x86/media-sound/esound/esound-0.2.22-r2.ebuild,v 1.2 2001/06/11 08:11:28 hallski Exp
-
-A=${P}.tar.gz
-S=${WORKDIR}/${P}
-DESCRIPTION="esound"
-SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/esound/${A}
- ftp://download.sourceforge.net/pub/mirrors/gnome/stable/sources/esound/${A}"
-HOMEPAGE="http://www.tux.org/~ricdude/EsounD.html"
-
-DEPEND="virtual/glibc
- alsa? ( >=media-libs/alsa-lib-0.5.9 )
- >=media-libs/audiofile-0.1.9
- tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )"
-
-RDEPEND="virtual/glibc
- alsa? ( >=media-libs/alsa-lib-0.5.9 )
- >=media-libs/audiofile-0.1.9"
-
-src_unpack() {
-
- unpack ${A}
-
- cd ${S}
-
- patch -p0 <${FILESDIR}/esddsp.c.diff || die
-
-}
-
-src_compile() {
-
- local myconf
- if [ "`use tcpd`" ]
- then
- myconf="--with-libwrap"
- else
- myconf="--without-libwrap"
- fi
-
-# ALSA support broken ... need newer ALSA ?
-# if [ "`use alsa`" ]
-# then
-# myconf="$myconf --enable-alsa"
-# else
- myconf="$myconf --enable-alsa=no"
-# fi
-
- ./configure --host=${CHOST} --prefix=/usr \
- --sysconfdir=/etc/esd $myconf || die
- pmake || die
-}
-
-src_install() {
- cd ${S}
- make prefix=${D}/usr sysconfdir=${D}/etc/esd install || die
- dodoc AUTHORS COPYING* ChangeLog README TODO
- dodoc NEWS TIPS
- dodoc docs/esound.ps
- docinto html
- dodoc docs/html/*.html docs/html/*.css
- docinto html/stylesheet-images
- dodoc docs/html/stylesheet-images/*.gif
-}
-
-
-
-
-
-
diff --git a/incoming/esound/files/esddsp.c.diff b/incoming/esound/files/esddsp.c.diff
deleted file mode 100644
index f435e7f32edc..000000000000
--- a/incoming/esound/files/esddsp.c.diff
+++ /dev/null
@@ -1,17 +0,0 @@
-*** esddsp.c Thu Feb 11 03:48:33 1999
---- esddsp.c.new Sun Sep 23 08:47:46 2001
-***************
-*** 34,39 ****
---- 34,45 ----
-
- #include "config.h"
-
-+ // Tempory hack to fix a wierd #define not passed to #includes problem
-+ // Maybe someone with gcc 3.01 could try without .diff ?
-+ #ifndef RTLD_NEXT
-+ # define RTLD_NEXT ((void *) -1l)
-+ #endif
-+
- #include <dlfcn.h>
- #include <stdarg.h>
- #include <stdlib.h>