summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2001-10-14 23:00:25 +0000
committerDan Armak <danarmak@gentoo.org>2001-10-14 23:00:25 +0000
commit9705b851d8557f0067b08c4e573fb4f12f80a227 (patch)
treea55200591acac61958aa74343b51ae7fd675c01e /kde-base/kdebindings
parentNow reads its config files correctly. (diff)
downloadgentoo-2-9705b851d8557f0067b08c4e573fb4f12f80a227.tar.gz
gentoo-2-9705b851d8557f0067b08c4e573fb4f12f80a227.tar.bz2
gentoo-2-9705b851d8557f0067b08c4e573fb4f12f80a227.zip
added some missing deps
Diffstat (limited to 'kde-base/kdebindings')
-rw-r--r--kde-base/kdebindings/kdebindings-2.2.1-r1.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/kde-base/kdebindings/kdebindings-2.2.1-r1.ebuild b/kde-base/kdebindings/kdebindings-2.2.1-r1.ebuild
index 2f619ae7738a..7ee07b6746c4 100644
--- a/kde-base/kdebindings/kdebindings-2.2.1-r1.ebuild
+++ b/kde-base/kdebindings/kdebindings-2.2.1-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings/kdebindings-2.2.1-r1.ebuild,v 1.4 2001/10/07 11:11:08 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings/kdebindings-2.2.1-r1.ebuild,v 1.5 2001/10/14 23:00:25 danarmak Exp $
. /usr/portage/eclass/inherit.eclass || die
inherit kde-dist || die
@@ -11,7 +11,10 @@ NEWDEPEND=">=kde-base/kdebase-${PV}
>=x11-libs/gtk+-1.2.10-r4
sys-devel/perl
python? ( dev-lang/python )
- java? ( dev-lang/jdk )"
+ java? ( dev-lang/jdk )
+ >=x11-libs/gtk+-1.2.6
+ >=dev-libs/glib-1.2.6
+ >=kde-base/kdenetwork-${PV}"
DEPEND="$DEPEND $NEWDEPEND"
RDEPEND="$RDEPEND $NEWDEPEND"
@@ -22,10 +25,11 @@ src_compile() {
use python || myconf="$myconf --without-python"
use java && myconf="$myconf --with-java=/opt/java" || myconf="$myconf --without-java"
-
+
kde_src_compile configure
-
- LIBPYTHON=\"`python-config`\" make || die
+
+ # the library_path is a kludge for a strange bug
+ LIBRARY_PATH=${QTDIR}/lib LIBPYTHON=\"`python-config`\" make || die
}