summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannes Mehnert <hannes@gentoo.org>2002-12-21 13:48:19 +0000
committerHannes Mehnert <hannes@gentoo.org>2002-12-21 13:48:19 +0000
commita412401747242b77051581d022d1694e1e158985 (patch)
treeab75d70a858ba380ee5b19838d1b79e5aa6c25d2 /kde-base/kdegraphics
parentToo much python... (diff)
downloadgentoo-2-a412401747242b77051581d022d1694e1e158985.tar.gz
gentoo-2-a412401747242b77051581d022d1694e1e158985.tar.bz2
gentoo-2-a412401747242b77051581d022d1694e1e158985.zip
kde-3.0.5a release.
Diffstat (limited to 'kde-base/kdegraphics')
-rw-r--r--kde-base/kdegraphics/files/digest-kdegraphics-3.0.5a1
-rw-r--r--kde-base/kdegraphics/files/kdegraphics-3.0.5a-kghostviewrc16
-rw-r--r--kde-base/kdegraphics/kdegraphics-3.0.5a.ebuild53
3 files changed, 70 insertions, 0 deletions
diff --git a/kde-base/kdegraphics/files/digest-kdegraphics-3.0.5a b/kde-base/kdegraphics/files/digest-kdegraphics-3.0.5a
new file mode 100644
index 000000000000..3a37955c53da
--- /dev/null
+++ b/kde-base/kdegraphics/files/digest-kdegraphics-3.0.5a
@@ -0,0 +1 @@
+MD5 cba91964c5fcebfbe1942b58d2b1d059 kdegraphics-3.0.5a.tar.bz2 2664922
diff --git a/kde-base/kdegraphics/files/kdegraphics-3.0.5a-kghostviewrc b/kde-base/kdegraphics/files/kdegraphics-3.0.5a-kghostviewrc
new file mode 100644
index 000000000000..5c2e48efba0c
--- /dev/null
+++ b/kde-base/kdegraphics/files/kdegraphics-3.0.5a-kghostviewrc
@@ -0,0 +1,16 @@
+[General]
+Antialiasing=true
+Interpreter=gs
+Messages=false
+Palette=color
+Platform fonts=false
+ShowPageList=true
+ShowPageNames=false
+ShowScrollBars=true
+WatchFile=false
+
+[Ghostscript]
+Antialiasing arguments=-sDEVICE=x11 -dTextAlphaBits=4 -dGraphicsAlphaBits=2 -dMaxBitmap=10000000
+Interpreter=gs
+Non-antialiasing arguments=-sDEVICE=x11
+
diff --git a/kde-base/kdegraphics/kdegraphics-3.0.5a.ebuild b/kde-base/kdegraphics/kdegraphics-3.0.5a.ebuild
new file mode 100644
index 000000000000..f36e3d3e79d6
--- /dev/null
+++ b/kde-base/kdegraphics/kdegraphics-3.0.5a.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/kdegraphics-3.0.5a.ebuild,v 1.1 2002/12/21 13:48:19 hannes Exp $
+inherit kde-dist
+
+DESCRIPTION="KDE $PV - graphics-related apps"
+
+KEYWORDS="x86 ~ppc ~alpha"
+
+newdepend "gphoto2? ( >=media-gfx/gphoto2-2.0_beta1 >=media-libs/libgpio-20010607 )
+ sys-devel/perl
+ scanner? ( media-gfx/sane-backends )
+ tetex? ( >=app-text/tetex-1.0.7 )
+ media-libs/imlib
+ app-text/ghostscript"
+# x86? ( scanner? sys-libs/libieee1284 )
+
+use gphoto2 && myconf="$myconf --with-kamera --with-gphoto2-includes=/usr/include/gphoto2 \
+ --with-gphoto2-libraries=/usr/lib/gphoto2 \
+ --with-gpio --with-gpio-includes=/usr/include \
+ --with-gpio-libraries=/usr/lib" || myconf="$myconf --without-kamera"
+
+use tetex && myconf="$myconf --with-system-kpathsea --with-tex-datadir=/usr/share"
+
+use scanner || KDE_REMOVE_DIR="kooka libkscan"
+
+myconf="$myconf --with-imlib --with-imlib-config=/usr/bin "
+
+need-autoconf 2.1
+
+src_unpack() {
+
+ base_src_unpack
+
+ if [ -z "`use scanner`" ]; then
+ cd $S
+ mv Makefile.am Makefile.am.orig
+ sed -e 's:$(KSCANDIR)::' Makefile.am.orig > Makefile.am
+ fi
+
+
+}
+
+src_install() {
+
+ kde_src_install
+
+ # default kghostviewrc beacuse kghostview doesn't generate a working default run on its 1st run
+ # fix bug #6562
+ dodir $PREFIX/share/config
+ cp $FILESDIR/$P-kghostviewrc $D/$PREFIX/share/config/kghostviewrc
+
+}