summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-01-25 18:17:26 +0000
committerJohannes Huber <johu@gentoo.org>2012-01-25 18:17:26 +0000
commit8f5c0a404860825a8ca1de5f74decd3e3b2f411e (patch)
treefd54bf03f8193c4baefa01616ebd14e3b25f8717 /kde-base/kdepimlibs
parentUse github from thirdpartymirrors. (diff)
downloadgentoo-2-8f5c0a404860825a8ca1de5f74decd3e3b2f411e.tar.gz
gentoo-2-8f5c0a404860825a8ca1de5f74decd3e3b2f411e.tar.bz2
gentoo-2-8f5c0a404860825a8ca1de5f74decd3e3b2f411e.zip
Version bump KDE SC 4.8.0
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kdepimlibs')
-rw-r--r--kde-base/kdepimlibs/ChangeLog7
-rw-r--r--kde-base/kdepimlibs/kdepimlibs-4.8.0.ebuild69
-rw-r--r--kde-base/kdepimlibs/metadata.xml5
3 files changed, 79 insertions, 2 deletions
diff --git a/kde-base/kdepimlibs/ChangeLog b/kde-base/kdepimlibs/ChangeLog
index 0b37a97db56c..0a04603dff66 100644
--- a/kde-base/kdepimlibs/ChangeLog
+++ b/kde-base/kdepimlibs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdepimlibs
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.128 2012/01/17 13:29:06 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.129 2012/01/25 18:16:54 johu Exp $
+
+*kdepimlibs-4.8.0 (25 Jan 2012)
+
+ 25 Jan 2012; Johannes Huber <johu@gentoo.org> +kdepimlibs-4.8.0.ebuild:
+ Version bump KDE SC 4.8.0
17 Jan 2012; Johannes Huber <johu@gentoo.org> -kdepimlibs-4.7.3-r1.ebuild:
Remove KDE SC 4.7.3
diff --git a/kde-base/kdepimlibs/kdepimlibs-4.8.0.ebuild b/kde-base/kdepimlibs/kdepimlibs-4.8.0.ebuild
new file mode 100644
index 000000000000..3724bccc15c4
--- /dev/null
+++ b/kde-base/kdepimlibs/kdepimlibs-4.8.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/kdepimlibs-4.8.0.ebuild,v 1.1 2012/01/25 18:16:54 johu Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+CPPUNIT_REQUIRED="optional"
+KDE_SCM="git"
+inherit kde4-base
+
+DESCRIPTION="Common library for KDE PIM apps."
+HOMEPAGE="http://www.kde.org/"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="LGPL-2.1"
+IUSE="debug ldap +prison semantic-desktop"
+
+# some akonadi tests timeout, that probaly needs more work as its ~700 tests
+RESTRICT="test"
+
+COMMON_DEPEND="
+ >=app-crypt/gpgme-1.1.6
+ dev-libs/libgpg-error
+ >=dev-libs/libical-0.43
+ dev-libs/cyrus-sasl
+ $(add_kdebase_dep kdelibs 'semantic-desktop=')
+ prison? ( media-libs/prison )
+ semantic-desktop? (
+ >=app-office/akonadi-server-1.7.0
+ media-libs/phonon
+ x11-misc/shared-mime-info
+ )
+ ldap? ( net-nds/openldap )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/boost-1.35.0-r5
+"
+RDEPEND="${COMMON_DEPEND}"
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ # Disable hardcoded checks
+ sed -r -e '/find_package\((Akonadi|SharedDesktopOntologies|Soprano|Nepomuk)/{/macro_optional_/!s/find/macro_optional_&/}' \
+ -e '/macro_log_feature\((Akonadi|SHAREDDESKTOPONTOLOGIES|Soprano|Nepomuk)_FOUND/s/ TRUE / FALSE /' \
+ -e '/add_subdirectory\((akonadi|mailtransport)/{/macro_optional_/!s/add/macro_optional_&/}' \
+ -i CMakeLists.txt || die
+ if ! use semantic-desktop; then
+ sed -e '/include(SopranoAddOntology)/s/^/#DISABLED /' \
+ -i CMakeLists.txt || die
+ # More reliable than -DBUILD_akonadi=OFF
+ rm -r akonadi mailtransport || die
+ fi
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build handbook doc)
+ $(cmake-utils_use_with ldap)
+ $(cmake-utils_use_with semantic-desktop Akonadi)
+ $(cmake-utils_use_with semantic-desktop SharedDesktopOntologies)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with prison Prison)
+ )
+
+ kde4-base_src_configure
+}
diff --git a/kde-base/kdepimlibs/metadata.xml b/kde-base/kdepimlibs/metadata.xml
index 8d1e86a9cefb..d19719a52cea 100644
--- a/kde-base/kdepimlibs/metadata.xml
+++ b/kde-base/kdepimlibs/metadata.xml
@@ -1,5 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>kde</herd>
+ <herd>kde</herd>
+ <use>
+ <flag name="prison">Enable support for QRcodes in contacts</flag>
+ </use>
</pkgmetadata>