summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2005-05-25 21:23:15 +0000
committerDan Armak <danarmak@gentoo.org>2005-05-25 21:23:15 +0000
commit2c22cfa8ffcfc73043bf37aeee39170605f0eb4d (patch)
treed056634258bce285b9c3837f09ef42145572f845 /kde-base/xparts
parentAdd the missing HOMEPAGE variable so repoman doesn't complain. (diff)
downloadgentoo-2-2c22cfa8ffcfc73043bf37aeee39170605f0eb4d.tar.gz
gentoo-2-2c22cfa8ffcfc73043bf37aeee39170605f0eb4d.tar.bz2
gentoo-2-2c22cfa8ffcfc73043bf37aeee39170605f0eb4d.zip
KDE 3.4.1 ebuilds; package.masked as they aren't released yet
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'kde-base/xparts')
-rw-r--r--kde-base/xparts/ChangeLog8
-rw-r--r--kde-base/xparts/Manifest8
-rw-r--r--kde-base/xparts/files/digest-xparts-3.4.12
-rw-r--r--kde-base/xparts/xparts-3.4.1.ebuild37
4 files changed, 51 insertions, 4 deletions
diff --git a/kde-base/xparts/ChangeLog b/kde-base/xparts/ChangeLog
index e1fc5897a7c4..6fe3dff7a789 100644
--- a/kde-base/xparts/ChangeLog
+++ b/kde-base/xparts/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/xparts
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/xparts/ChangeLog,v 1.8 2005/03/23 16:17:14 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/xparts/ChangeLog,v 1.9 2005/05/25 21:23:15 danarmak Exp $
+
+*xparts-3.4.1 (25 May 2005)
+
+ 25 May 2005; Dan Armak <danarmak@gentoo.org> +xparts-3.4.1.ebuild:
+ Ebuilds for KDE 3.4.1. These are package.masked until 3.4.1 is actually
+ released. You can't get the tarballs yet.
23 Mar 2005; Seemant Kulleen <seemant@gentoo.org> xparts-3.3.1.ebuild,
xparts-3.4.0.ebuild:
diff --git a/kde-base/xparts/Manifest b/kde-base/xparts/Manifest
index 1cd81333dc25..920854805fe8 100644
--- a/kde-base/xparts/Manifest
+++ b/kde-base/xparts/Manifest
@@ -1,7 +1,9 @@
-MD5 acc03a4b12bb0433a57e95bd253b9501 metadata.xml 156
MD5 d104eb29f13a498c62812d06852923ef xparts-3.4.0.ebuild 1193
-MD5 98a173448758a0b5d16338ab29e7e059 ChangeLog 1669
MD5 ca9550c47090fc658c5e454dc7069f9c xparts-3.3.1.ebuild 1244
-MD5 b49bfb02ebaf3b34e2e5c4c5750429d6 files/digest-xparts-3.4.0 71
+MD5 74a5cde55097e6684dd92875925595f9 xparts-3.4.1.ebuild 1195
+MD5 c7fc6ed01d816b88fed76017857327c3 ChangeLog 1886
+MD5 acc03a4b12bb0433a57e95bd253b9501 metadata.xml 156
MD5 ffe26fb6d5d193883dfebd69250df2e5 files/no-gtk-glib-check.diff 949
MD5 6830fc45ae55313b9f8515babcf58b79 files/digest-xparts-3.3.1 71
+MD5 b49bfb02ebaf3b34e2e5c4c5750429d6 files/digest-xparts-3.4.0 71
+MD5 ebf92f288d10fb2438ab4a589e92aad3 files/digest-xparts-3.4.1 142
diff --git a/kde-base/xparts/files/digest-xparts-3.4.1 b/kde-base/xparts/files/digest-xparts-3.4.1
new file mode 100644
index 000000000000..6e4205dc862e
--- /dev/null
+++ b/kde-base/xparts/files/digest-xparts-3.4.1
@@ -0,0 +1,2 @@
+MD5 bac87a665ce5e5704f48336122052fb4 kdebindings-3.4.0.tar.bz2 7161497
+MD5 18a4e2c42d34bb86279e691498482951 kdebindings-3.4.1.tar.bz2 7219233
diff --git a/kde-base/xparts/xparts-3.4.1.ebuild b/kde-base/xparts/xparts-3.4.1.ebuild
new file mode 100644
index 000000000000..3d139f55cc89
--- /dev/null
+++ b/kde-base/xparts/xparts-3.4.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/xparts/xparts-3.4.1.ebuild,v 1.1 2005/05/25 21:23:15 danarmak Exp $
+
+KMNAME=kdebindings
+KMEXTRACTONLY="dcopc"
+KMCOPYLIB="libdcopc dcopc"
+KM_MAKEFILESREV=1
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta
+
+DESCRIPTION="Allows embedding of generic XParts as KDE KParts"
+KEYWORDS="~x86 ~amd64" # broken according to upstream - 3.4a1 README
+IUSE="mozilla"
+DEPEND="=dev-libs/glib-1.2*
+ =x11-libs/gtk+-1.2*
+ mozilla? ( www-client/mozilla )"
+PATCHES="$FILESDIR/no-gtk-glib-check.diff"
+
+src_unpack() {
+ kde-meta_src_unpack
+
+ # Doesn't affect makefile tarballs.
+ # Real solution will be to split this further and make a separate
+ # ebuild for the mozilla xpart.
+ # But since this is officially broken anyway I'm not going to bother...
+ if ! useq mozilla ; then
+ # disable mozilla bindings/xpart, because configure doesn't seem to do so
+ # even when it doesn't detect the mozilla headers
+ cd ${S}/xparts
+ cp Makefile.am Makefile.am.orig
+ sed -e 's:mozilla::' Makefile.am.orig > Makefile.am
+ fi
+ cd ${S} && make -f admin/Makefile.common
+}
+