summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2004-06-12 12:27:14 +0000
committerCaleb Tennis <caleb@gentoo.org>2004-06-12 12:27:14 +0000
commit776c703f502a73927f43641775dd80f8508e4283 (patch)
tree509e5e3b04d877786f35a01119d9b4e1897ca86a /kde-base
parentsyntax fix (Manifest recommit) (diff)
downloadgentoo-2-776c703f502a73927f43641775dd80f8508e4283.tar.gz
gentoo-2-776c703f502a73927f43641775dd80f8508e4283.tar.bz2
gentoo-2-776c703f502a73927f43641775dd80f8508e4283.zip
gcc34 patch readd
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kdeaddons/files/kdeaddons-3.2.3-gcc34.patch28
-rw-r--r--kde-base/kdeaddons/kdeaddons-3.2.3.ebuild4
2 files changed, 30 insertions, 2 deletions
diff --git a/kde-base/kdeaddons/files/kdeaddons-3.2.3-gcc34.patch b/kde-base/kdeaddons/files/kdeaddons-3.2.3-gcc34.patch
new file mode 100644
index 000000000000..75ab7123e372
--- /dev/null
+++ b/kde-base/kdeaddons/files/kdeaddons-3.2.3-gcc34.patch
@@ -0,0 +1,28 @@
+diff -udBbr kdeaddons-3.2.2/work/kdeaddons-3.2.2/noatun-plugins/synaescope/polygon.h kdeaddons-3.2.2-fix1/work/kdeaddons-3.2.2/noatun-plugins/synaescope/polygon.h
+--- noatun-plugins/synaescope/polygon.h 2001-04-17 03:20:34.000000000 +0400
++++ noatun-plugins/synaescope/polygon.h 2004-04-24 09:51:48.355249296 +0400
+@@ -25,6 +25,10 @@
+ template<class Pixel, class Combiner, int superSampleShift>
+ struct PolygonEngine : public Bitmap<Pixel>
+ {
++ using Bitmap<Pixel>::width;
++ using Bitmap<Pixel>::height;
++ using Bitmap<Pixel>::data;
++
+ PolygonEngine() : Bitmap<Pixel>(1) { }
+
+ #define super (1<<superSampleShift)
+diff -udBbr kdeaddons-3.2.2/work/kdeaddons-3.2.2/noatun-plugins/tippercanoe/polygon.h kdeaddons-3.2.2-fix1/work/kdeaddons-3.2.2/noatun-plugins/tippercanoe/polygon.h
+--- noatun-plugins/tippercanoe/polygon.h 2001-04-17 02:04:03.000000000 +0400
++++ noatun-plugins/tippercanoe/polygon.h 2004-04-24 09:58:30.243153048 +0400
+@@ -23,6 +23,10 @@
+
+ template<class Pixel, class Combiner, int superSampleShift>
+ struct PolygonEngine : public Bitmap<Pixel> {
++ using Bitmap<Pixel>::width;
++ using Bitmap<Pixel>::height;
++ using Bitmap<Pixel>::data;
++
+ PolygonEngine() : Bitmap<Pixel>(1) { }
+
+ #define super (1<<superSampleShift)
diff --git a/kde-base/kdeaddons/kdeaddons-3.2.3.ebuild b/kde-base/kdeaddons/kdeaddons-3.2.3.ebuild
index 8b7e44f41bb3..5e2a35a9d4f4 100644
--- a/kde-base/kdeaddons/kdeaddons-3.2.3.ebuild
+++ b/kde-base/kdeaddons/kdeaddons-3.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeaddons/kdeaddons-3.2.3.ebuild,v 1.1 2004/06/10 22:45:24 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeaddons/kdeaddons-3.2.3.ebuild,v 1.2 2004/06/12 12:27:14 caleb Exp $
inherit kde-dist flag-o-matic
@@ -24,4 +24,4 @@ use xmms || export ac_cv_have_xmms=no
# Make vimpart use /usr/bin/kvim -- fixes bug 33257.
# This should continue to apply to upcoming versions since it's
# Gentoo-specific and won't go upstream.
-PATCHES="$FILESDIR/${PN}-3.2.0-kvim.diff"
+PATCHES="$FILESDIR/${PN}-3.2.0-kvim.diff $FILESDIR/${PN}-3.2.3-gcc34.patch"