summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-12-02 13:06:44 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-12-02 13:06:44 +0000
commit4ceb59398f1730df43d82e0abc589caf45282907 (patch)
tree8318807430c9da56e28c6d68c6bff2f7f7af0492 /kde-base
parentRevision bump to default to ruby20. (diff)
downloadgentoo-2-4ceb59398f1730df43d82e0abc589caf45282907.tar.gz
gentoo-2-4ceb59398f1730df43d82e0abc589caf45282907.tar.bz2
gentoo-2-4ceb59398f1730df43d82e0abc589caf45282907.zip
Revision bump to default to ruby20.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/korundum/ChangeLog8
-rw-r--r--kde-base/korundum/korundum-4.14.3-r1.ebuild72
-rw-r--r--kde-base/korundum/korundum-4.14.3.ebuild4
3 files changed, 81 insertions, 3 deletions
diff --git a/kde-base/korundum/ChangeLog b/kde-base/korundum/ChangeLog
index 24aaa339c984..f41f09ec492f 100644
--- a/kde-base/korundum/ChangeLog
+++ b/kde-base/korundum/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/korundum
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/ChangeLog,v 1.227 2014/11/16 12:21:26 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/ChangeLog,v 1.228 2014/12/02 13:06:44 mrueg Exp $
+
+*korundum-4.14.3-r1 (02 Dec 2014)
+
+ 02 Dec 2014; Manuel Rüger <mrueg@gentoo.org> +korundum-4.14.3-r1.ebuild,
+ korundum-4.14.3.ebuild:
+ Revision bump to default to ruby20.
*korundum-4.14.3 (16 Nov 2014)
diff --git a/kde-base/korundum/korundum-4.14.3-r1.ebuild b/kde-base/korundum/korundum-4.14.3-r1.ebuild
new file mode 100644
index 000000000000..1f25fca169b8
--- /dev/null
+++ b/kde-base/korundum/korundum-4.14.3-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/korundum-4.14.3-r1.ebuild,v 1.1 2014/12/02 13:06:44 mrueg Exp $
+
+EAPI=5
+
+OPENGL_REQUIRED="always"
+
+USE_RUBY="ruby20"
+# Only one ruby version is supported:
+# 1) cmake bails when configuring twice or more - solved with CMAKE_IN_SOURCE_BUILD=1
+# 2) the ebuild can only be installed for one ruby variant, otherwise the compiled
+# files with identical path+name will overwrite each other - difficult :(
+
+inherit kde4-base ruby-ng
+
+DESCRIPTION="KDE Ruby bindings"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="akonadi debug kate nepomuk okular"
+HOMEPAGE="http://techbase.kde.org/Development/Languages/Ruby"
+
+DEPEND="
+ $(add_kdebase_dep qtruby 'ruby_targets_ruby20')
+ $(add_kdebase_dep smokekde 'akonadi?,kate?,okular?,nepomuk?')
+ $(add_kdebase_dep smokeqt)
+"
+RDEPEND="${DEPEND}
+"
+
+pkg_setup() {
+ ruby-ng_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_unpack() {
+ local S="${WORKDIR}/${P}"
+ kde4-base_src_unpack
+
+ cd "${WORKDIR}"
+ mkdir all
+ mv ${P} all/ || die "Could not move sources"
+}
+
+all_ruby_prepare() {
+ kde4-base_src_prepare
+}
+
+each_ruby_configure() {
+ CMAKE_USE_DIR=${S}
+ local mycmakeargs=(
+ -DRUBY_LIBRARY=$(ruby_get_libruby)
+ -DRUBY_INCLUDE_PATH=$(ruby_get_hdrdir)
+ -DRUBY_EXECUTABLE=${RUBY}
+ $(cmake-utils_use_with akonadi)
+ $(cmake-utils_use_with akonadi KdepimLibs)
+ $(cmake-utils_use_with nepomuk)
+ $(cmake-utils_use_with nepomuk Soprano)
+ $(cmake-utils_use_disable kate)
+ $(cmake-utils_use_with okular)
+ )
+ kde4-base_src_configure
+}
+
+each_ruby_compile() {
+ CMAKE_USE_DIR=${S}
+ kde4-base_src_compile
+}
+
+each_ruby_install() {
+ CMAKE_USE_DIR=${S}
+ kde4-base_src_install
+}
diff --git a/kde-base/korundum/korundum-4.14.3.ebuild b/kde-base/korundum/korundum-4.14.3.ebuild
index 6695590de9fa..30e78d709395 100644
--- a/kde-base/korundum/korundum-4.14.3.ebuild
+++ b/kde-base/korundum/korundum-4.14.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/korundum-4.14.3.ebuild,v 1.1 2014/11/16 12:21:26 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/korundum-4.14.3.ebuild,v 1.2 2014/12/02 13:06:44 mrueg Exp $
EAPI=5
@@ -20,7 +20,7 @@ IUSE="akonadi debug kate nepomuk okular"
HOMEPAGE="http://techbase.kde.org/Development/Languages/Ruby"
DEPEND="
- $(add_kdebase_dep qtruby)
+ $(add_kdebase_dep qtruby 'ruby_targets_ruby19')
$(add_kdebase_dep smokekde 'akonadi?,kate?,okular?,nepomuk?')
$(add_kdebase_dep smokeqt)
"