summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2015-02-14 22:09:58 +0000
committerJohannes Huber <johu@gentoo.org>2015-02-14 22:09:58 +0000
commit74b62f2ff15457f5192135569c197c6d6fb3c655 (patch)
tree0ae0e3f9483bbf4d3da54d603b86a850aa88a5d4 /kde-frameworks/kio
parentKeyword ~ppc, bug #505998 (diff)
downloadgentoo-2-74b62f2ff15457f5192135569c197c6d6fb3c655.tar.gz
gentoo-2-74b62f2ff15457f5192135569c197c6d6fb3c655.tar.bz2
gentoo-2-74b62f2ff15457f5192135569c197c6d6fb3c655.zip
Version bump KDE Frameworks 5.7.0
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-frameworks/kio')
-rw-r--r--kde-frameworks/kio/ChangeLog8
-rw-r--r--kde-frameworks/kio/files/kio-9999-tests-optional.patch28
-rw-r--r--kde-frameworks/kio/kio-5.7.0.ebuild84
3 files changed, 119 insertions, 1 deletions
diff --git a/kde-frameworks/kio/ChangeLog b/kde-frameworks/kio/ChangeLog
index 84b36067978d..fd1013c1d39a 100644
--- a/kde-frameworks/kio/ChangeLog
+++ b/kde-frameworks/kio/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-frameworks/kio
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-frameworks/kio/ChangeLog,v 1.6 2015/01/09 18:25:30 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-frameworks/kio/ChangeLog,v 1.7 2015/02/14 22:09:57 johu Exp $
+
+*kio-5.7.0 (14 Feb 2015)
+
+ 14 Feb 2015; Johannes Huber <johu@gentoo.org> +kio-5.7.0.ebuild,
+ +files/kio-9999-tests-optional.patch:
+ Version bump KDE Frameworks 5.7.0
*kio-5.6.0 (09 Jan 2015)
diff --git a/kde-frameworks/kio/files/kio-9999-tests-optional.patch b/kde-frameworks/kio/files/kio-9999-tests-optional.patch
new file mode 100644
index 000000000000..ca45d8853f48
--- /dev/null
+++ b/kde-frameworks/kio/files/kio-9999-tests-optional.patch
@@ -0,0 +1,28 @@
+--- a/CMakeLists.txt 2015-01-21 01:30:56.784894492 +0100
++++ b/CMakeLists.txt 2015-01-21 01:34:51.192505604 +0100
+@@ -57,7 +57,7 @@
+ add_definitions(-DQT_NO_URL_CAST_FROM_STRING)
+
+ set(REQUIRED_QT_VERSION 5.2.0)
+-find_package(Qt5 ${REQUIRED_QT_VERSION} CONFIG REQUIRED Widgets DBus Network Concurrent Xml Test)
++find_package(Qt5 ${REQUIRED_QT_VERSION} CONFIG REQUIRED Widgets DBus Network Concurrent Xml)
+
+ find_package(GSSAPI)
+ set_package_properties(GSSAPI PROPERTIES DESCRIPTION "Allows KIO to make use of certain HTTP authentication services"
+@@ -85,10 +85,13 @@
+ endif()
+ include(CheckLibraryExists)
+ add_subdirectory(src)
+-add_subdirectory(autotests)
+
+-if (NOT KIOCORE_ONLY)
+-add_subdirectory(tests)
++if(BUILD_TESTING)
++ find_package(Qt5Test ${REQUIRED_QT_VERSION} CONFIG REQUIRED)
++ add_subdirectory(autotests)
++ if (NOT KIOCORE_ONLY)
++ add_subdirectory(tests)
++ endif()
+ endif()
+
+ # create a Config.cmake and a ConfigVersion.cmake file and install them
diff --git a/kde-frameworks/kio/kio-5.7.0.ebuild b/kde-frameworks/kio/kio-5.7.0.ebuild
new file mode 100644
index 000000000000..c0f2dd7ffe14
--- /dev/null
+++ b/kde-frameworks/kio/kio-5.7.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-frameworks/kio/kio-5.7.0.ebuild,v 1.1 2015/02/14 22:09:57 johu Exp $
+
+EAPI=5
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework providing transparent file and data management"
+LICENSE="LGPL-2+"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="acl kerberos X"
+
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtscript:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ dev-libs/libxml2
+ dev-libs/libxslt
+ acl? (
+ sys-apps/attr
+ virtual/acl
+ )
+ kerberos? ( virtual/krb5 )
+ X? ( dev-qt/qtx11extras:5 )
+ !<kde-base/kio-extras-5.0.95-r1:5
+"
+DEPEND="${RDEPEND}
+ $(add_frameworks_dep kdoctools)
+ dev-qt/qtconcurrent:5
+ test? ( sys-libs/zlib )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXrender
+ x11-proto/xproto
+ )
+"
+PDEPEND="
+ $(add_frameworks_dep kded)
+"
+
+# tests hang
+RESTRICT="test"
+
+src_prepare() {
+ # whole patch should be upstreamed, doesn't work in PATCHES
+ epatch "${FILESDIR}/${PN}-9999-tests-optional.patch"
+
+ kde5_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package acl)
+ $(cmake-utils_use_find_package kerberos GSSAPI)
+ $(cmake-utils_use_find_package X X11)
+ )
+
+ kde5_src_configure
+}