summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2005-07-12 09:11:38 +0000
committerTorsten Veller <tove@gentoo.org>2005-07-12 09:11:38 +0000
commit46b478fedc779dca4e3359bf3e8278449cee508f (patch)
tree326d3e82c12b3e5137ebbe397cf791330c31da16 /mail-filter
parentStable on x86 with regard to security bug 97655. (diff)
downloadgentoo-2-46b478fedc779dca4e3359bf3e8278449cee508f.tar.gz
gentoo-2-46b478fedc779dca4e3359bf3e8278449cee508f.tar.bz2
gentoo-2-46b478fedc779dca4e3359bf3e8278449cee508f.zip
Version bump.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/bogofilter/ChangeLog10
-rw-r--r--mail-filter/bogofilter/Manifest14
-rw-r--r--mail-filter/bogofilter/bogofilter-0.95.2.ebuild90
-rw-r--r--mail-filter/bogofilter/files/digest-bogofilter-0.95.21
-rw-r--r--mail-filter/bogofilter/metadata.xml5
5 files changed, 108 insertions, 12 deletions
diff --git a/mail-filter/bogofilter/ChangeLog b/mail-filter/bogofilter/ChangeLog
index 63634d76c42f..ea073f396ae0 100644
--- a/mail-filter/bogofilter/ChangeLog
+++ b/mail-filter/bogofilter/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for mail-filter/bogofilter
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/ChangeLog,v 1.37 2005/06/09 07:31:27 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/ChangeLog,v 1.38 2005/07/12 09:11:37 tove Exp $
+
+*bogofilter-0.95.2 (12 Jul 2005)
+
+ 12 Jul 2005; Torsten Veller <tove@gentoo.org> metadata.xml,
+ +bogofilter-0.95.2.ebuild:
+ Version bump. 0.95.2 supports Unicode (UTF-8).
+ For 64-bit machines that require 8-byte alignment for longword access
+ >=dev-db/sqlite-3.2.2 is needed.
*bogofilter-0.94.14 (09 Jun 2005)
diff --git a/mail-filter/bogofilter/Manifest b/mail-filter/bogofilter/Manifest
index df6842f78d14..d5308e58df41 100644
--- a/mail-filter/bogofilter/Manifest
+++ b/mail-filter/bogofilter/Manifest
@@ -1,16 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 e4bfdf5d18231412651867d6506c9d53 bogofilter-0.94.14.ebuild 2446
MD5 e2285a40ab55c158c5b275ff758c520c bogofilter-0.92.8.ebuild 1572
MD5 b712636d663d8ed749e776ba4861b79a ChangeLog 12246
-MD5 5721b86fd871bdfab77231abc6e02f68 metadata.xml 161
+MD5 48bd0f185b30f8151e8da04a025e0373 metadata.xml 424
+MD5 be0d46ebb29eca8ada85f261fdf45a0b bogofilter-0.95.2.ebuild 2483
MD5 5d294556f965d8a34f818dd691028d3a files/digest-bogofilter-0.94.14 71
MD5 1970df6e6d8dabe53d04a6f120d0b8bb files/digest-bogofilter-0.92.8 70
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFCqJt3V3J2n04EauwRAhVMAKCcpTf9cIJmqGARcrqSuIg82/HhnQCgyv+q
-tLnop2dG0FcV2bvOX0doPNc=
-=GAx7
------END PGP SIGNATURE-----
+MD5 36abbe0564d3ec8d59dabd4c15f21f25 files/digest-bogofilter-0.95.2 70
diff --git a/mail-filter/bogofilter/bogofilter-0.95.2.ebuild b/mail-filter/bogofilter/bogofilter-0.95.2.ebuild
new file mode 100644
index 000000000000..27be413c4e89
--- /dev/null
+++ b/mail-filter/bogofilter/bogofilter-0.95.2.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/bogofilter-0.95.2.ebuild,v 1.1 2005/07/12 09:11:37 tove Exp $
+
+inherit eutils
+
+DESCRIPTION="Bayesian spam filter designed with fast algorithms, and tuned for speed."
+HOMEPAGE="http://bogofilter.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bogofilter/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+#KEYWORDS="${KEYWORDS} ~arm ~mips" # missing, see bug #74046
+IUSE="doc gsl berkdb sqlite"
+
+DEPEND="
+ || (
+ sys-libs/glibc
+ dev-libs/libiconv
+ )
+ berkdb? ( >=sys-libs/db-3.2 )
+ !berkdb? (
+ sqlite? ( >=dev-db/sqlite-3.2.2 )
+ !sqlite? ( >=sys-libs/db-3.2 )
+ )
+ gsl? ( sci-libs/gsl )"
+# app-arch/pax" # only needed for bf_tar
+
+pkg_setup() {
+ einfo ""
+ einfo "It is best to dump or backup your wordlists BEFORE upgrading!"
+ einfo ""
+ epause 3
+}
+
+src_compile() {
+ local myconf=""
+ useq !gsl && myconf="${myconf} --with-included-gsl" # 'without-' doesn't work
+# myconf="$(use_with !gsl included-gsl)"
+
+ # determine backend: berkdb *is* default
+ if useq berkdb && useq sqlite ; then
+ einfo "Both berkdb and sqlite are in USE."
+ einfo "Choosing berkdb as default database backend."
+ elif useq sqlite ; then
+ myconf="${myconf} --with-database=sqlite"
+ elif ! useq berkdb ; then
+ einfo "Using berkdb as database backend."
+ fi
+
+ econf ${myconf} || die "could not configure"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ exeinto /usr/share/${PN}/contrib
+ doexe contrib/{bogofilter-qfe,bogogrep,mime.get.rfc822,parmtest.sh}
+ doexe contrib/{randomtrain,scramble,*.pl}
+
+ insinto /usr/share/${PN}/contrib
+ doins contrib/{README.*,bogo.R,bogogrep.c,dot-qmail-bogofilter-default}
+ doins contrib/{trainbogo.sh,*.example}
+
+ dodoc AUTHORS COPYING INSTALL NEWS README
+ dodoc RELEASE.NOTES* TODO doc/integrating-with-*
+ dodoc GETTING.STARTED doc/README.{db,sqlite}
+
+ dodir /usr/share/doc/${PF}/samples
+ mv ${D}/etc/* ${D}/usr/share/doc/${PF}/samples/
+ rmdir ${D}/etc
+
+ if useq doc; then
+ dohtml doc/*.html
+ else
+ dohtml doc/bogofilter-faq{,-fr}.html doc/bogofilter-tuning.HOWTO.html
+ fi
+}
+
+pkg_postinst() {
+ ewarn ""
+ ewarn "Incompatible changes in bogofilter-0.93 and -0.94:"
+ ewarn "Please read the documentation (RELEASE.NOTES)!"
+ ewarn ""
+ einfo ""
+ einfo "If you need ${ROOT}usr/bin/bf_tar please install app-arch/pax."
+ einfo ""
+}
diff --git a/mail-filter/bogofilter/files/digest-bogofilter-0.95.2 b/mail-filter/bogofilter/files/digest-bogofilter-0.95.2
new file mode 100644
index 000000000000..c88b7e6477d1
--- /dev/null
+++ b/mail-filter/bogofilter/files/digest-bogofilter-0.95.2
@@ -0,0 +1 @@
+MD5 43da78d185f6a206923e6fb8e50c6fe7 bogofilter-0.95.2.tar.bz2 725106
diff --git a/mail-filter/bogofilter/metadata.xml b/mail-filter/bogofilter/metadata.xml
index 51f94e3fbe0e..00acb1c62c7b 100644
--- a/mail-filter/bogofilter/metadata.xml
+++ b/mail-filter/bogofilter/metadata.xml
@@ -2,4 +2,9 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>net-mail</herd>
+<longdescription>
+ Bogofilter is a mail filter that classifies mail as spam or ham (non-spam)
+ by a statistical analysis of the message's header and content (body). The
+ program is able to learn from the user's classifications and corrections.
+</longdescription>
</pkgmetadata>