summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2004-05-30 22:46:58 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2004-05-30 22:46:58 +0000
commit8615e6c4839d5f97529f843b20a1808a3bb3db65 (patch)
tree2884e4dfe7a407e3c1ec0fad70649b16dc848a0c /mail-mta
parentMerged into gentoo-dev-sources (diff)
downloadgentoo-2-8615e6c4839d5f97529f843b20a1808a3bb3db65.tar.gz
gentoo-2-8615e6c4839d5f97529f843b20a1808a3bb3db65.tar.bz2
gentoo-2-8615e6c4839d5f97529f843b20a1808a3bb3db65.zip
Not quite right yet. Adding virtual/mta blocker if mailwrapper not in USE.
Diffstat (limited to 'mail-mta')
-rw-r--r--mail-mta/ssmtp/ssmtp-2.60.7-r1.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/mail-mta/ssmtp/ssmtp-2.60.7-r1.ebuild b/mail-mta/ssmtp/ssmtp-2.60.7-r1.ebuild
index 17d939f77cd0..fd6990416b8c 100644
--- a/mail-mta/ssmtp/ssmtp-2.60.7-r1.ebuild
+++ b/mail-mta/ssmtp/ssmtp-2.60.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/ssmtp/ssmtp-2.60.7-r1.ebuild,v 1.2 2004/05/30 22:26:09 g2boojum Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/ssmtp/ssmtp-2.60.7-r1.ebuild,v 1.3 2004/05/30 22:46:58 g2boojum Exp $
inherit eutils
@@ -16,6 +16,7 @@ IUSE="ssl ipv6 md5sum mailwrapper"
DEPEND="virtual/glibc
ssl? ( dev-libs/openssl )"
RDEPEND="mailwrapper? ( =net-mail/mailwrapper-0.1 )
+ !mailwrapper? ( !virtual/mta )
net-mail/mailbase
ssl? ( dev-libs/openssl )"
PROVIDE="virtual/mta"
@@ -84,3 +85,13 @@ src_install() {
# mv ${conffile}.pre ${conffile}
#fi
}
+
+pkg_postinst() {
+ if ! use mailwrapper && [[ -e /etc/mailer.conf ]]
+ then
+ einfo
+ einfo "Since you emerged ssmtp w/o mailwrapper in USE,"
+ einfo "you probably want to 'emerge -C mailwrapper' now."
+ einfo
+ fi
+}