summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-12-23 21:59:07 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2014-12-23 21:59:07 +0000
commit395f7a93a3f2773f84307720089aa181fff43eb0 (patch)
tree37c23712781bd70729c9e42d94b647ec3f97b9c7 /media-gfx/eog
parentDisable LTO unconditionally on 1.12.16* since it does not work properly (bug ... (diff)
downloadgentoo-2-395f7a93a3f2773f84307720089aa181fff43eb0.tar.gz
gentoo-2-395f7a93a3f2773f84307720089aa181fff43eb0.tar.bz2
gentoo-2-395f7a93a3f2773f84307720089aa181fff43eb0.zip
Version bump for Gnome 3.14.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'media-gfx/eog')
-rw-r--r--media-gfx/eog/ChangeLog7
-rw-r--r--media-gfx/eog/eog-3.14.3.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/media-gfx/eog/ChangeLog b/media-gfx/eog/ChangeLog
index f87bf8281d9b..6c79057fba84 100644
--- a/media-gfx/eog/ChangeLog
+++ b/media-gfx/eog/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/eog
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/ChangeLog,v 1.317 2014/11/13 12:17:18 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/ChangeLog,v 1.318 2014/12/23 21:59:07 eva Exp $
+
+*eog-3.14.3 (23 Dec 2014)
+
+ 23 Dec 2014; Gilles Dartiguelongue <eva@gentoo.org> +eog-3.14.3.ebuild:
+ Version bump for Gnome 3.14.
13 Nov 2014; Pacho Ramos <pacho@gentoo.org> -eog-2.32.1.ebuild,
-eog-3.10.2.ebuild, -eog-3.12.1.ebuild, -files/eog-2.32.1-gmodule.patch:
diff --git a/media-gfx/eog/eog-3.14.3.ebuild b/media-gfx/eog/eog-3.14.3.ebuild
new file mode 100644
index 000000000000..66af9d9078ef
--- /dev/null
+++ b/media-gfx/eog/eog-3.14.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/eog-3.14.3.ebuild,v 1.1 2014/12/23 21:59:07 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="The Eye of GNOME image viewer"
+HOMEPAGE="https://wiki.gnome.org/Apps/EyeOfGnome"
+
+LICENSE="GPL-2+"
+SLOT="1"
+IUSE="+exif +introspection +jpeg lcms +svg tiff xmp"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+REQUIRED_USE="exif? ( jpeg )"
+
+RDEPEND="
+ >=x11-libs/gtk+-3.14:3[introspection,X]
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/libxml2-2:2
+ >=dev-libs/libpeas-0.7.4:=[gtk]
+ >=gnome-base/gnome-desktop-2.91.2:3=
+ >=gnome-base/gsettings-desktop-schemas-2.91.92
+ >=x11-misc/shared-mime-info-0.20
+
+ x11-libs/gdk-pixbuf:2[jpeg?,tiff?]
+ x11-libs/libX11
+
+ exif? ( >=media-libs/libexif-0.6.14 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.3 )
+ jpeg? ( virtual/jpeg:0 )
+ lcms? ( media-libs/lcms:2 )
+ svg? ( >=gnome-base/librsvg-2.36.2:2 )
+ xmp? ( media-libs/exempi:2 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.16
+ >=dev-util/intltool-0.50.1
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README THANKS TODO"
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ $(use_with jpeg libjpeg) \
+ $(use_with exif libexif) \
+ $(use_with lcms cms) \
+ $(use_with xmp) \
+ $(use_with svg librsvg) \
+ ITSTOOL=$(type -P true)
+}