summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn N. Laliberte <allanonjl@gentoo.org>2005-07-16 02:18:13 +0000
committerJohn N. Laliberte <allanonjl@gentoo.org>2005-07-16 02:18:13 +0000
commit44f566c969f1292b74e3abb7fd27fbd86163c931 (patch)
tree727fae7b7b537ed1657026fffdf3801837e63350 /media-gfx/gimp/gimp-1.2.5.ebuild
parentremove pointless code (diff)
downloadgentoo-2-44f566c969f1292b74e3abb7fd27fbd86163c931.tar.gz
gentoo-2-44f566c969f1292b74e3abb7fd27fbd86163c931.tar.bz2
gentoo-2-44f566c969f1292b74e3abb7fd27fbd86163c931.zip
filter ffast-math because gimp needs accuracy. fixes #98685
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'media-gfx/gimp/gimp-1.2.5.ebuild')
-rw-r--r--media-gfx/gimp/gimp-1.2.5.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/media-gfx/gimp/gimp-1.2.5.ebuild b/media-gfx/gimp/gimp-1.2.5.ebuild
index 69e6c575768d..bdd116b1377e 100644
--- a/media-gfx/gimp/gimp-1.2.5.ebuild
+++ b/media-gfx/gimp/gimp-1.2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.2.5.ebuild,v 1.21 2005/02/03 04:18:25 joem Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.2.5.ebuild,v 1.22 2005/07/16 02:18:13 allanonjl Exp $
inherit eutils flag-o-matic
@@ -44,7 +44,8 @@ src_compile() {
# over-optimisations (#21787)
replace-flags -Os -O2
# gimp has inline functions (plug-ins/common/grid.c) (#23078)
- filter-flags "-fno-inline"
+ # gimp uses floating point math, needs accuracy (#98685)
+ filter-flags "-fno-inline" "-ffast-math"
local mymake=""
local AA