summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriele Giorgetti <stroke@gentoo.org>2002-06-01 21:03:30 +0000
committerGabriele Giorgetti <stroke@gentoo.org>2002-06-01 21:03:30 +0000
commit9137113809c85f9426a5c6d5d9b47093e88c7b6e (patch)
tree107f55b00c07f7c74838b0cf628fdc5bd7ec1817 /media-gfx/gtkam
parentAdded another patch. This one for gcc3.1 support. (diff)
downloadgentoo-2-9137113809c85f9426a5c6d5d9b47093e88c7b6e.tar.gz
gentoo-2-9137113809c85f9426a5c6d5d9b47093e88c7b6e.tar.bz2
gentoo-2-9137113809c85f9426a5c6d5d9b47093e88c7b6e.zip
gtkam added. Initial version. - stroke
Diffstat (limited to 'media-gfx/gtkam')
-rw-r--r--media-gfx/gtkam/ChangeLog13
-rw-r--r--media-gfx/gtkam/files/digest-gtkam-0.1.41
-rw-r--r--media-gfx/gtkam/gtkam-0.1.4.ebuild43
3 files changed, 57 insertions, 0 deletions
diff --git a/media-gfx/gtkam/ChangeLog b/media-gfx/gtkam/ChangeLog
new file mode 100644
index 000000000000..701022ee08a3
--- /dev/null
+++ b/media-gfx/gtkam/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for media-gfx/gtkam
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gtkam/ChangeLog,v 1.1 2002/06/01 21:03:30 stroke Exp $
+
+*gtkam-0.1.4 (1 June 2002)
+
+ 1 June 2002; Lasse Mikkelsen <lbm@fatalerror.dk> gtkam-0.1.4.ebuild :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/media-gfx/gtkam/files/digest-gtkam-0.1.4 b/media-gfx/gtkam/files/digest-gtkam-0.1.4
new file mode 100644
index 000000000000..171d966323ef
--- /dev/null
+++ b/media-gfx/gtkam/files/digest-gtkam-0.1.4
@@ -0,0 +1 @@
+MD5 6e21303d062f3bb5c3ff171a3a44df19 gtkam-0.1.4.tar.gz 349702
diff --git a/media-gfx/gtkam/gtkam-0.1.4.ebuild b/media-gfx/gtkam/gtkam-0.1.4.ebuild
new file mode 100644
index 000000000000..dc9ac799dc44
--- /dev/null
+++ b/media-gfx/gtkam/gtkam-0.1.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gtkam/gtkam-0.1.4.ebuild,v 1.1 2002/06/01 21:03:30 stroke Exp $
+
+DESCRIPTION="A frontend for gPhoto 2"
+HOMEPAGE="http://gphoto.org/gphoto2/gtk.html"
+LICENSE="GPL-2"
+
+SRC_URI="http://telia.dl.sourceforge.net/sourceforge/gphoto/${P}.tar.gz
+ http://unc.dl.sourceforge.net/sourceforge/gphoto/${P}.tar.gz
+ http://belnet.dl.sourceforge.net/sourceforge/gphoto/${P}.tar.gz"
+
+SLOT="0"
+
+DEPEND=">=x11-libs/gtk+-1.2.10-r7
+ >=media-libs/gdk-pixbuf-0.17.0
+ >=media-gfx/gphoto2-2.0-r1"
+RDEPEND="${DEPEND}"
+
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --without-gimp || die
+
+ emake || die
+}
+
+src_install () {
+
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ dodoc ABOUT-NLS AUTHORS COPYING INSTALL MANUAL NEWS README
+}