summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-03-13 12:02:36 +0000
committerMamoru Komachi <usata@gentoo.org>2004-03-13 12:02:36 +0000
commit690c390d10af63a13405344ea79ae8513d4d5765 (patch)
treeb3412ec882026f2b070b97f9a3662c73bf2b2a57 /media-gfx/xloadimage/xloadimage-4.1-r1.ebuild
parentfixing broken commit (diff)
downloadgentoo-2-690c390d10af63a13405344ea79ae8513d4d5765.tar.gz
gentoo-2-690c390d10af63a13405344ea79ae8513d4d5765.tar.bz2
gentoo-2-690c390d10af63a13405344ea79ae8513d4d5765.zip
Moved from x11-misc to media-gfx. Fixed conflict between xli, see bug #26751
Diffstat (limited to 'media-gfx/xloadimage/xloadimage-4.1-r1.ebuild')
-rw-r--r--media-gfx/xloadimage/xloadimage-4.1-r1.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/media-gfx/xloadimage/xloadimage-4.1-r1.ebuild b/media-gfx/xloadimage/xloadimage-4.1-r1.ebuild
new file mode 100644
index 000000000000..082183054af6
--- /dev/null
+++ b/media-gfx/xloadimage/xloadimage-4.1-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xloadimage/xloadimage-4.1-r1.ebuild,v 1.1 2004/03/13 12:02:36 usata Exp $
+
+inherit alternatives
+
+MY_P="${P/-/.}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="utility to view many different types of images under X11"
+HOMEPAGE="http://world.std.com/~jimf/xloadimage.html"
+SRC_URI="ftp://ftp.x.org/R5contrib/${MY_P}.tar.gz
+ mirror://gentoo/${P}-gentoo.diff.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="x86 sparc ppc alpha hppa amd64 ia64"
+IUSE="tiff jpeg png"
+
+DEPEND=">=sys-apps/sed-4.0.5
+ virtual/x11
+ tiff? ( media-libs/tiff )
+ png? ( media-libs/libpng )
+ jpeg? ( media-libs/jpeg )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${WORKDIR}/${P}-gentoo.diff
+
+ # Do not define errno extern, but rather include errno.h
+ # <azarah@gentoo.org> (1 Jan 2003)
+ epatch ${FILESDIR}/${P}-include-errno_h.patch
+
+ sed -i "s:OPT_FLAGS=:OPT_FLAGS=$CFLAGS:" Make.conf
+
+ chmod +x ${S}/configure
+ sed -i "s:^#include <varargs.h>:#include <stdarg.h>:" ${S}/rlelib.c
+}
+
+src_install() {
+ dobin xloadimage
+ dobin uufilter
+
+ insinto /etc/X11
+ doins xloadimagerc
+
+ newman xloadimage.man xloadimage.1
+ newman uufilter.man uufilter.1
+
+ dodoc README
+}
+
+update_alternatives() {
+ alternatives_makesym /usr/bin/xview \
+ /usr/bin/{xloadimage,xli}
+ alternatives_makesym /usr/bin/xsetbg \
+ /usr/bin/{xloadimage,xli}
+ alternatives_makesym /usr/share/man/man1/xview.1.gz \
+ /usr/share/man/man1/{xloadimage,xli}.1.gz
+ alternatives_makesym /usr/share/man/man1/xsetbg.1.gz \
+ /usr/share/man/man1/{xloadimage,xli}.1.gz
+}
+
+pkg_postinst() {
+ update_alternatives
+}
+
+pkg_postrm() {
+ update_alternatives
+}