summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2005-06-06 13:01:47 +0000
committerMarinus Schraal <foser@gentoo.org>2005-06-06 13:01:47 +0000
commit565d54613ce68541875b5236b777c5c311cc1d9c (patch)
tree0323ae09915ced592a472cc0d6752f0dc2ff1871 /media-gfx
parentStable on x86, bug #87579. (diff)
downloadgentoo-2-565d54613ce68541875b5236b777c5c311cc1d9c.tar.gz
gentoo-2-565d54613ce68541875b5236b777c5c311cc1d9c.tar.bz2
gentoo-2-565d54613ce68541875b5236b777c5c311cc1d9c.zip
fix fix you know it's braincells i miss
(Portage version: 2.0.51.19)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/eog/eog-2.10.0.ebuild9
-rw-r--r--media-gfx/eog/eog-2.4.1.ebuild37
-rw-r--r--media-gfx/eog/eog-2.6.1.ebuild43
-rw-r--r--media-gfx/eog/eog-2.8.0.ebuild44
-rw-r--r--media-gfx/eog/eog-2.8.1.ebuild44
-rw-r--r--media-gfx/eog/eog-2.8.2.ebuild8
-rw-r--r--media-gfx/eog/eog-2.9.0.ebuild42
-rw-r--r--media-gfx/eog/files/digest-eog-2.4.11
-rw-r--r--media-gfx/eog/files/digest-eog-2.6.11
-rw-r--r--media-gfx/eog/files/digest-eog-2.8.01
-rw-r--r--media-gfx/eog/files/digest-eog-2.8.11
-rw-r--r--media-gfx/eog/files/digest-eog-2.9.01
-rw-r--r--media-gfx/eog/files/eog-2.6.1-libexif-0.6.patch24
13 files changed, 15 insertions, 241 deletions
diff --git a/media-gfx/eog/eog-2.10.0.ebuild b/media-gfx/eog/eog-2.10.0.ebuild
index 4c16cd6f2cd5..12540de4af99 100644
--- a/media-gfx/eog/eog-2.10.0.ebuild
+++ b/media-gfx/eog/eog-2.10.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/eog-2.10.0.ebuild,v 1.1 2005/04/19 01:47:06 joem Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/eog-2.10.0.ebuild,v 1.2 2005/06/06 13:01:47 foser Exp $
inherit gnome2 eutils
@@ -40,3 +40,10 @@ src_unpack() {
epatch ${FILESDIR}/${PN}-2.8.0-jpeg_build.patch
}
+
+src_install() {
+
+ # fix #92920 FIXME
+ gnome2_src_install scrollkeeper_localstate_dir=${D}/var/lib/scrollkeeper/
+
+}
diff --git a/media-gfx/eog/eog-2.4.1.ebuild b/media-gfx/eog/eog-2.4.1.ebuild
deleted file mode 100644
index b0f5af1fee25..000000000000
--- a/media-gfx/eog/eog-2.4.1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/eog-2.4.1.ebuild,v 1.10 2005/01/01 14:52:58 weeve Exp $
-
-inherit gnome2
-
-IUSE="jpeg"
-
-DESCRIPTION="the Eye Of Gnome - Image Viewer and Cataloger for Gnome2"
-HOMEPAGE="http://www.gnome.org/"
-
-SLOT="1"
-LICENSE="GPL-2"
-KEYWORDS="x86 ppc alpha sparc hppa amd64 ia64 mips"
-
-RDEPEND=">=x11-libs/gtk+-2.2.1
- >=gnome-base/gconf-2.2
- dev-libs/popt
- >=gnome-base/gnome-vfs-2.2
- >=gnome-base/libgnomeui-2.2
- >=gnome-base/libgnomecanvas-2
- >=gnome-base/libbonoboui-2.3.3
- >=gnome-base/libglade-2.0.1
- >=gnome-base/eel-2.2
- >=media-libs/libart_lgpl-2.2
- >=gnome-base/libgnomeprintui-2.2.1.1
- jpeg? ( >=media-libs/libexif-0.5.10
- media-libs/jpeg )"
-
-DEPEND="${RDEPEND}
- app-text/scrollkeeper
- >=dev-util/pkgconfig-0.12.0"
-
-G2CONF="${G2CONF} $(use_with jpeg libjpeg)"
-
-DOCS="AUTHORS ChangeLog COPYING README INSTALL NEWS HACKING DEPENDS THANKS TODO"
-
diff --git a/media-gfx/eog/eog-2.6.1.ebuild b/media-gfx/eog/eog-2.6.1.ebuild
deleted file mode 100644
index 698f77c29814..000000000000
--- a/media-gfx/eog/eog-2.6.1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/eog-2.6.1.ebuild,v 1.12 2005/01/01 14:52:58 weeve Exp $
-
-inherit gnome2 eutils
-
-DESCRIPTION="Eye Of Gnome, an image viewer"
-HOMEPAGE="http://www.gnome.org/"
-LICENSE="GPL-2"
-
-SLOT="1"
-IUSE="jpeg"
-KEYWORDS="x86 ppc alpha sparc hppa amd64 ~ia64 mips ppc64"
-
-RDEPEND=">=x11-libs/gtk+-2.4
- >=gnome-base/gconf-2.6
- dev-libs/popt
- >=gnome-base/gnome-vfs-2.6
- >=gnome-base/libgnomeui-2.6
- >=gnome-base/libgnomecanvas-2.6
- >=gnome-base/libbonobo-2.6
- >=gnome-base/libbonoboui-2.6
- >=gnome-base/libglade-2.3.6
- >=media-libs/libart_lgpl-2.3.16
- >=gnome-base/libgnomeprintui-2.6
- >=gnome-base/eel-2.6
- jpeg? ( >=media-libs/libexif-0.5.12
- media-libs/jpeg )"
-
-DEPEND="${RDEPEND}
- app-text/scrollkeeper
- >=dev-util/intltool-0.29
- >=dev-util/pkgconfig-0.12.0"
-
-G2CONF="${G2CONF} $(use_with jpeg libjpeg) $(use_with jpeg libexif)"
-
-DOCS="AUTHORS ChangeLog COPYING README INSTALL NEWS HACKING DEPENDS THANKS TODO"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- has_version '>=media-libs/libexif-0.6' && epatch ${FILESDIR}/${P}-libexif-0.6.patch
-}
diff --git a/media-gfx/eog/eog-2.8.0.ebuild b/media-gfx/eog/eog-2.8.0.ebuild
deleted file mode 100644
index 6701a66dfd41..000000000000
--- a/media-gfx/eog/eog-2.8.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/eog-2.8.0.ebuild,v 1.6 2005/01/01 14:52:58 weeve Exp $
-
-inherit gnome2 eutils
-
-DESCRIPTION="Eye Of Gnome, an image viewer"
-HOMEPAGE="http://www.gnome.org/"
-LICENSE="GPL-2"
-
-SLOT="1"
-IUSE="jpeg"
-KEYWORDS="x86 ppc ~alpha sparc ~hppa ~amd64 ~ia64 ~mips ~ppc64"
-
-RDEPEND=">=x11-libs/gtk+-2.4
- >=gnome-base/gconf-2.6
- dev-libs/popt
- >=gnome-base/gnome-vfs-2.6
- >=gnome-base/libgnomeui-2.6
- >=gnome-base/libgnomecanvas-2.6
- >=gnome-base/libglade-2.4
- >=media-libs/libart_lgpl-2.3.16
- >=gnome-base/eel-2.6
- jpeg? ( >=media-libs/libexif-0.5.12
- media-libs/jpeg )"
-
-DEPEND="${RDEPEND}
- app-text/scrollkeeper
- >=dev-util/intltool-0.29
- >=dev-util/pkgconfig-0.12.0"
-
-G2CONF="${G2CONF} $(use_with jpeg libjpeg) $(use_with jpeg libexif)"
-
-DOCS="AUTHORS ChangeLog COPYING README INSTALL NEWS HACKING DEPENDS THANKS TODO"
-
-src_unpack() {
-
- unpack ${A}
-
- cd ${S}
- epatch ${FILESDIR}/${P}-jpeg_build.patch
-
-}
-
diff --git a/media-gfx/eog/eog-2.8.1.ebuild b/media-gfx/eog/eog-2.8.1.ebuild
deleted file mode 100644
index 41bd160e4611..000000000000
--- a/media-gfx/eog/eog-2.8.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/eog-2.8.1.ebuild,v 1.5 2005/01/01 14:52:58 weeve Exp $
-
-inherit gnome2 eutils
-
-DESCRIPTION="Eye Of Gnome, an image viewer"
-HOMEPAGE="http://www.gnome.org/"
-LICENSE="GPL-2"
-
-SLOT="1"
-IUSE="jpeg"
-KEYWORDS="x86 ~ppc alpha sparc ~hppa ~amd64 ~ia64 ~mips ~ppc64"
-
-RDEPEND=">=x11-libs/gtk+-2.4
- >=gnome-base/gconf-2.6
- dev-libs/popt
- >=gnome-base/gnome-vfs-2.6
- >=gnome-base/libgnomeui-2.6
- >=gnome-base/libgnomecanvas-2.6
- >=gnome-base/libglade-2.4
- >=media-libs/libart_lgpl-2.3.16
- >=gnome-base/eel-2.6
- jpeg? ( >=media-libs/libexif-0.5.12
- media-libs/jpeg )"
-
-DEPEND="${RDEPEND}
- app-text/scrollkeeper
- >=dev-util/intltool-0.29
- >=dev-util/pkgconfig-0.12.0"
-
-G2CONF="${G2CONF} $(use_with jpeg libjpeg) $(use_with jpeg libexif)"
-
-DOCS="AUTHORS ChangeLog COPYING README INSTALL NEWS HACKING DEPENDS THANKS TODO"
-
-src_unpack() {
-
- unpack ${A}
-
- cd ${S}
- # build fix without jpeg support
- epatch ${FILESDIR}/${PN}-2.8.0-jpeg_build.patch
-
-}
diff --git a/media-gfx/eog/eog-2.8.2.ebuild b/media-gfx/eog/eog-2.8.2.ebuild
index 0de6477827af..93081923115c 100644
--- a/media-gfx/eog/eog-2.8.2.ebuild
+++ b/media-gfx/eog/eog-2.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/eog-2.8.2.ebuild,v 1.11 2005/04/08 17:11:19 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/eog-2.8.2.ebuild,v 1.12 2005/06/06 13:01:47 foser Exp $
inherit gnome2 eutils
@@ -41,3 +41,9 @@ src_unpack() {
epatch ${FILESDIR}/${PN}-2.8.0-jpeg_build.patch
}
+
+src_install() {
+
+ gnome2_src_install scrollkeeper_localstate_dir=${D}/var/lib/scrollkeeper/
+
+}
diff --git a/media-gfx/eog/eog-2.9.0.ebuild b/media-gfx/eog/eog-2.9.0.ebuild
deleted file mode 100644
index 539aeb7b7c68..000000000000
--- a/media-gfx/eog/eog-2.9.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/eog-2.9.0.ebuild,v 1.1 2005/03/20 22:53:29 joem Exp $
-
-inherit gnome2 eutils
-
-DESCRIPTION="Eye Of Gnome, an image viewer"
-HOMEPAGE="http://www.gnome.org/"
-
-LICENSE="GPL-2"
-SLOT="1"
-KEYWORDS="~x86 ~ppc ~alpha ~sparc ~hppa ~amd64 ~ia64 ~mips ~ppc64"
-IUSE="jpeg"
-
-RDEPEND=">=x11-libs/gtk+-2.4
- >=gnome-base/gconf-2.6
- dev-libs/popt
- >=gnome-base/gnome-vfs-2.6
- >=gnome-base/libgnomeui-2.6
- >=gnome-base/libgnomecanvas-2.6
- >=gnome-base/libglade-2.4
- >=media-libs/libart_lgpl-2.3.16
- jpeg? ( >=media-libs/libexif-0.5.12
- media-libs/jpeg )"
-
-DEPEND="${RDEPEND}
- app-text/scrollkeeper
- >=dev-util/intltool-0.29
- >=dev-util/pkgconfig-0.12.0"
-
-G2CONF="${G2CONF} $(use_with jpeg libjpeg) $(use_with jpeg libexif)"
-
-DOCS="AUTHORS ChangeLog README NEWS HACKING THANKS TODO"
-
-src_unpack() {
-
- unpack ${A}
- cd ${S}
- # build fix without jpeg support
- epatch ${FILESDIR}/${PN}-2.8.0-jpeg_build.patch
-
-}
diff --git a/media-gfx/eog/files/digest-eog-2.4.1 b/media-gfx/eog/files/digest-eog-2.4.1
deleted file mode 100644
index 93ae8b40a038..000000000000
--- a/media-gfx/eog/files/digest-eog-2.4.1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 a7098a85d0f36591521660cc778ed819 eog-2.4.1.tar.bz2 696930
diff --git a/media-gfx/eog/files/digest-eog-2.6.1 b/media-gfx/eog/files/digest-eog-2.6.1
deleted file mode 100644
index f7b3bae2086a..000000000000
--- a/media-gfx/eog/files/digest-eog-2.6.1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 a7207082b9034e9e24ec7adde744c3a9 eog-2.6.1.tar.bz2 863021
diff --git a/media-gfx/eog/files/digest-eog-2.8.0 b/media-gfx/eog/files/digest-eog-2.8.0
deleted file mode 100644
index 5c26c26fe96a..000000000000
--- a/media-gfx/eog/files/digest-eog-2.8.0
+++ /dev/null
@@ -1 +0,0 @@
-MD5 a6bf46dfc587ee6cffa9f86c12086a8a eog-2.8.0.tar.bz2 805859
diff --git a/media-gfx/eog/files/digest-eog-2.8.1 b/media-gfx/eog/files/digest-eog-2.8.1
deleted file mode 100644
index b773e0acdc35..000000000000
--- a/media-gfx/eog/files/digest-eog-2.8.1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 2bad4006f3ccf15b0153d7b9facbc961 eog-2.8.1.tar.bz2 834279
diff --git a/media-gfx/eog/files/digest-eog-2.9.0 b/media-gfx/eog/files/digest-eog-2.9.0
deleted file mode 100644
index 0334b7093674..000000000000
--- a/media-gfx/eog/files/digest-eog-2.9.0
+++ /dev/null
@@ -1 +0,0 @@
-MD5 be4c2b1dcb1457069d03bf282fccf54b eog-2.9.0.tar.bz2 843143
diff --git a/media-gfx/eog/files/eog-2.6.1-libexif-0.6.patch b/media-gfx/eog/files/eog-2.6.1-libexif-0.6.patch
deleted file mode 100644
index d8ce462efdca..000000000000
--- a/media-gfx/eog/files/eog-2.6.1-libexif-0.6.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- libeog/eog-info-view.c.orig 2004-09-28 13:41:23.987814033 -0600
-+++ libeog/eog-info-view.c 2004-09-28 13:43:09.522474289 -0600
-@@ -246,6 +246,7 @@
- EogInfoView *view;
- EogInfoViewPrivate *priv;
- char *path;
-+ char b[1024];
-
- view = EOG_INFO_VIEW (data);
- priv = view->priv;
-@@ -255,11 +256,11 @@
- path = g_hash_table_lookup (priv->id_path_hash, GINT_TO_POINTER (entry->tag));
-
- if (path != NULL) {
-- set_row_data (store, path, exif_tag_get_name (entry->tag), exif_entry_get_value (entry));
-+ set_row_data (store, path, exif_tag_get_name (entry->tag), exif_entry_get_value (entry, b, sizeof(b)));
- }
- else {
- path = set_row_data (store, NULL,
-- exif_tag_get_name (entry->tag), exif_entry_get_value (entry));
-+ exif_tag_get_name (entry->tag), exif_entry_get_value (entry, b, sizeof(b)));
-
- g_hash_table_insert (priv->id_path_hash,
- GINT_TO_POINTER (entry->tag),