summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2001-11-21 02:36:31 +0000
committerDonny Davies <woodchip@gentoo.org>2001-11-21 02:36:31 +0000
commit690296c58bfe5d38039c77c72d6c38fd0913ddf9 (patch)
treeaf54541daf98ce0bd8959104b4e34bd90c66debb /media-gfx
parentI finished the package after all... removed from package.mask... Must (diff)
downloadgentoo-2-690296c58bfe5d38039c77c72d6c38fd0913ddf9.tar.gz
gentoo-2-690296c58bfe5d38039c77c72d6c38fd0913ddf9.tar.bz2
gentoo-2-690296c58bfe5d38039c77c72d6c38fd0913ddf9.zip
updated version as hinted from incoming. slight tweakage to the mandir stuff.
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/imagemagick/files/digest-imagemagick-5.4.01
-rw-r--r--media-gfx/imagemagick/imagemagick-5.4.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/media-gfx/imagemagick/files/digest-imagemagick-5.4.0 b/media-gfx/imagemagick/files/digest-imagemagick-5.4.0
new file mode 100644
index 000000000000..f764546b7a46
--- /dev/null
+++ b/media-gfx/imagemagick/files/digest-imagemagick-5.4.0
@@ -0,0 +1 @@
+MD5 bb39eff9695e377df23e8ff7c0a624e8 ImageMagick-5.4.0.tar.gz 3612672
diff --git a/media-gfx/imagemagick/imagemagick-5.4.0.ebuild b/media-gfx/imagemagick/imagemagick-5.4.0.ebuild
new file mode 100644
index 000000000000..36fe692189d8
--- /dev/null
+++ b/media-gfx/imagemagick/imagemagick-5.4.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/imagemagick/imagemagick-5.4.0.ebuild,v 1.1 2001/11/21 02:36:31 woodchip Exp $
+
+P=ImageMagick-${PV}
+S=${WORKDIR}/${P}
+DESCRIPTION="A collection of tools and libraries for many image formats"
+SRC_URI="ftp://ftp.fifi.org/pub/ImageMagick/${P}.tar.gz"
+HOMEPAGE="http://www.imagemagick.org"
+
+DEPEND="virtual/glibc sys-devel/gcc >=app-text/dgs-0.5.9.1
+ perl? ( >=sys-devel/perl-5 )
+ >=sys-apps/bzip2-1
+ >=media-libs/freetype-2.0
+ >=media-libs/tiff-3.5.5
+ >=media-libs/libpng-1.0.7
+ virtual/x11
+ virtual/lpr"
+
+RDEPEND="virtual/glibc sys-devel/gcc >app-text/dgs-0.5.9.1
+ >=sys-apps/bzip2-1
+ >=media-libs/tiff-3.5.5
+ >=media-libs/freetype-2.0
+ >=media-libs/libpng-1.0.7"
+
+src_compile() {
+
+ local myconf
+ use perl || myconf="--without-perl"
+
+ ./configure \
+ --prefix=/usr --enable-shared --enable-static --without-xml --without-lcms \
+ --enable-lzw --with-ttf --without-fpx --without-gslib --without-hdf \
+ --without-jbig --without-wmf --with-threads --mandir=/usr/share/man \
+ --build=${CHOST} ${myconf} || die "bad configure"
+
+ emake || die "compile problem"
+}
+
+src_install () {
+
+ make \
+ prefix=${D}/usr \
+ PREFIX=${D}/usr \
+ mandir=${D}/usr/share/man \
+ install || die "install problem"
+
+ dodoc Copyright.txt PLATFORMS.txt QuickStart.txt README.txt TODO.txt
+}