summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-06-12 00:37:59 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-06-12 00:37:59 +0000
commit957474e6291df6aae5d26d06cdbd328051294533 (patch)
tree606af78eaa73f4724f704f68b41bda76dc04fe16 /media-gfx
parentfreshly baked (diff)
downloadgentoo-2-957474e6291df6aae5d26d06cdbd328051294533.tar.gz
gentoo-2-957474e6291df6aae5d26d06cdbd328051294533.tar.bz2
gentoo-2-957474e6291df6aae5d26d06cdbd328051294533.zip
Version rev and a small bugfix. Fixes #3612
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/xsane/ChangeLog9
-rw-r--r--media-gfx/xsane/files/digest-xsane-0.861
-rw-r--r--media-gfx/xsane/xsane-0.86.ebuild35
3 files changed, 44 insertions, 1 deletions
diff --git a/media-gfx/xsane/ChangeLog b/media-gfx/xsane/ChangeLog
index 385b7b9a96c2..2a30fb3d3c0c 100644
--- a/media-gfx/xsane/ChangeLog
+++ b/media-gfx/xsane/ChangeLog
@@ -1,7 +1,14 @@
# ChangeLog for media-gfx/xsane
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/xsane/ChangeLog,v 1.1 2002/02/01 21:53:30 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xsane/ChangeLog,v 1.2 2002/06/12 00:37:59 rphillips Exp $
+*xsane-0.86 (11 June 2002)
+
+ 11 June 2002; Ryan Phillips <rphillips@gentoo.org> xsane-0.86.ebuild :
+
+ Thanks to Bret the ebuild will install the plugin link into the correct
+ location. Updated Revision.
+
*xsane-0.77-r1 (1 Feb 2002)
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
diff --git a/media-gfx/xsane/files/digest-xsane-0.86 b/media-gfx/xsane/files/digest-xsane-0.86
new file mode 100644
index 000000000000..43b011f6822d
--- /dev/null
+++ b/media-gfx/xsane/files/digest-xsane-0.86
@@ -0,0 +1 @@
+MD5 038dffe5643c6988f74e54a6b194732a xsane-0.86.tar.gz 2259870
diff --git a/media-gfx/xsane/xsane-0.86.ebuild b/media-gfx/xsane/xsane-0.86.ebuild
new file mode 100644
index 000000000000..85dc45aa16ae
--- /dev/null
+++ b/media-gfx/xsane/xsane-0.86.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Tools Team <tools@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/media-gfx/xsane/xsane-0.77-r1.ebuild,v 1.2 2002/04/28 04:50:25 seemant Exp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="XSane is a graphical scanning frontend"
+SRC_URI="http://www.xsane.org/download/${P}.tar.gz"
+HOMEPAGE="http://www.xsane.org"
+
+DEPEND="media-gfx/sane-backends media-gfx/gimp"
+
+src_compile() {
+
+ ./configure --enable-gimp --prefix=/usr --mandir=/usr/man --host=${CHOST} || die
+ make || die
+
+}
+
+src_install () {
+
+ make prefix=${D}/usr/ mandir=${D}/usr/man install || die
+ dodoc xsane.[A-Z]*
+ dohtml -r doc
+
+ # link xsane so it is seen as a plugin in gimp
+ if [ -d /usr/lib/gimp/1.2 ]; then
+ mkdir -p ${D}/usr/lib/gimp/1.2/plug-ins
+ ln -sf /usr/bin/xsane ${D}/usr/lib/gimp/1.2/plug-ins
+ fi
+ if [ -d /usr/lib/gimp/1.3 ]; then
+ mkdir -p ${D}/usr/lib/gimp/1.3/plug-ins
+ ln -sf /usr/bin/xsane ${D}/usr/lib/gimp/1.3/plug-ins
+ fi
+}