summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2005-11-30 09:38:30 +0000
committerChris White <chriswhite@gentoo.org>2005-11-30 09:38:30 +0000
commit67c8b060271109f68d8b0a44de61d297ddfbe2e7 (patch)
tree42ce8164da9dd6d55caa82dfe6832b4a2a0a6ad5 /media-libs/a52dec/a52dec-0.7.4.ebuild
parent*** empty log message *** (diff)
downloadgentoo-2-67c8b060271109f68d8b0a44de61d297ddfbe2e7.tar.gz
gentoo-2-67c8b060271109f68d8b0a44de61d297ddfbe2e7.tar.bz2
gentoo-2-67c8b060271109f68d8b0a44de61d297ddfbe2e7.zip
Diffstat (limited to 'media-libs/a52dec/a52dec-0.7.4.ebuild')
-rw-r--r--media-libs/a52dec/a52dec-0.7.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-libs/a52dec/a52dec-0.7.4.ebuild b/media-libs/a52dec/a52dec-0.7.4.ebuild
new file mode 100644
index 000000000000..76c9e126f0f6
--- /dev/null
+++ b/media-libs/a52dec/a52dec-0.7.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-libs/a52dec/a52dec-0.7.4.ebuild,v 1.1 2002/07/29 15:35:40 raker Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="a52dec is a bundle of the liba52 (a free library for decoding ATSC A/52 streams used in DVD, etc) with a test program"
+SRC_URI="http://liba52.sourceforge.net/files/${P}.tar.gz"
+HOMEPAGE="http://liba52.sourceforge.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND=">=sys-devel/autoconf-2.52d-r1"
+
+src_compile() {
+
+ local myconf
+
+ use oss \
+ || myconf="${myconf} --disable-oss"
+
+ use static \
+ && myconf="${myconf} --disable-shared --enable-static" \
+ || myconf="${myconf} --enable-shared --disable-static"
+
+ econf ${myconf} || die
+ make || die
+
+}
+
+src_install() {
+
+ einstall docdir=${D}/usr/share/doc/${PF}/html || die
+
+ dodoc AUTHORS COPYING ChangeLog HISTORY INSTALL NEWS README TODO
+ dodoc doc/liba52.txt
+}