summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2003-06-02 20:16:54 +0000
committerDaniel Robbins <drobbins@gentoo.org>2003-06-02 20:16:54 +0000
commit71b6b445f54dbdf3b89ea909ad5b24d425c259e9 (patch)
tree082ab5b9dcc7d6b7d4295ecdada222f27686387f /media-libs/flac/flac-1.1.0.ebuild
parentImprove my java-config again. (diff)
downloadgentoo-2-71b6b445f54dbdf3b89ea909ad5b24d425c259e9.tar.gz
gentoo-2-71b6b445f54dbdf3b89ea909ad5b24d425c259e9.tar.bz2
gentoo-2-71b6b445f54dbdf3b89ea909ad5b24d425c259e9.zip
alpha support, USE X fix
Diffstat (limited to 'media-libs/flac/flac-1.1.0.ebuild')
-rw-r--r--media-libs/flac/flac-1.1.0.ebuild30
1 files changed, 19 insertions, 11 deletions
diff --git a/media-libs/flac/flac-1.1.0.ebuild b/media-libs/flac/flac-1.1.0.ebuild
index 3699665a5b8a..1bc1c99410ee 100644
--- a/media-libs/flac/flac-1.1.0.ebuild
+++ b/media-libs/flac/flac-1.1.0.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/flac/flac-1.1.0.ebuild,v 1.7 2003/04/25 13:45:33 vapier Exp $
-
-inherit libtool
+# $Header: /var/cvsroot/gentoo-x86/media-libs/flac/flac-1.1.0.ebuild,v 1.8 2003/06/02 20:16:36 drobbins Exp $
DESCRIPTION="=free lossless audio encoder which includes an XMMS plugin"
SRC_URI="mirror://sourceforge/flac/${P}.tar.gz"
@@ -10,24 +8,34 @@ HOMEPAGE="http://flac.sourceforge.net/"
SLOT="0"
LICENSE="GPL-2 LGPL-2"
-KEYWORDS="x86 ppc ~sparc ~alpha"
-IUSE="sse xmms"
+KEYWORDS="x86 ppc ~sparc alpha"
+IUSE="sse xmms X"
RDEPEND="virtual/glibc
media-libs/id3lib
>=media-libs/libogg-1.0_rc2
- xmms? ( media-sound/xmms )"
+ X? ( xmms? ( media-sound/xmms ) )"
+
DEPEND="${RDEPEND}
x86? ( dev-lang/nasm )
sys-apps/gawk"
-src_compile() {
- use xmms || {
+inherit libtool
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ #if X not in use, then don't build in xmms support
+ #if xmms not in use, then don't do it either.
+ #if both X and xmms in use, then do it.
+ if ! use xmms || ! use X
+ then
cp src/Makefile.in src/Makefile.in.orig
- sed -e '/^@FLaC__HAS_XMMS_TRUE/d' \
- src/Makefile.in.orig > src/Makefile.in
- }
+ sed -e '/^@FLaC__HAS_XMMS_TRUE/d' src/Makefile.in.orig > src/Makefile.in || die
+ fi
+}
+src_compile() {
elibtoolize --reverse-deps
local myconf