summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-20 21:47:45 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-20 21:47:45 +0000
commit3338064d40fc66daaa42d15ecc1f2ba95722558f (patch)
tree5ec9226b2980ce887efb2722b990f61a49e652c4 /media-libs/imlib2
parentMarking stable x86, keywording ~sparc (diff)
downloadgentoo-2-3338064d40fc66daaa42d15ecc1f2ba95722558f.tar.gz
gentoo-2-3338064d40fc66daaa42d15ecc1f2ba95722558f.tar.bz2
gentoo-2-3338064d40fc66daaa42d15ecc1f2ba95722558f.zip
fix searching for X libs #93300 and amd64 asm #93314
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'media-libs/imlib2')
-rw-r--r--media-libs/imlib2/files/imlib2-1.2.0.007-x-typo.patch12
-rw-r--r--media-libs/imlib2/imlib2-1.2.0.007.ebuild14
2 files changed, 22 insertions, 4 deletions
diff --git a/media-libs/imlib2/files/imlib2-1.2.0.007-x-typo.patch b/media-libs/imlib2/files/imlib2-1.2.0.007-x-typo.patch
new file mode 100644
index 000000000000..925398232022
--- /dev/null
+++ b/media-libs/imlib2/files/imlib2-1.2.0.007-x-typo.patch
@@ -0,0 +1,12 @@
+http://bugs.gentoo.org/93300
+--- configure
++++ configure
+@@ -20251,7 +20251,7 @@
+ # See if we find them without any special options.
+ # Don't add to $LIBS permanently.
+ ac_save_LIBS=$LIBS
+- LIBS="-lX $LIBS"
++ LIBS="-lX11 $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
diff --git a/media-libs/imlib2/imlib2-1.2.0.007.ebuild b/media-libs/imlib2/imlib2-1.2.0.007.ebuild
index 8a04ee73ee71..e8764c335c34 100644
--- a/media-libs/imlib2/imlib2-1.2.0.007.ebuild
+++ b/media-libs/imlib2/imlib2-1.2.0.007.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/imlib2/imlib2-1.2.0.007.ebuild,v 1.2 2005/05/20 05:01:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/imlib2/imlib2-1.2.0.007.ebuild,v 1.3 2005/05/20 21:47:45 vapier Exp $
EKEY_STATE=snap
-EHACKAUTOGEN=yes
inherit enlightenment
MY_P=${P/_/-}
@@ -19,10 +18,17 @@ DEPEND="=media-libs/freetype-2*
tiff? ( >=media-libs/tiff-3.5.5 )
X? ( virtual/x11 )"
+src_unpack() {
+ enlightenment_src_unpack
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-x-typo.patch
+}
+
src_compile() {
local mymmx=""
- if [ "${ARCH}" == "amd64" ] ; then
- mymmx="--disable-mmx"
+ if [[ ${ARCH} == "amd64" ]] ; then
+ mymmx="--disable-mmx --disable-amd64"
+ [[ ${PV} != "1.2.0.007" ]] && die "revisit amd64 check"
else
mymmx="$(use_enable mmx)"
fi