summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-16 11:36:53 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-16 11:36:53 +0000
commit511e33e9b8ac87b1f15a19ed318c3cab31f3d050 (patch)
treefed6d42b9ed74a42d51f9c784bdc9b264d113851 /media-libs/jpeg
parentadded new licenses to list (diff)
downloadgentoo-2-511e33e9b8ac87b1f15a19ed318c3cab31f3d050.tar.gz
gentoo-2-511e33e9b8ac87b1f15a19ed318c3cab31f3d050.tar.bz2
gentoo-2-511e33e9b8ac87b1f15a19ed318c3cab31f3d050.zip
ppc KEYWORDS and misc fixes
Diffstat (limited to 'media-libs/jpeg')
-rw-r--r--media-libs/jpeg/jpeg-6b-r2.ebuild27
1 files changed, 19 insertions, 8 deletions
diff --git a/media-libs/jpeg/jpeg-6b-r2.ebuild b/media-libs/jpeg/jpeg-6b-r2.ebuild
index e2a7d027d679..cb2bbc904538 100644
--- a/media-libs/jpeg/jpeg-6b-r2.ebuild
+++ b/media-libs/jpeg/jpeg-6b-r2.ebuild
@@ -1,25 +1,36 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/jpeg-6b-r2.ebuild,v 1.3 2002/07/11 06:30:38 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/jpeg-6b-r2.ebuild,v 1.4 2002/07/16 11:36:47 seemant Exp $
-A=jpegsrc.v6b.tar.gz
+MY_P=${PN}src.v${PV}
S=${WORKDIR}/${P}
DESCRIPTION="libjpeg"
-SRC_URI="ftp://ftp.uu.net/graphics/jpeg/${A}"
-#SRC_URI="http://mirror/${A}"
+SRC_URI="ftp://ftp.uu.net/graphics/jpeg/${MY_P}.tar.gz"
HOMEPAGE="http://www.ijg.org/"
DEPEND="virtual/glibc"
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="x86 ppc"
+
src_compile() {
- try ./configure --prefix=/usr --mandir=/usr/share/man --enable-shared --enable-static
- try make
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --enable-shared \
+ --enable-static || die
+
+ make || die
}
src_install() {
- dodir /usr/{include,lib,bin,share/man/man1}
- try make install prefix=${D}/usr mandir=${D}/usr/share/man/man1
+ dodir /usr/{include,lib,bin,share/man/man1}
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man/man1 \
+ install || die
dodoc README change.log structure.doc
}