summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-10-07 02:55:54 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-10-07 02:55:54 +0000
commitf05ac09bf5b9c652a907cc6d9a4b32ad8a2839c7 (patch)
tree418d4a1824254bdad58dec4a86d3123e3688b764 /media-libs/ladspa-sdk/ladspa-sdk-1.12-r2.ebuild
parentget_libdir fixes. (Manifest recommit) (diff)
downloadgentoo-2-f05ac09bf5b9c652a907cc6d9a4b32ad8a2839c7.tar.gz
gentoo-2-f05ac09bf5b9c652a907cc6d9a4b32ad8a2839c7.tar.bz2
gentoo-2-f05ac09bf5b9c652a907cc6d9a4b32ad8a2839c7.zip
get_libdir fixes.
Diffstat (limited to 'media-libs/ladspa-sdk/ladspa-sdk-1.12-r2.ebuild')
-rw-r--r--media-libs/ladspa-sdk/ladspa-sdk-1.12-r2.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/media-libs/ladspa-sdk/ladspa-sdk-1.12-r2.ebuild b/media-libs/ladspa-sdk/ladspa-sdk-1.12-r2.ebuild
index b8128b6490d0..256bc371a88a 100644
--- a/media-libs/ladspa-sdk/ladspa-sdk-1.12-r2.ebuild
+++ b/media-libs/ladspa-sdk/ladspa-sdk-1.12-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/ladspa-sdk/ladspa-sdk-1.12-r2.ebuild,v 1.5 2004/09/16 03:47:58 kito Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ladspa-sdk/ladspa-sdk-1.12-r2.ebuild,v 1.6 2004/10/07 02:53:46 eradicator Exp $
inherit eutils
@@ -46,7 +46,7 @@ src_test() {
src_install() {
make \
- INSTALL_PLUGINS_DIR=${D}/usr/lib/ladspa \
+ INSTALL_PLUGINS_DIR=${D}/usr/$(get_libdir)/ladspa \
INSTALL_INCLUDE_DIR=${D}/usr/include \
INSTALL_BINARY_DIR=${D}/usr/bin \
install || die "make install failed"
@@ -56,5 +56,5 @@ src_install() {
# Needed for apps like rezound
dodir /etc/env.d
- echo "LADSPA_PATH=/usr/lib/ladspa" > ${D}/etc/env.d/60ladspa
+ echo "LADSPA_PATH=/usr/$(get_libdir)/ladspa" > ${D}/etc/env.d/60ladspa
}