summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-10-11 01:39:11 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-10-11 01:39:11 +0000
commit8ce2553bee45f83412631282b357ce0c4b318ee9 (patch)
tree8212c88a4bec958950add0b788b5ed8d29011502 /media-libs/libdvbpsi
parentUse libtirpc for USE=rpc support #370995 by Diego Elio Pettenò. Migrate awa... (diff)
downloadgentoo-2-8ce2553bee45f83412631282b357ce0c4b318ee9.tar.gz
gentoo-2-8ce2553bee45f83412631282b357ce0c4b318ee9.tar.bz2
gentoo-2-8ce2553bee45f83412631282b357ce0c4b318ee9.zip
USE="static-libs" and remove useless libtool archive. Force recent enough graphviz wrt #181147 in order to remove pkg_setup() test.
(Portage version: 2.2.0_alpha64/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libdvbpsi')
-rw-r--r--media-libs/libdvbpsi/ChangeLog6
-rw-r--r--media-libs/libdvbpsi/libdvbpsi-0.2.1.ebuild58
2 files changed, 26 insertions, 38 deletions
diff --git a/media-libs/libdvbpsi/ChangeLog b/media-libs/libdvbpsi/ChangeLog
index 5075eda356f3..aa4869eb8864 100644
--- a/media-libs/libdvbpsi/ChangeLog
+++ b/media-libs/libdvbpsi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libdvbpsi
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libdvbpsi/ChangeLog,v 1.43 2011/09/20 17:50:21 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdvbpsi/ChangeLog,v 1.44 2011/10/11 01:39:11 ssuominen Exp $
+
+ 11 Oct 2011; Samuli Suominen <ssuominen@gentoo.org> libdvbpsi-0.2.1.ebuild:
+ USE="static-libs" and remove useless libtool archive. Force recent enough
+ graphviz wrt #181147 in order to remove pkg_setup() test.
*libdvbpsi-0.2.1 (20 Sep 2011)
diff --git a/media-libs/libdvbpsi/libdvbpsi-0.2.1.ebuild b/media-libs/libdvbpsi/libdvbpsi-0.2.1.ebuild
index 293a46e8b30f..d3fd460a421a 100644
--- a/media-libs/libdvbpsi/libdvbpsi-0.2.1.ebuild
+++ b/media-libs/libdvbpsi/libdvbpsi-0.2.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libdvbpsi/libdvbpsi-0.2.1.ebuild,v 1.1 2011/09/20 17:50:21 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdvbpsi/libdvbpsi-0.2.1.ebuild,v 1.2 2011/10/11 01:39:11 ssuominen Exp $
-IUSE="doc"
+EAPI=4
DESCRIPTION="library for MPEG TS/DVB PSI tables decoding and generation"
HOMEPAGE="http://www.videolan.org/libdvbpsi"
@@ -10,47 +10,31 @@ SRC_URI="http://download.videolan.org/pub/${PN}/${PV}/${P}.tar.bz2"
LICENSE="LGPL-2.1"
SLOT="0"
-# doxygen missing: ~ia64
KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc static-libs"
-DEPEND="doc? (
- >=app-doc/doxygen-1.2.16
- media-gfx/graphviz
- )"
RDEPEND=""
-
-pkg_setup() {
- if use doc; then
- # Making the documentation requires that /usr/bin/dot from
- # media-libs/graphviz supports PNG output.
- # This is an automagic dependency :(, Bug #181147
- # Check that /usr/bin/dot supports png by calling it with
- # an unsupported format (-Txxx) to get a list of supported formats
-
- if /usr/bin/dot -Txxx 2>&1 | grep -q png ; then
- # dot supports png
- :
- else
- die "You need to recompile media-gfx/graphviz with png support."
- fi
- fi
+DEPEND="
+ doc? (
+ app-doc/doxygen
+ >=media-gfx/graphviz-2.26
+ )" # Require recent enough graphviz wrt #181147
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --enable-release
}
src_compile() {
- econf --enable-release
-
- emake || die "emake failed"
-
- if use doc; then
- einfo "Attempting to build documentation"
- emake doc || die "Could not build documentation."
- else
- einfo "Documentation was not built"
- fi
+ emake
+ use doc && emake doc
}
-src_install () {
- emake DESTDIR="${D}" install || die
- use doc && dohtml "${S}"/doc/doxygen/html/*
- dodoc AUTHORS INSTALL README NEWS
+src_install() {
+ default
+ use doc && dohtml doc/doxygen/html/*
+ rm -f "${ED}"usr/lib*/${PN}.la
}