summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2006-03-23 17:19:24 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2006-03-23 17:19:24 +0000
commit1768d90a9d3fc0585cd885e683174ba5ec6bb912 (patch)
tree9868c0717a7abafe87263a894aa09441f4869095 /media-libs/libemf/libemf-1.0.3.ebuild
parentgames-roguelike/falconseye masked for security reasons (diff)
downloadgentoo-2-1768d90a9d3fc0585cd885e683174ba5ec6bb912.tar.gz
gentoo-2-1768d90a9d3fc0585cd885e683174ba5ec6bb912.tar.bz2
gentoo-2-1768d90a9d3fc0585cd885e683174ba5ec6bb912.zip
Looks like this version is slightly better maintained than the original dead project.
(Portage version: 2.0.54)
Diffstat (limited to 'media-libs/libemf/libemf-1.0.3.ebuild')
-rw-r--r--media-libs/libemf/libemf-1.0.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-libs/libemf/libemf-1.0.3.ebuild b/media-libs/libemf/libemf-1.0.3.ebuild
new file mode 100644
index 000000000000..cd24f903b73b
--- /dev/null
+++ b/media-libs/libemf/libemf-1.0.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libemf/libemf-1.0.3.ebuild,v 1.1 2006/03/23 17:19:24 phosphan Exp $
+
+inherit eutils
+
+MY_P="${P/emf/EMF}"
+DESCRIPTION="Library implementation of ECMA-234 API for the generation of enhanced metafiles."
+HOMEPAGE="http://libemf.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pstoedit/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ econf --enable-editing || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dohtml doc/html/*
+ dodoc README NEWS AUTHORS ChangeLog
+}