summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-07-17 16:02:12 +0000
committerChristoph Mende <angelos@gentoo.org>2011-07-17 16:02:12 +0000
commitc358ca07c1771e7d414a7428560c1f789c84475d (patch)
tree9e6c8eb930027fcd3359d26e1c803f256bb5671b /media-libs/libmpd
parentMove to global mms USE flag. (diff)
downloadgentoo-2-c358ca07c1771e7d414a7428560c1f789c84475d.tar.gz
gentoo-2-c358ca07c1771e7d414a7428560c1f789c84475d.tar.bz2
gentoo-2-c358ca07c1771e7d414a7428560c1f789c84475d.zip
Add live ebuild
(Portage version: 2.2.0_alpha45/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libmpd')
-rw-r--r--media-libs/libmpd/ChangeLog7
-rw-r--r--media-libs/libmpd/libmpd-9999.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/media-libs/libmpd/ChangeLog b/media-libs/libmpd/ChangeLog
index 5b9392527678..fe79a958a289 100644
--- a/media-libs/libmpd/ChangeLog
+++ b/media-libs/libmpd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libmpd
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpd/ChangeLog,v 1.59 2011/03/20 19:25:53 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpd/ChangeLog,v 1.60 2011/07/17 16:02:12 angelos Exp $
+
+*libmpd-9999 (17 Jul 2011)
+
+ 17 Jul 2011; Christoph Mende <angelos@gentoo.org> +libmpd-9999.ebuild:
+ Add live ebuild
20 Mar 2011; Christoph Mende <angelos@gentoo.org> libmpd-0.20.0-r1.ebuild:
Made building of static libraries optional and removed .la files
diff --git a/media-libs/libmpd/libmpd-9999.ebuild b/media-libs/libmpd/libmpd-9999.ebuild
new file mode 100644
index 000000000000..636849f559a7
--- /dev/null
+++ b/media-libs/libmpd/libmpd-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpd/libmpd-9999.ebuild,v 1.1 2011/07/17 16:02:10 angelos Exp $
+
+EAPI=4
+inherit autotools git-2
+
+DESCRIPTION="A library handling connections to a MPD server"
+HOMEPAGE="http://gmpc.wikia.com/wiki/Libmpd"
+EGIT_REPO_URI="git://git.musicpd.org/master/${PN}.git"
+EGIT_BOOTSTRAP="eautoreconf"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc static-libs"
+
+RDEPEND=">=dev-libs/glib-2.16:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+}
+
+src_compile() {
+ emake
+ use doc && emake -C doc doc
+}
+
+src_install() {
+ default
+ use doc && dohtml -r doc/html/*
+ find "${ED}" -name "*.la" -exec rm -rf {} + || die
+ rm "${ED}"/usr/share/doc/${PF}/{README,ChangeLog} || die
+}