summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-10-03 21:55:52 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-10-03 21:55:52 +0000
commitc98caff4eb3bde9b91df249b005087c57afc533a (patch)
tree803256c0a9fefdb57106f1dac66d16e9caf6f63e /media-libs/qhull
parentVersion bump (diff)
downloadgentoo-2-c98caff4eb3bde9b91df249b005087c57afc533a.tar.gz
gentoo-2-c98caff4eb3bde9b91df249b005087c57afc533a.tar.bz2
gentoo-2-c98caff4eb3bde9b91df249b005087c57afc533a.zip
Added a patch for overflows. Add a patch that allows to install everything with cmake, so install include file and libararies properly now fixing bug #338964. Added longdescription and a static-libs use flag.
(Portage version: 2.2_rc88/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/qhull')
-rw-r--r--media-libs/qhull/ChangeLog11
-rw-r--r--media-libs/qhull/files/qhull-2010.1-cmake-install.patch98
-rw-r--r--media-libs/qhull/files/qhull-2010.1-overflows.patch50
-rw-r--r--media-libs/qhull/metadata.xml12
-rw-r--r--media-libs/qhull/qhull-2010.1-r1.ebuild30
-rw-r--r--media-libs/qhull/qhull-2010.1.ebuild31
6 files changed, 200 insertions, 32 deletions
diff --git a/media-libs/qhull/ChangeLog b/media-libs/qhull/ChangeLog
index ac070c920138..bddfab9a054a 100644
--- a/media-libs/qhull/ChangeLog
+++ b/media-libs/qhull/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-libs/qhull
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/qhull/ChangeLog,v 1.36 2010/07/09 09:13:57 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/qhull/ChangeLog,v 1.37 2010/10/03 21:55:52 bicatali Exp $
+
+*qhull-2010.1-r1 (03 Oct 2010)
+
+ 03 Oct 2010; Sébastien Fabbro <bicatali@gentoo.org> -qhull-2010.1.ebuild,
+ +qhull-2010.1-r1.ebuild, +files/qhull-2010.1-cmake-install.patch,
+ +files/qhull-2010.1-overflows.patch, metadata.xml:
+ Added a patch for overflows. Add a patch that allows to install everything
+ with cmake, so install include file and libararies properly now fixing bug
+ #338964. Added longdescription and a static-libs use flag.
09 Jul 2010; Samuli Suominen <ssuominen@gentoo.org>
qhull-2003.1-r1.ebuild:
diff --git a/media-libs/qhull/files/qhull-2010.1-cmake-install.patch b/media-libs/qhull/files/qhull-2010.1-cmake-install.patch
new file mode 100644
index 000000000000..2a110a6ee7e2
--- /dev/null
+++ b/media-libs/qhull/files/qhull-2010.1-cmake-install.patch
@@ -0,0 +1,98 @@
+diff -Nur qhull-2010.1.orig/CMakeLists.txt qhull-2010.1/CMakeLists.txt
+--- qhull-2010.1.orig/CMakeLists.txt 2010-01-10 00:07:32.000000000 +0000
++++ qhull-2010.1/CMakeLists.txt 2010-10-03 22:16:50.000000000 +0100
+@@ -1,8 +1,44 @@
+ project(qhull)
+-cmake_minimum_required(VERSION 2.4)
+-if(COMMAND cmake_policy)
+- cmake_policy(SET CMP0003 NEW)
+-endif(COMMAND cmake_policy)
++cmake_minimum_required(VERSION 2.6)
++
++
++set(QHULL_VERSION "2010.1")
++
++if(INCLUDE_INSTALL_DIR)
++else()
++set(INCLUDE_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/include)
++endif()
++if(LIB_INSTALL_DIR)
++else()
++set(LIB_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/lib)
++endif()
++if(BIN_INSTALL_DIR)
++else()
++set(BIN_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/bin)
++endif()
++if(DOC_INSTALL_DIR)
++else()
++set(DOC_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/share/doc/qhull)
++endif()
++
++message(STATUS)
++message(STATUS "========== qhull Build Information ==========")
++message(STATUS "Build Version: ${QHULL_VERSION}")
++message(STATUS "Install Prefix (CMAKE_INSTALL_PREFIX): ${CMAKE_INSTALL_PREFIX}")
++message(STATUS "Binary Directory (BIN_INSTALL_DIR): ${BIN_INSTALL_DIR}")
++message(STATUS "Library Directory (LIB_INSTALL_DIR): ${LIB_INSTALL_DIR}")
++message(STATUS "Include Directory (INCLUDE_INSTALL_DIR): ${INCLUDE_INSTALL_DIR}")
++message(STATUS "Documentation Directory (DOC_INSTALL_DIR): ${DOC_INSTALL_DIR}")
++message(STATUS)
++message(STATUS "To change any of these options, override them using -D{OPTION_NAME} on the commandline.")
++message(STATUS "To build and install qhull, run \"make\" and \"make install\"")
++message(STATUS)
++
+
+ add_subdirectory(src)
++option(WITH_STATIC_LIBS "Build with a static library" OFF)
++option(WITH_DOCS "Install HTML documentation" OFF)
+
++if (WITH_DOCS)
++install(DIRECTORY html/ DESTINATION ${DOC_INSTALL_DIR})
++endif (WITH_DOCS)
+diff -Nur qhull-2010.1.orig/src/CMakeLists.txt qhull-2010.1/src/CMakeLists.txt
+--- qhull-2010.1.orig/src/CMakeLists.txt 2010-01-10 00:07:32.000000000 +0000
++++ qhull-2010.1/src/CMakeLists.txt 2010-10-03 22:21:34.000000000 +0100
+@@ -23,8 +23,25 @@
+
+ file(GLOB qhull_hdr *.h)
+
+-add_library(qhull ${qhull_src})
++add_library(qhull SHARED ${qhull_src})
+ target_link_libraries(qhull m)
++if(UNIX)
++ if(APPLE)
++ set_target_properties(qhull PROPERTIES
++ INSTALL_NAME_DIR "${LIB_INSTALL_DIR}")
++ else(APPLE)
++ set_target_properties(qhull PROPERTIES
++ INSTALL_RPATH "${LIB_INSTALL_DIR}"
++ INSTALL_RPATH_USE_LINK_PATH TRUE
++ BUILD_WITH_INSTALL_RPATH FALSE)
++ endif(APPLE)
++endif(UNIX)
++
++if(WITH_STATIC_LIBS)
++ add_library(qhullstatic STATIC ${qhull_src})
++ set_property(TARGET qhullstatic PROPERTY OUTPUT_NAME "qhull")
++ install(TARGETS qhullstatic ARCHIVE DESTINATION ${LIB_INSTALL_DIR})
++endif(WITH_STATIC_LIBS)
+
+ set(qhullcmd_SOURCES unix.c)
+ set(rbox_SOURCES rbox.c)
+@@ -36,6 +53,7 @@
+
+ add_executable(qhullcmd ${qhullcmd_SOURCES})
+ target_link_libraries(qhullcmd qhull)
++set_property(TARGET qhullcmd PROPERTY OUTPUT_NAME "qhull")
+
+ add_executable(rbox ${rbox_SOURCES})
+ target_link_libraries(rbox qhull)
+@@ -52,3 +70,7 @@
+ add_executable(qhalf ${qhalf_SOURCES})
+ target_link_libraries(qhalf qhull)
+
++install(TARGETS qhull qhullcmd rbox qconvex qdelaunay qvoronoi qhalf
++ RUNTIME DESTINATION ${BIN_INSTALL_DIR}
++ LIBRARY DESTINATION ${LIB_INSTALL_DIR})
++install(FILES libqhull.h DESTINATION ${INCLUDE_INSTALL_DIR})
diff --git a/media-libs/qhull/files/qhull-2010.1-overflows.patch b/media-libs/qhull/files/qhull-2010.1-overflows.patch
new file mode 100644
index 000000000000..df4aa3da19c7
--- /dev/null
+++ b/media-libs/qhull/files/qhull-2010.1-overflows.patch
@@ -0,0 +1,50 @@
+From 176c01851026125f574a8223ad49ec58b2b58ec0 Mon Sep 17 00:00:00 2001
+From: Johannes Obermayr <johannesobermayr@gmx.de>
+Date: Fri, 23 Jul 2010 20:02:19 +0200
+Subject: [PATCH] Fix some serious compiler warnings causing build breakage on openSUSE.
+
+---
+ src/global.c | 2 +-
+ src/rboxlib.c | 6 +++---
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/src/global.c b/src/global.c
+index 3c6141a..4c9f56c 100644
+--- a/src/global.c
++++ b/src/global.c
+@@ -614,7 +614,7 @@ void qh_initflags(char *command) {
+ if (command <= &qh qhull_command[0] || command > &qh qhull_command[0] + sizeof(qh qhull_command)) {
+ if (command != &qh qhull_command[0]) {
+ *qh qhull_command= '\0';
+- strncat( qh qhull_command, command, sizeof( qh qhull_command));
++ strncat(qh qhull_command, command, sizeof(qh qhull_command)-strlen(qh qhull_command)-1);
+ }
+ while (*s && !isspace(*s)) /* skip program name */
+ s++;
+diff --git a/src/rboxlib.c b/src/rboxlib.c
+index 4f11d22..17d01ac 100644
+--- a/src/rboxlib.c
++++ b/src/rboxlib.c
+@@ -124,7 +124,7 @@ int qh_rboxpoints(FILE* fout, FILE* ferr, char* rbox_command) {
+ }
+
+ *command= '\0';
+- strncat(command, rbox_command, sizeof(command));
++ strncat(command, rbox_command, sizeof(command)-strlen(command)-1);
+
+ while (*s && !isspace(*s)) /* skip program name */
+ s++;
+@@ -346,8 +346,8 @@ int qh_rboxpoints(FILE* fout, FILE* ferr, char* rbox_command) {
+ }
+ }else if (israndom) {
+ seed= (int)time(&timedata);
+- sprintf(seedbuf, " t%d", seed); /* appends an extra t, not worth removing */
+- strncat(command, seedbuf, sizeof(command));
++ printf(seedbuf, " t%d", seed); /* appends an extra t, not worth removing */
++ strncat(command, seedbuf, sizeof(command)-strlen(command)-1);
+ t= strstr(command, " t ");
+ if (t)
+ strcpy(t+1, t+3); /* remove " t " */
+--
+1.6.1
+
diff --git a/media-libs/qhull/metadata.xml b/media-libs/qhull/metadata.xml
index 5a2f1c7b832e..31adf701f53b 100644
--- a/media-libs/qhull/metadata.xml
+++ b/media-libs/qhull/metadata.xml
@@ -2,4 +2,16 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>sci-mathematics</herd>
+<longdescription lang='en'>
+ Qhull computes the convex hull, Delaunay triangulation, Voronoi
+ diagram, halfspace intersection about a point, furthest-site
+ Delaunay triangulation, and furthest-site Voronoi diagram. The
+ source code runs in 2-d, 3-d, 4-d, and higher dimensions. Qhull
+ implements the Quickhull algorithm for computing the convex hull. It
+ handles roundoff errors from floating point arithmetic. It computes
+ volumes, surface areas, and approximations to the convex hull.
+ Qhull does not support constrained Delaunay triangulations,
+ triangulation of non-convex surfaces, mesh generation of non-convex
+ objects, or medium-sized inputs in 9-D and higher.
+</longdescription>
</pkgmetadata>
diff --git a/media-libs/qhull/qhull-2010.1-r1.ebuild b/media-libs/qhull/qhull-2010.1-r1.ebuild
new file mode 100644
index 000000000000..0c5636f42871
--- /dev/null
+++ b/media-libs/qhull/qhull-2010.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/qhull/qhull-2010.1-r1.ebuild,v 1.1 2010/10/03 21:55:52 bicatali Exp $
+
+EAPI=3
+
+inherit cmake-utils flag-o-matic
+
+MY_P="${PN}${PV}"
+DESCRIPTION="Geometry library"
+HOMEPAGE="http://www.qhull.org"
+SRC_URI="${HOMEPAGE}/download/${P}-src.tgz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc static-libs"
+
+DOCS="Announce.txt File_id.diz README.txt REGISTER.txt"
+PATCHES=( "${FILESDIR}/${P}-cmake-install.patch" "${FILESDIR}/${P}-overflows.patch" )
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+ mycmakeargs="
+ -DLIB_INSTALL_DIR=${EPREFIX}/usr/$(get_libdir)
+ -DDOC_INSTALL_DIR=${EPREFIX}/usr/share/doc/${PF}
+ $(cmake-utils_use_with static-libs STATIC_LIBS)
+ $(cmake-utils_use_with doc DOCS)"
+ cmake-utils_src_configure
+}
diff --git a/media-libs/qhull/qhull-2010.1.ebuild b/media-libs/qhull/qhull-2010.1.ebuild
deleted file mode 100644
index 68d46c57ff1c..000000000000
--- a/media-libs/qhull/qhull-2010.1.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/qhull/qhull-2010.1.ebuild,v 1.1 2010/05/22 09:43:00 jlec Exp $
-
-EAPI=2
-
-inherit cmake-utils eutils flag-o-matic
-
-MY_P="${PN}${PV}"
-DESCRIPTION="Geometry library"
-HOMEPAGE="http://www.qhull.org"
-SRC_URI="${HOMEPAGE}/download/${P}-src.tgz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="doc"
-
-pkg_setup() {
- append-flags -fno-strict-aliasing
-}
-
-src_install() {
- dobin "${S}"_build/src/{q*,rbox} || die
-
- dodoc Announce.txt File_id.diz README.txt REGISTER.txt || die
-
- if use doc; then
- dohtml -r index.htm html || die
- fi
-}