summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando Serboncini <fserb@gentoo.org>2005-01-25 13:31:43 +0000
committerFernando Serboncini <fserb@gentoo.org>2005-01-25 13:31:43 +0000
commitaec4513b7b6c693565c9f20aab18ba1d4132d1f6 (patch)
treefff4a8bbb5b58875f609c87cdccfec473fab008f /media-libs/tunepimp
parentVersion bump (diff)
downloadgentoo-2-aec4513b7b6c693565c9f20aab18ba1d4132d1f6.tar.gz
gentoo-2-aec4513b7b6c693565c9f20aab18ba1d4132d1f6.tar.bz2
gentoo-2-aec4513b7b6c693565c9f20aab18ba1d4132d1f6.zip
media-libs/tunepimp added perl and python bindings
(Portage version: 2.0.51-r14)
Diffstat (limited to 'media-libs/tunepimp')
-rw-r--r--media-libs/tunepimp/ChangeLog7
-rw-r--r--media-libs/tunepimp/Manifest12
-rw-r--r--media-libs/tunepimp/tunepimp-0.3.0.ebuild23
3 files changed, 26 insertions, 16 deletions
diff --git a/media-libs/tunepimp/ChangeLog b/media-libs/tunepimp/ChangeLog
index 0071b19d937c..0b4509e87db0 100644
--- a/media-libs/tunepimp/ChangeLog
+++ b/media-libs/tunepimp/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-libs/tunepimp
-# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/tunepimp/ChangeLog,v 1.13 2004/12/18 22:26:04 corsair Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tunepimp/ChangeLog,v 1.14 2005/01/25 13:31:43 fserb Exp $
+
+ 25 Jan 2005; Fernando Serboncini <fserb@gentoo.org> tunepimp-0.3.0.ebuild:
+ Added python and perl bindings
18 Dec 2004; Markus Rothe <corsair@gentoo.org> tunepimp-0.3.0.ebuild:
Stable on ppc64
diff --git a/media-libs/tunepimp/Manifest b/media-libs/tunepimp/Manifest
index 20f5d17b208a..7a2185b6ff44 100644
--- a/media-libs/tunepimp/Manifest
+++ b/media-libs/tunepimp/Manifest
@@ -1,15 +1,5 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 c84d85cda204ab02261e1e71d2211f44 ChangeLog 1530
MD5 1b6808bbd78c9161f8b7efb090d966f8 metadata.xml 162
-MD5 fcb49f4cb9c4e408ffbc0da4dde66d6a tunepimp-0.3.0.ebuild 1059
+MD5 972b20e0418a090f17ea7819b4be0143 tunepimp-0.3.0.ebuild 1522
MD5 f79074eba8191dbaded3e898a9e6faf9 files/digest-tunepimp-0.3.0 69
MD5 9df04c3c157b652e3e895eeabb7015e6 files/thread.patch 393
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.14 (GNU/Linux)
-
-iD8DBQFB9ZtaroRuSHgZdywRAvtTAJ9hEPNoYth77JaJh7hvjOCqqJIUbwCfcgAO
-1MmJ+Nu7N3bDxIGzfGboMFM=
-=IUfA
------END PGP SIGNATURE-----
diff --git a/media-libs/tunepimp/tunepimp-0.3.0.ebuild b/media-libs/tunepimp/tunepimp-0.3.0.ebuild
index 44f83cff3d5c..460a836f8d5a 100644
--- a/media-libs/tunepimp/tunepimp-0.3.0.ebuild
+++ b/media-libs/tunepimp/tunepimp-0.3.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/tunepimp/tunepimp-0.3.0.ebuild,v 1.19 2005/01/25 01:04:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tunepimp/tunepimp-0.3.0.ebuild,v 1.20 2005/01/25 13:31:43 fserb Exp $
-inherit eutils
+inherit eutils distutils perl-module
DESCRIPTION="Client library to create MusicBrainz enabled tagging applications"
HOMEPAGE="http://www.musicbrainz.org/products/tunepimp"
@@ -11,7 +11,7 @@ SRC_URI="http://ftp.musicbrainz.org/pub/musicbrainz/lib${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
-IUSE="flac mad oggvorbis readline"
+IUSE="flac mad oggvorbis readline python perl"
RDEPEND="dev-libs/expat"
DEPEND="${RDEPEND}
@@ -29,10 +29,27 @@ src_compile() {
epatch ${FILESDIR}/thread.patch
econf || die "configure failed"
emake || die "emake failed"
+ if use perl; then
+ cd ${S}/perl/tunepimp-perl
+ perl-module_src_compile || die "perl module failed to compile"
+ fi
}
src_install() {
+ cd ${S}
make DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS ChangeLog INSTALL README TODO
+ if use python; then
+ cd ${S}/python
+ distutils_src_install
+ insinto /usr/share/doc/${PF}/examples/
+ doins examples/*
+ fi
+ if use perl; then
+ cd ${S}/perl/tunepimp-perl
+ perl-module_src_install || die "perl module failed to install"
+ insinto /usr/share/doc/${PF}/examples/
+ doins examples/*
+ fi
}