summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-06-20 21:10:59 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-06-20 21:10:59 +0000
commit7d73e57125626e8adb3db100199554e41e294425 (patch)
tree94ab0de0b191ebc13ebadf9f62f74fd64f855517 /media-libs/xine-lib
parentUpdated commend for xine d4d and d5d plugins. (diff)
downloadgentoo-2-7d73e57125626e8adb3db100199554e41e294425.tar.gz
gentoo-2-7d73e57125626e8adb3db100199554e41e294425.tar.bz2
gentoo-2-7d73e57125626e8adb3db100199554e41e294425.zip
Updated to 0.9.11.
Diffstat (limited to 'media-libs/xine-lib')
-rw-r--r--media-libs/xine-lib/ChangeLog8
-rw-r--r--media-libs/xine-lib/files/digest-xine-lib-0.9.111
-rw-r--r--media-libs/xine-lib/files/xineconfig.patch-0.9.1111
-rw-r--r--media-libs/xine-lib/xine-lib-0.9.11.ebuild100
4 files changed, 119 insertions, 1 deletions
diff --git a/media-libs/xine-lib/ChangeLog b/media-libs/xine-lib/ChangeLog
index 23bca5356e2e..7ec01c4e9f74 100644
--- a/media-libs/xine-lib/ChangeLog
+++ b/media-libs/xine-lib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/xine-lib
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.9 2002/06/16 19:22:15 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.10 2002/06/20 21:10:59 agenkin Exp $
+
+*xine-lib-0.9.11 (20 Jun 2002)
+
+ 20 Jun 2002; Arcady Genkin <agenkin@thpoon.com> xine-lib-0.9.10.ebuld :
+
+ Update to version 0.9.11.
*xine-lib-0.9.10-r1 (16 Jun 2002)
diff --git a/media-libs/xine-lib/files/digest-xine-lib-0.9.11 b/media-libs/xine-lib/files/digest-xine-lib-0.9.11
new file mode 100644
index 000000000000..8cdfb3e3c53b
--- /dev/null
+++ b/media-libs/xine-lib/files/digest-xine-lib-0.9.11
@@ -0,0 +1 @@
+MD5 152eb07b12c4ad969f788586fe22374a xine-lib-0.9.11.tar.gz 2386034
diff --git a/media-libs/xine-lib/files/xineconfig.patch-0.9.11 b/media-libs/xine-lib/files/xineconfig.patch-0.9.11
new file mode 100644
index 000000000000..d8b99700bebc
--- /dev/null
+++ b/media-libs/xine-lib/files/xineconfig.patch-0.9.11
@@ -0,0 +1,11 @@
+--- configure.orig Thu Jun 20 16:54:36 2002
++++ configure Thu Jun 20 16:55:03 2002
+@@ -13350,7 +13350,7 @@
+
+
+
+-INCLUDES='-I$(top_srcdir) -I$(top_builddir) -I$(top_srcdir)/src -I$(top_builddir)/src -I$(top_srcdir)/src/xine-engine -I$(top_builddir)/src/xine-engine -I$(top_srcdir)/src/xine-utils -I$(top_builddir)/src/xine-utils $(INTLDIR)'
++INCLUDES='-I/usr/include/directfb -I$(top_srcdir) -I$(top_builddir) -I$(top_srcdir)/src -I$(top_builddir)/src -I$(top_srcdir)/src/xine-engine -I$(top_builddir)/src/xine-engine -I$(top_srcdir)/src/xine-utils -I$(top_builddir)/src/xine-utils $(INTLDIR)'
+
+
+
diff --git a/media-libs/xine-lib/xine-lib-0.9.11.ebuild b/media-libs/xine-lib/xine-lib-0.9.11.ebuild
new file mode 100644
index 000000000000..26709fd49c94
--- /dev/null
+++ b/media-libs/xine-lib/xine-lib-0.9.11.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-0.9.11.ebuild,v 1.1 2002/06/20 21:10:59 agenkin Exp $
+
+DESCRIPTION="Xine is a free gpl-licensed video player for unix-like systems"
+HOMEPAGE="http://xine.sourceforge.net/"
+LICENSE="GPL"
+
+DEPEND="X? ( virtual/x11 )
+ avi? ( >=media-libs/win32codecs-0.50
+ media-libs/divx4linux )
+ esd? ( media-sound/esound )
+ dvd? ( >=media-libs/libdvdcss-0.0.3.3
+ >=media-libs/libdvdread-0.9.2 )
+ arts? ( kde-base/kdelibs )
+ alsa? ( media-libs/alsa-lib )
+ aalib? ( media-libs/aalib )
+ oggvorbis? ( media-libs/libvorbis )"
+RDEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )"
+
+SRC_URI="http://xine.sourceforge.net/files/${P}.tar.gz"
+SLOT="0"
+S=${WORKDIR}/${P}
+
+src_unpack() {
+
+ unpack ${P}.tar.gz
+ cd ${S}
+ # Patch for framebuffer support.
+ patch -p0 < ${FILESDIR}/xineconfig.patch-${PV} || die
+
+}
+
+src_compile() {
+
+ libtoolize --copy --force
+
+ # Most of these are not working currently, but are here for completeness
+ local myconf
+ use X || myconf="${myconf} --disable-x11 --disable-xv"
+ use esd || myconf="${myconf} --disable-esd --disable-esdtest"
+ use nls || myconf="${myconf} --disable-nls"
+ use alsa || myconf="${myconf} --disable-alsa --disable-alsatest"
+ use arts || myconf="${myconf} --disable-arts --disable-artstest"
+ # This breaks because with the test disabled, it defaults to "found" check with
+ # the next release until then let it autodetect. See bug #2377.
+ # use aalib || myconf="${myconf} --disable-aalib --disable-aalibtest"
+
+ use oggvorbis || myconf="${myconf}
+ --disable-ogg
+ --disable-oggtest
+ --disable-vorbis
+ --disable-vorbistest"
+
+ use avi && myconf="${myconf}
+ --with-w32-path=/usr/lib/win32" \
+ || myconf="${myconf}
+ --disable-asf"
+
+ # This is ``fixes'' compilation problems when em8300 libs installed
+ # The proper fix is to follow.
+ # myconf="${myconf} --disable-dxr3 --disable-dxr3test"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ docdir=${D}/usr/share/doc/${PF}/html \
+ sysconfdir=${D}/etc \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL README TODO
+ cd ${S}/doc
+ dodoc dataflow.dia README*
+
+}
+
+pkg_postinst() {
+
+ einfo
+ einfo "Please note, a new version of xine-lib has been installed,"
+ einfo "for library consistency you need to unmerge old versions"
+ einfo "of xine-lib before merging xine-ui."
+ einfo "Please also note that xine-d4d and xine-d5d plugins are"
+ einfo "not yet compatible with this new library."
+ einfo
+
+}