summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-05-15 15:28:55 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-05-15 15:28:55 +0000
commit47ba13b98367d9ded7a1a99a7e93a7a742c08041 (patch)
treea5e90d15041621854e501e34b4bd00f27d831904 /media-libs
parent+ slashless path patch (diff)
downloadgentoo-2-47ba13b98367d9ded7a1a99a7e93a7a742c08041.tar.gz
gentoo-2-47ba13b98367d9ded7a1a99a7e93a7a742c08041.tar.bz2
gentoo-2-47ba13b98367d9ded7a1a99a7e93a7a742c08041.zip
Cleanup of ebuild: using $() syntax for command expansion; better check for gcc 3.4 or better (consider gcc 4).
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/xine-lib/ChangeLog7
-rw-r--r--media-libs/xine-lib/xine-lib-1.0.1-r1.ebuild26
2 files changed, 17 insertions, 16 deletions
diff --git a/media-libs/xine-lib/ChangeLog b/media-libs/xine-lib/ChangeLog
index 9742d7f428a0..220da9093243 100644
--- a/media-libs/xine-lib/ChangeLog
+++ b/media-libs/xine-lib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/xine-lib
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.224 2005/05/15 02:03:46 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.225 2005/05/15 15:28:54 flameeyes Exp $
+
+ 15 May 2005; Diego Pettenò <flameeyes@gentoo.org>
+ xine-lib-1.0.1-r1.ebuild:
+ Cleanup of ebuild: using $() syntax for command expansion; better check for
+ gcc 3.4 or better (consider gcc 4).
15 May 2005; Diego Pettenò <flameeyes@gentoo.org>
xine-lib-1_rc6-r2.ebuild, xine-lib-1_rc8-r1.ebuild,
diff --git a/media-libs/xine-lib/xine-lib-1.0.1-r1.ebuild b/media-libs/xine-lib/xine-lib-1.0.1-r1.ebuild
index 7373959d51d2..e0a08305e31e 100644
--- a/media-libs/xine-lib/xine-lib-1.0.1-r1.ebuild
+++ b/media-libs/xine-lib/xine-lib-1.0.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1.0.1-r1.ebuild,v 1.5 2005/05/15 02:03:46 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1.0.1-r1.ebuild,v 1.6 2005/05/15 15:28:55 flameeyes Exp $
inherit eutils flag-o-matic toolchain-funcs libtool
@@ -45,6 +45,7 @@ RDEPEND="vorbis? ( media-libs/libvorbis )
vcd? ( media-video/vcdimager )
ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20050226-r1 )
!=media-libs/xine-lib-0.9.13*"
+
DEPEND="${RDEPEND}
v4l? ( sys-kernel/linux-headers )
>=sys-devel/automake-1.7
@@ -77,7 +78,6 @@ src_unpack() {
}
src_compile() {
-
#filter dangerous compile CFLAGS
strip-flags
@@ -86,20 +86,19 @@ src_compile() {
use x86 && has_pic && append-flags -UHAVE_MMX
- if [ "`gcc-major-version`" -ge "3" -a "`gcc-minor-version`" -ge "4" ]; then
- append-flags -fno-web #49509
+ if [ "$(gcc-major-version)" -eq "3" -a "$(gcc-minor-version)" -ge "4" ] || \
+ [ "$(gcc-major-version)" -ge "4" ]; then
+ # bugs 49509 and 55202
+ append-flags -fno-web -funit-at-a-time
filter-flags -fno-unit-at-a-time #55202
- append-flags -funit-at-a-time #55202
fi
is-flag -O? || append-flags -O1 #31243
# fix build errors with sse2 #49482
- if use x86 ; then
- if [ `gcc-major-version` -eq 3 ] ; then
- append-flags -mno-sse2 `test_flag -mno-sse3`
- filter-mfpmath sse
- fi
+ if use x86 && [ $(gcc-major-version) -ge 3 ]; then
+ append-flags -mno-sse2 $(test_flag -mno-sse3)
+ filter-mfpmath sse
fi
local myconf
@@ -109,9 +108,6 @@ src_compile() {
&& myconf="${myconf} --with-w32-path=/usr/$(get_libdir)/win32" \
|| myconf="${myconf} --disable-asf"
- use sparc \
- && myconf="${myconf} --build=${CHOST}"
-
# enable/disable appropiate optimizations on sparc
[ "${PROFILE_ARCH}" == "sparc64" ] \
&& myconf="${myconf} --enable-vis"
@@ -121,11 +117,11 @@ src_compile() {
# Fix compilation-errors on PowerPC #45393 & #55460 & #68251
if use ppc || use ppc64 ; then
append-flags -U__ALTIVEC__
- myconf="${myconf} `use_enable altivec`"
+ myconf="${myconf} $(use_enable altivec)"
fi
# The default CFLAGS (-O) is the only thing working on hppa.
- if use hppa && [ "`gcc-version`" != "3.4" ] ; then
+ if use hppa; then
unset CFLAGS
else
append-flags -ffunction-sections